aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-01-27 01:57:01 +0800
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-01-27 01:57:01 +0800
commit6b5eb98e6db4f293f80720be3673fd681824caa3 (patch)
treeaa646ffb24932ade6d8738bef409d890fb28e70f /audio
parent401bffd6dce248205d095bcd3607492ce1e696c0 (diff)
downloadfreebsd-ports-gnome-6b5eb98e6db4f293f80720be3673fd681824caa3.tar.gz
freebsd-ports-gnome-6b5eb98e6db4f293f80720be3673fd681824caa3.tar.zst
freebsd-ports-gnome-6b5eb98e6db4f293f80720be3673fd681824caa3.zip
Unbreak the build on 9.X (against old yacc(1) which apparently does not
support %token_table declaration). Originally the port was relying on bison(1) instead (via USES=bison) in yacc-compat mode, but was switched to yacc(1) in r389653 because it failed to build against `devel/bison' version update to 3.0.4 as part of an exp-run (see PR). It turns out that actually generated code does not suffer from removing %token_table: the only difference in generated `neural_parse.cc' is that yyname[] table is not guarded by `#if YYDEBUG' and it #define's yytname as yyname, but the code that references yytname in `neural_parse.cc' is #if'ed 0 and YYDEBUG is defined to 1 earlier. That said, simply comment out %token_table line which allows the build to proceed (ir)regardless of the yacc(1) version, on all FreeBSD releases (including 8.X). While here, remove `ac_cv_lib_stdcpp_main=no' in CONFIGURE_ENV that was supposed to fix the build against Clang added in r323095 as it seems no longer required, augment COMMENT and port description, and fix WWW line to point to working website, killing trailing whitespace along the way. PR: 200833
Diffstat (limited to 'audio')
-rw-r--r--audio/epos-devel/Makefile6
-rw-r--r--audio/epos-devel/files/patch-src__nnet__neural_parse.yy11
-rw-r--r--audio/epos-devel/pkg-descr20
3 files changed, 26 insertions, 11 deletions
diff --git a/audio/epos-devel/Makefile b/audio/epos-devel/Makefile
index c1a7e15a21b2..61fe305ead30 100644
--- a/audio/epos-devel/Makefile
+++ b/audio/epos-devel/Makefile
@@ -8,16 +8,14 @@ CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-dev/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Text-to-Speech system
+COMMENT= Language independent Text-to-Speech (TTS) system
LICENSE= GPLv2 LGPL20
LICENSE_COMB= multi
-BROKEN_FreeBSD_9= does not build on FreeBSD < 10.x
-
USES= gmake
GNU_CONFIGURE= yes
-CONFIGURE_ENV= ac_cv_lib_stdcpp_main=no YACC=${YACC}
+CONFIGURE_ENV= YACC="${YACC}"
post-patch:
@${REINPLACE_CMD} -e 's/^\(SUBDIRS =.*\)doc/\1/' ${WRKSRC}/Makefile.in
diff --git a/audio/epos-devel/files/patch-src__nnet__neural_parse.yy b/audio/epos-devel/files/patch-src__nnet__neural_parse.yy
index e7f49d56490e..6aa31356965e 100644
--- a/audio/epos-devel/files/patch-src__nnet__neural_parse.yy
+++ b/audio/epos-devel/files/patch-src__nnet__neural_parse.yy
@@ -1,6 +1,15 @@
--- src/nnet/neural_parse.yy.orig
+++ src/nnet/neural_parse.yy
-@@ -255,7 +255,7 @@
+@@ -104,7 +104,7 @@ make_tree (TTypedValue val = TTypedValue
+ /* SYMBOLS */
+ /* * * * * * * * * * * * * * * * * * * * * * * * * * */
+
+-%token_table
++//%token_table -- unsupported by the base yacc(1) on some FreeBSD versions
+ //%raw bison nefunguje s raw! (aspon yylex ne)
+
+ %union {
+@@ -255,7 +255,7 @@ unit_level: string_exp
int yyerror (char *s)
{
diff --git a/audio/epos-devel/pkg-descr b/audio/epos-devel/pkg-descr
index 8716d97424d2..3155a97c4f0f 100644
--- a/audio/epos-devel/pkg-descr
+++ b/audio/epos-devel/pkg-descr
@@ -1,8 +1,16 @@
-Epos is a language independent rule-driven Text-to-Speech (TTS) system
-primarily designed to serve as a research tool. Epos is (or tries to be)
-independent of the language processed, linguistic description method,
-and computing environment.
+Epos is a language independent rule-driven Text-to-Speech (TTS) system
+primarily designed to serve as a research tool. Epos is (or tries to be)
+independent of the language processed, linguistic description method, and
+computing environment. It has the following features:
-This port is built from the development branch of Epos.
+ - Czech and Slovak text to speech synthesis configuration
+ - LPC and time domain speech synthesizers
+ - Prosody modelling driven by rules, prosody models, and artificial
+ neural networks
+ - All language dependencies are defined in the configuration files,
+ as opposed to the source code
+ - Documentation in English included in the distribution
-WWW: http://epos.ure.cas.cz/
+This is a port for the development version of Epos.
+
+WWW: http://epos.ufe.cz/