aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorsbruno <sbruno@FreeBSD.org>2014-05-27 02:18:09 +0800
committersbruno <sbruno@FreeBSD.org>2014-05-27 02:18:09 +0800
commit707030cca7f82e3e97669bf31f25d02013da4285 (patch)
treeda16d5a1681932ebb540bebcfd33c2c7c9efc95f /audio
parentc82d01d449944f5276146a347d4c75b8c3979b43 (diff)
downloadfreebsd-ports-gnome-707030cca7f82e3e97669bf31f25d02013da4285.tar.gz
freebsd-ports-gnome-707030cca7f82e3e97669bf31f25d02013da4285.tar.zst
freebsd-ports-gnome-707030cca7f82e3e97669bf31f25d02013da4285.zip
Update clementine-player to 1.2.3
- Move distfile location to GitHub - Remove three uneeded patches accepted upstream - Add one new patch for <functional> support - Add new dependency on libechonest From Changelog: Version 1.2.3: Bugfixes: * Fix compilation with GCC 4.9. * (Linux) Fix poor search performance with sqlite 3.8. * (Ubuntu) Fix dependency issues on Ubuntu 14.04. * (Windows) Upgrade to OpenSSL 1.0.1g to fix CVE-2014-0160. Version 1.2.2: Major features: * (Android Remote) Add kittens support. Bugfixes: * Rename SkyDrive to OneDrive. * Don't include the user's IP address in the log (from the network remote settings dialog). * (Debian) Fix a bug with HTTPS logins to all cloud storage providers. * (Mac OS X) Fix a bug in the workaround for a weird font issue on 10.9. * (Mac OS X) Fix rendering of source icons on retina displays. * (Android Remote) Don't advertise songs that aren't available. * (Android Remote) Fix playing songs with special characters in filenames. Reviewed by: mat@
Diffstat (limited to 'audio')
-rw-r--r--audio/clementine-player/Makefile13
-rw-r--r--audio/clementine-player/distinfo4
-rw-r--r--audio/clementine-player/files/patch-ext__libclementine-common__core__closure.cpp20
-rw-r--r--audio/clementine-player/files/patch-ext__libclementine-common__core__closure.h42
-rw-r--r--audio/clementine-player/files/patch-src__library_groupbydialog.h11
-rw-r--r--audio/clementine-player/files/patch-src__playlistparsers__plsparser.cpp11
6 files changed, 22 insertions, 79 deletions
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index 4aeed004e9a8..04ed065afed6 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -2,12 +2,16 @@
# $FreeBSD$
PORTNAME= clementine
-PORTVERSION= 1.2.1
-PORTREVISION= 7
+PORTVERSION= 1.2.3
CATEGORIES= audio
-MASTER_SITES= GOOGLE_CODE
PKGNAMESUFFIX= -player
+USE_GITHUB= yes
+GH_ACCOUNT= ${PORTNAME}${PKGNAMESUFFIX}
+GH_PROJECT= Clementine
+GH_TAGNAME= ${PORTVERSION}
+GH_COMMIT= c189ee5
+
MAINTAINER= sbruno@FreeBSD.org
COMMENT= Cross-platform music player based on Amarok 1.4
@@ -19,7 +23,8 @@ LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
libprotobuf.so:${PORTSDIR}/devel/protobuf \
libqca.so:${PORTSDIR}/devel/qca \
libqjson.so:${PORTSDIR}/devel/qjson \
- libfftw3.so:${PORTSDIR}/math/fftw3
+ libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libechonest.so:${PORTSDIR}/audio/libechonest
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
diff --git a/audio/clementine-player/distinfo b/audio/clementine-player/distinfo
index 6194b421964b..3648e87e16a8 100644
--- a/audio/clementine-player/distinfo
+++ b/audio/clementine-player/distinfo
@@ -1,2 +1,2 @@
-SHA256 (clementine-1.2.1.tar.gz) = db556e8bf230e2535636f5736a62ffe24ce154481fb05123e8395ab4aa64654e
-SIZE (clementine-1.2.1.tar.gz) = 9274351
+SHA256 (clementine-1.2.3.tar.gz) = b7e4813b54f2cb586e80c27945240c11d884082459248e87b7359689a0f0dffb
+SIZE (clementine-1.2.3.tar.gz) = 9075813
diff --git a/audio/clementine-player/files/patch-ext__libclementine-common__core__closure.cpp b/audio/clementine-player/files/patch-ext__libclementine-common__core__closure.cpp
deleted file mode 100644
index b3395fe659c2..000000000000
--- a/audio/clementine-player/files/patch-ext__libclementine-common__core__closure.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./ext/libclementine-common/core/closure.cpp.orig 2013-11-24 15:58:51.321696435 -0800
-+++ ./ext/libclementine-common/core/closure.cpp 2013-11-24 15:59:00.552695416 -0800
-@@ -33,7 +33,7 @@
- CallbackClosure::CallbackClosure(
- QObject* sender,
- const char* signal,
-- std::tr1::function<void()> callback)
-+ std::function<void()> callback)
- : ClosureBase(new ObjectHelper(sender, signal, this)),
- callback_(callback) {
- }
-@@ -67,7 +67,7 @@
- _detail::ClosureBase* NewClosure(
- QObject* sender,
- const char* signal,
-- std::tr1::function<void()> callback) {
-+ std::function<void()> callback) {
- return new _detail::CallbackClosure(
- sender, signal, callback);
- }
diff --git a/audio/clementine-player/files/patch-ext__libclementine-common__core__closure.h b/audio/clementine-player/files/patch-ext__libclementine-common__core__closure.h
deleted file mode 100644
index b5c1e8b853a7..000000000000
--- a/audio/clementine-player/files/patch-ext__libclementine-common__core__closure.h
+++ /dev/null
@@ -1,42 +0,0 @@
---- ./ext/libclementine-common/core/closure.h.orig 2013-11-24 15:58:19.241698287 -0800
-+++ ./ext/libclementine-common/core/closure.h 2013-11-24 15:58:38.634697259 -0800
-@@ -18,7 +18,7 @@
- #ifndef CLOSURE_H
- #define CLOSURE_H
-
--#include <tr1/functional>
-+#include <functional>
-
- #include <QMetaMethod>
- #include <QObject>
-@@ -158,12 +158,12 @@
- CallbackClosure(
- QObject* sender,
- const char* signal,
-- std::tr1::function<void()> callback);
-+ std::function<void()> callback);
-
- virtual void Invoke();
-
- private:
-- std::tr1::function<void()> callback_;
-+ std::function<void()> callback_;
- };
-
- } // namespace _detail
-@@ -194,13 +194,13 @@
- _detail::ClosureBase* NewClosure(
- QObject* sender,
- const char* signal,
-- std::tr1::function<void()> callback);
-+ std::function<void()> callback);
-
- template <typename... Args>
- _detail::ClosureBase* NewClosure(
- QObject* sender,
- const char* signal,
-- std::tr1::function<void(Args...)> callback,
-+ std::function<void(Args...)> callback,
- const Args&... args) {
- return NewClosure(sender, signal, boost::bind(callback, args...));
- }
diff --git a/audio/clementine-player/files/patch-src__library_groupbydialog.h b/audio/clementine-player/files/patch-src__library_groupbydialog.h
new file mode 100644
index 000000000000..ecdacf2e4e65
--- /dev/null
+++ b/audio/clementine-player/files/patch-src__library_groupbydialog.h
@@ -0,0 +1,11 @@
+--- ./src/library/groupbydialog.h.orig 2014-05-25 10:38:37.378768447 -0700
++++ ./src/library/groupbydialog.h 2014-05-25 10:39:12.641759778 -0700
+@@ -22,6 +22,8 @@
+
+ #include <memory>
+
++#include <functional>
++
+ using std::placeholders::_1;
+ using std::placeholders::_2;
+
diff --git a/audio/clementine-player/files/patch-src__playlistparsers__plsparser.cpp b/audio/clementine-player/files/patch-src__playlistparsers__plsparser.cpp
deleted file mode 100644
index f93bd7e0131c..000000000000
--- a/audio/clementine-player/files/patch-src__playlistparsers__plsparser.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/playlistparsers/plsparser.cpp.orig 2013-11-24 16:01:13.247686715 -0800
-+++ ./src/playlistparsers/plsparser.cpp 2013-11-24 16:03:24.812677689 -0800
-@@ -46,7 +46,7 @@
- // Use the title and length we've already loaded if any
- if (!songs[n].title().isEmpty())
- song.set_title(songs[n].title());
-- if (!songs[n].length_nanosec() != -1)
-+ if (songs[n].length_nanosec() != -1)
- song.set_length_nanosec(songs[n].length_nanosec());
-
- songs[n] = song;