aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-14 03:53:18 +0800
committertijl <tijl@FreeBSD.org>2014-09-14 03:53:18 +0800
commit70c44b2eead6d8fbcf18a54dbb139487f231d4b7 (patch)
treecf54ae521d0e649a8743691f579a55c9d734fefa /audio
parent31b52adaabc0714e52a49d3efc683937509646ee (diff)
downloadfreebsd-ports-gnome-70c44b2eead6d8fbcf18a54dbb139487f231d4b7.tar.gz
freebsd-ports-gnome-70c44b2eead6d8fbcf18a54dbb139487f231d4b7.tar.zst
freebsd-ports-gnome-70c44b2eead6d8fbcf18a54dbb139487f231d4b7.zip
- Remove unused LIBTOOLFLAGS
- Replace some LIB_DEPENDS with USE_GNOME components - Replace CONFIGURE_ENV about missing link with post-patch command
Diffstat (limited to 'audio')
-rw-r--r--audio/gnomoradio/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/audio/gnomoradio/Makefile b/audio/gnomoradio/Makefile
index d3add524304e..d803a88c14d3 100644
--- a/audio/gnomoradio/Makefile
+++ b/audio/gnomoradio/Makefile
@@ -11,23 +11,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gahr@FreeBSD.org
COMMENT= Program for finding and playing free music from the Internet
-LIB_DEPENDS= libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
- libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24 \
- libgconfmm-2.6.so:${PORTSDIR}/devel/gconfmm26 \
- libxml++-2.6.so:${PORTSDIR}/textproc/libxml++26 \
- libvorbis.so:${PORTSDIR}/audio/libvorbis \
+LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
libao.so:${PORTSDIR}/audio/libao
USES= pathfix pkgconfig libtool
GNU_CONFIGURE= yes
-USE_GNOME= gnomeprefix
+USE_GNOME= gconfmm26 gnomeprefix gtkmm24
USE_LDCONFIG= yes
-LIBTOOLFLAGS= --tag=CXX
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= LIBS="`pkg-config --libs glibmm-2.4`"
+LIBS+= -L${LOCALBASE}/lib
post-patch:
+ @${REINPLACE_CMD} '/^rainbow_get_LDADD =/s/$$/ $$(RAINBOW_LIBS)/' \
+ ${WRKSRC}/rainbow/Makefile.in
@${REINPLACE_CMD} -e 's|CCLD = $$(CC)|CCLD = $$(CXX)|' \
${WRKSRC}/roboradio/mp3/Makefile.in
@${REINPLACE_CMD} -e 's|static char|static const char|' \