aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2013-05-25 22:37:02 +0800
committerzeising <zeising@FreeBSD.org>2013-05-25 22:37:02 +0800
commit715298b528f23a6a763e28623a4c98f1365c81ce (patch)
treecf13f962932aab3646f0af684b2923c4e0f0825b /audio
parent0f8e632e50d273ba38d9d13f7e446a4a10d95cd4 (diff)
downloadfreebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.tar.gz
freebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.tar.zst
freebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.zip
The FreeBSD x11 team proudly presents
an zeising, kwm, miwi, bapt, eadler production: Xorg 7.7 Starring: xserver 1.12.4 (new xorg only) Mesa 8.0.4, including libGL, libGLU and dri (new xorg only) libX11 1.5.0 libxcb 1.9 libdrm 2.4.42 (new xorg only) freeglut 2.8.1 Also starring: Updates to drivers and other libraries and utilities Additional notes: Change pkgconf to be a build dependency. Add a new USE_XORG, xcb, to depend on libxcb and update all ports to use this. Trim makefile headers. Take maintanership of x11/xcb-proto, ok'd by ashish. If you are running WITH_NEW_XORG=, you need to rebuild all installed drivers, see UPDATING for more information. Various fixes to make ports compile. PR: ports/177942 Exp-run by: miwi Approved by: portmgr (miwi) Thanks to all who helped testing!
Diffstat (limited to 'audio')
-rw-r--r--audio/arts/Makefile5
-rw-r--r--audio/py-karaoke/Makefile5
-rw-r--r--audio/xmms-curses/Makefile11
-rw-r--r--audio/xmms-flac/Makefile5
4 files changed, 9 insertions, 17 deletions
diff --git a/audio/arts/Makefile b/audio/arts/Makefile
index c9c5862eec56..a2735b564c10 100644
--- a/audio/arts/Makefile
+++ b/audio/arts/Makefile
@@ -27,8 +27,7 @@ LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib \
png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2 \
expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- xcb:${PORTSDIR}/x11/libxcb
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
DEPRECATED= Depends on QT3; unmaintained
EXPIRATION_DATE= 2013-07-01
@@ -40,7 +39,7 @@ USE_QT_VER= 3
USE_BZIP2= yes
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
-USE_XORG= ice sm x11 xau xcursor xdmcp xext xfixes xft xi \
+USE_XORG= ice sm x11 xau xcb xcursor xdmcp xext xfixes xft xi \
xinerama xrandr xrender xt
USE_LDCONFIG= yes
QTCPPFLAGS+= -L${LOCALBASE}/lib
diff --git a/audio/py-karaoke/Makefile b/audio/py-karaoke/Makefile
index b7580f0c8fa2..4ab180517b93 100644
--- a/audio/py-karaoke/Makefile
+++ b/audio/py-karaoke/Makefile
@@ -15,8 +15,7 @@ LICENSE= LGPL21 # (or later)
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>0:${PORTSDIR}/devel/py-game
LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- aa:${PORTSDIR}/graphics/aalib \
- xcb:${PORTSDIR}/x11/libxcb
+ aa:${PORTSDIR}/graphics/aalib
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>0:${PORTSDIR}/devel/py-game \
dejavu>0:${PORTSDIR}/x11-fonts/dejavu \
${PYNUMPY}
@@ -27,7 +26,7 @@ MUTAGEN_DESC= Enable Mutagen support
USES= iconv
USE_ZIP= yes
USE_SDL= sdl
-USE_XORG= x11 xau xdmcp
+USE_XORG= x11 xau xcb xdmcp
USE_WX= 2.6+
WX_COMPS= python:lib
diff --git a/audio/xmms-curses/Makefile b/audio/xmms-curses/Makefile
index f94856bc75b6..0cfd016e0679 100644
--- a/audio/xmms-curses/Makefile
+++ b/audio/xmms-curses/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xmms-curses
-# Date created: 2007-07-20
-# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@FreeBSD.org>
-#
+# Created by: Ion-Mihai "IOnut" Tetcu <itetcu@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= xmms-curses
PORTVERSION= 0.2.2
@@ -16,12 +12,11 @@ COMMENT= A ncurses program for (remote) controlling multimedia/xmms
BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
-LIB_DEPENDS= pthread-stubs.0:${PORTSDIR}/devel/libpthread-stubs \
- xcb.2:${PORTSDIR}/x11/libxcb
+LIB_DEPENDS= pthread-stubs.0:${PORTSDIR}/devel/libpthread-stubs
USES= gettext iconv
USE_GNOME= gtk12
-USE_XORG= x11 xau xdmcp xext xi
+USE_XORG= x11 xau xcb xdmcp xext xi
MAN1= ${PORTNAME}.1
diff --git a/audio/xmms-flac/Makefile b/audio/xmms-flac/Makefile
index 4bcad5c4dc0a..fb7b4a923f9a 100644
--- a/audio/xmms-flac/Makefile
+++ b/audio/xmms-flac/Makefile
@@ -13,13 +13,12 @@ COMMENT= XMMS input plugin for playing FLAC files
LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
FLAC.10:${PORTSDIR}/audio/flac \
pthread-stubs.0:${PORTSDIR}/devel/libpthread-stubs \
- ogg:${PORTSDIR}/audio/libogg \
- xcb.2:${PORTSDIR}/x11/libxcb
+ ogg:${PORTSDIR}/audio/libogg
USE_AUTOTOOLS= libtool
USES= gettext iconv
USE_GNOME= gtk12
-USE_XORG= x11 xau xdmcp xext xi
+USE_XORG= x11 xau xcb xdmcp xext xi
CONFIGURE_ARGS= --with-libiconv-prefix="${LOCALBASE}" \
--with-ogg="${LOCALBASE}" \
--with-xmms-prefix="${LOCALBASE}"