aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-04 14:00:41 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-04 14:00:41 +0800
commit72a112c5a6481ac21d03f9c1dea9cb38b8f53ee9 (patch)
tree93a7b5783e378369642d05135fda978caa381719 /audio
parentc6536b312c07c139e23bde7606dd89f7fca3cebd (diff)
downloadfreebsd-ports-gnome-72a112c5a6481ac21d03f9c1dea9cb38b8f53ee9.tar.gz
freebsd-ports-gnome-72a112c5a6481ac21d03f9c1dea9cb38b8f53ee9.tar.zst
freebsd-ports-gnome-72a112c5a6481ac21d03f9c1dea9cb38b8f53ee9.zip
audio/csound: use libc++ and unbreak with gcc5 or later
$ ldd $(which csound5gui) | fgrep c++ libc++.so.1 => /usr/lib/libc++.so.1 (0x803309000) libstdc++.so.6 => /usr/local/lib/gcc49/libstdc++.so.6 (0x803a22000) libcsound64.so.5: undefined reference to `csp_dag_is_finished' libcsound64.so.5: undefined reference to `csp_set_count' libcsound64.so.5: undefined reference to `csp_set_get_num' collect2: error: ld returned 1 exit status PR: 216707 Reported by: antoine (via exp-run)
Diffstat (limited to 'audio')
-rw-r--r--audio/csound/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 883b8fc95629..d9038ef65953 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -3,7 +3,7 @@
PORTNAME= csound
PORTVERSION= 5.19.01
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= audio lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION:R} \
SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION:R}/manual:manual
@@ -27,7 +27,8 @@ CONFLICTS_INSTALL= outguess-* csound6
WRKSRC= ${WRKDIR}/${PORTNAME:S/c/C/}${PORTVERSION}
-USES= bison cpe gettext scons compiler:openmp python
+USES= bison cpe gettext scons compiler:gcc-c++11-lib python
+USE_CSTD= gnu89
# math/gmm++ requires c++11
USE_CXXSTD= c++11
CPE_VENDOR= csounds