aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 10:58:50 +0800
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 10:58:50 +0800
commit7c5c64f24161a315d84f87db0d48b5e36544e73c (patch)
tree758fb5953ec05cb7929e5e1bae00132df74bf607 /audio
parentb1965cc50136d3bf81de5e467ccf5e3dbcc8c7ee (diff)
downloadfreebsd-ports-gnome-7c5c64f24161a315d84f87db0d48b5e36544e73c.tar.gz
freebsd-ports-gnome-7c5c64f24161a315d84f87db0d48b5e36544e73c.tar.zst
freebsd-ports-gnome-7c5c64f24161a315d84f87db0d48b5e36544e73c.zip
[non-maintainer update] update logic for "BROKEN" variable in audio/aureal-kmod
The current logic to calculate BROKEN in this port does not allow for one OS release to ask the port if it is broken on another OS release. This is due to an assumption that the OSVERSION passed to the Makefile exactly corresponds to the source version installed under /usr/src/sys (if any.) That is the default. However, when doing a cross-query, this is not the case. While this is a problem that is probably only of interest to myself, Bill Fenner, and Dan Langille, the logic could use tightening anyway. PR: ports/52590 Submitted by: Mark Linimon <linimon@lonesome.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/aureal-kmod/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/audio/aureal-kmod/Makefile b/audio/aureal-kmod/Makefile
index 40f01fd63331..a99f46373d65 100644
--- a/audio/aureal-kmod/Makefile
+++ b/audio/aureal-kmod/Makefile
@@ -36,8 +36,7 @@ VERSION_SOUND_C!= ident < ${SRCPREFIX}/sys/dev/sound/pcm/sound.c | \
VERSION_SOUND_C=
.endif
-VERSION_SOUND_C_CURRENT:= ${VERSION_SOUND_C:S/1.//}
-VERSION_SOUND_C_STABLE:= ${VERSION_SOUND_C:S/1.17.2.//}
+VERSION_SOUND_C_MINOR:= ${VERSION_SOUND_C:S/^1.//:S/^17.2.//}
.if ${OSVERSION} < 410000
BROKEN= "FreeBSD 3.*, 4.0 are not supported"
@@ -51,7 +50,7 @@ PORTREVISION= 3
# FreeBSD 4.2, 4.3
PORTVERSION= 1.3
-.if ${VERSION_SOUND_C_STABLE} < 4
+.if ${VERSION_SOUND_C_MINOR} < 4
# FreeBSD 4.2 before kobj MFC
PORTREVISION= 1
@@ -69,7 +68,7 @@ MAKE_ENV+= HAVE_KOBJ_PCM=1
.elif ${OSVERSION} < 500000
# FreeBSD 4.5+, 4.6, 4.7, 4.8-
-.if ${VERSION_SOUND_C_STABLE} < 12
+.if ${VERSION_SOUND_C_MINOR} < 12
BROKEN= "Base system is outdated. This port needs -STABLE after 2002-04-22."
.endif
PORTVERSION= 1.3
@@ -79,7 +78,7 @@ MAKE_ENV+= HAVE_KOBJ_PCM=1
.if ${OSVERSION} > 500000
# FreeBSD 5-CURRENT
-.if ${VERSION_SOUND_C_CURRENT} < 70
+.if ${VERSION_SOUND_C_MINOR} < 70
BROKEN= "Base system is outdated. This port needs -CURRENT after 2002-04-04."
.endif
.endif