aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-12-18 02:23:46 +0800
committerjbeich <jbeich@FreeBSD.org>2016-12-18 02:23:46 +0800
commit8957b65a3d8bb432efed143c6d3f28214d2037b0 (patch)
tree1f0f56e03376830a50cadb21138a444a8f441e34 /audio
parent0fe4b337b460141146e6589f99fa6e79703da4e5 (diff)
downloadfreebsd-ports-gnome-8957b65a3d8bb432efed143c6d3f28214d2037b0.tar.gz
freebsd-ports-gnome-8957b65a3d8bb432efed143c6d3f28214d2037b0.tar.zst
freebsd-ports-gnome-8957b65a3d8bb432efed143c6d3f28214d2037b0.zip
audio/soundtouch: OPENMP=on to use system C++ library
Mixing libc++ and libstdc++ often causes crashes.
Diffstat (limited to 'audio')
-rw-r--r--audio/soundtouch/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/audio/soundtouch/Makefile b/audio/soundtouch/Makefile
index 0da1afc11b9e..936a0d4bb0ff 100644
--- a/audio/soundtouch/Makefile
+++ b/audio/soundtouch/Makefile
@@ -3,7 +3,7 @@
PORTNAME= soundtouch
PORTVERSION= 1.9.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://www.surina.net/soundtouch/
@@ -29,7 +29,7 @@ OPTIONS_DEFAULT_i386= ${MACHINE_CPU:tu:MSSE}
INTEGER_SAMPLES_DESC= Use integer sample format
INTEGER_SAMPLES_CONFIGURE_ENABLE= integer-samples
OPENMP_CONFIGURE_ENABLE=openmp
-OPENMP_USES= compiler:openmp
+OPENMP_USES= compiler:gcc-c++11-lib
SSE_CONFIGURE_ENABLE= x86-optimizations
SSE_USES= compiler:c++11-lang