aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorlme <lme@FreeBSD.org>2012-06-05 05:02:02 +0800
committerlme <lme@FreeBSD.org>2012-06-05 05:02:02 +0800
commit8c44cdec219bd95f2513651761be15faeb269aa9 (patch)
treee3598ccb8fd34877763694d75bb44b6f51e0ddd7 /audio
parent5604bdf4b091825f3b1e9504512765afb51fbd02 (diff)
downloadfreebsd-ports-gnome-8c44cdec219bd95f2513651761be15faeb269aa9.tar.gz
freebsd-ports-gnome-8c44cdec219bd95f2513651761be15faeb269aa9.tar.zst
freebsd-ports-gnome-8c44cdec219bd95f2513651761be15faeb269aa9.zip
- Use the new options framework
- Correct plist
Diffstat (limited to 'audio')
-rw-r--r--audio/atunes/Makefile45
-rw-r--r--audio/atunes/pkg-plist1
2 files changed, 24 insertions, 22 deletions
diff --git a/audio/atunes/Makefile b/audio/atunes/Makefile
index 317a8566da95..444377765bcb 100644
--- a/audio/atunes/Makefile
+++ b/audio/atunes/Makefile
@@ -21,42 +21,45 @@ SUB_FILES= atunes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-SNAPSHOT
-OPTIONS= MPLAYER "Engine: Use Mplayer" on \
- XINE "Engine: Use Xine" off \
- CDDA2WAV "Ripper: Enable cdrtools support" on \
- LAME "Encoder: Enable lame MP3 encoder" on \
- VORBIS "Encoder: Enable vorbis OGG encoder" on \
- FLAC "Encoder: Enable FLAC encoder" off
-
-.include <bsd.port.pre.mk>
-
-pre-everything::
-.if !defined(WITH_MPLAYER) && !defined(WITH_XINE)
- @${ECHO_MSG} "You need to select at least one engine, mplayer or xine!"
- @${FALSE}
-.endif
+OPTIONS_DEFINE= CDDA2WAV
+
+OPTIONS_MULTI= ENCODER ENGINE
+
+OPTIONS_MULTI_ENCODER= LAME VORBIS FLAC
+OPTIONS_MULTI_ENGINE= MPLAYER XINE
+
+OPTIONS_DEFAULT= MPLAYER CDDA2WAV LAME VORBIS
+
+MPLAYER_DESC= Engine: Use Mplayer
+XINE_DESC= Engine: Use Xine
+CDDA2WAV_DESC= Ripper: Enable cdrtools support
+LAME_DESC= Encoder: Enable lame MP3 encoder
+VORBIS_DESC= Encoder: Enable vorbis OGG encoder
+FLAC_DESC= Encoder: Enable FLAC encoder
+
+.include <bsd.port.options.mk>
-.if defined(WITH_MPLAYER)
+.if ${PORT_OPTIONS:MMPLAYER}
RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
.endif
-.if defined(WITH_XINE)
+.if ${PORT_OPTIONS:MXINE}
LIB_DEPENDS+= xine.2:${PORTSDIR}/multimedia/libxine
.endif
-.if defined(WITH_CDDA2WAV)
+.if ${PORT_OPTIONS:MCDDA2WAV}
USE_CDRTOOLS= yes
.endif
-.if defined(WITH_LAME)
+.if ${PORT_OPTIONS:MLAME}
RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
.endif
-.if defined(WITH_VORBIS)
+.if ${PORT_OPTIONS:MVORBIS}
RUN_DEPENDS+= ogg123:${PORTSDIR}/audio/vorbis-tools
.endif
-.if defined(WITH_FLAC)
+.if ${PORT_OPTIONS:MFLAC}
RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
.endif
@@ -85,4 +88,4 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/pixmaps
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/atunes/pkg-plist b/audio/atunes/pkg-plist
index a2dded5af60b..6950cd75fd8e 100644
--- a/audio/atunes/pkg-plist
+++ b/audio/atunes/pkg-plist
@@ -43,4 +43,3 @@ bin/atunes
share/pixmaps/atunes.png
@dirrm %%DATADIR%%/lib
@dirrm %%DATADIR%%
-@dirrmtry share/applications