aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2018-02-15 16:51:05 +0800
committerjhale <jhale@FreeBSD.org>2018-02-15 16:51:05 +0800
commit8c8c9f16b6657da3a915764e5734313fb47f249b (patch)
treeb1313bb20434452f326536ee0515a140a5930242 /audio
parent0daafbea5e9062e0de0b1baf128379bc10ad4c55 (diff)
downloadfreebsd-ports-gnome-8c8c9f16b6657da3a915764e5734313fb47f249b.tar.gz
freebsd-ports-gnome-8c8c9f16b6657da3a915764e5734313fb47f249b.tar.zst
freebsd-ports-gnome-8c8c9f16b6657da3a915764e5734313fb47f249b.zip
New port: audio/moodbar
Moodbar is a stand-alone moodbar file generator. These files can be used by audio players to display a visual representation or "mood" of an audio track. The original moodbar generator developed for Amarok has become abandonware. This is a new implementation based on GStreamer 1.x. WWW: https://github.com/exaile/moodbar
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/moodbar/Makefile26
-rw-r--r--audio/moodbar/distinfo3
-rw-r--r--audio/moodbar/pkg-descr8
4 files changed, 38 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index b7e71ad1699f..1f1b01500567 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -511,6 +511,7 @@
SUBDIR += mma
SUBDIR += moc
SUBDIR += modplugplay
+ SUBDIR += moodbar
SUBDIR += moony-lv2
SUBDIR += mous
SUBDIR += mp-player
diff --git a/audio/moodbar/Makefile b/audio/moodbar/Makefile
new file mode 100644
index 000000000000..522c6540fc83
--- /dev/null
+++ b/audio/moodbar/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= moodbar
+PORTVERSION= 0.0.1.20171217
+CATEGORIES= audio
+
+MAINTAINER= jhale@FreeBSD.org
+COMMENT= Generates mood files from audio files
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libfftw3.so:math/fftw3
+
+USES= compiler:c++14-lang meson pkgconfig
+
+USE_GITHUB= yes
+GH_ACCOUNT= exaile
+GH_TAGNAME= 5d31ce4
+
+USE_GNOME= glib20
+USE_GSTREAMER1= yes good ogg vorbis
+
+PLIST_FILES= bin/moodbar
+
+.include <bsd.port.mk>
diff --git a/audio/moodbar/distinfo b/audio/moodbar/distinfo
new file mode 100644
index 000000000000..8c391857fd56
--- /dev/null
+++ b/audio/moodbar/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518629139
+SHA256 (exaile-moodbar-0.0.1.20171217-5d31ce4_GH0.tar.gz) = e7b5b90baf5505f0846062757825467f5dd25500c3d0dc3303de3fe342273dae
+SIZE (exaile-moodbar-0.0.1.20171217-5d31ce4_GH0.tar.gz) = 23772
diff --git a/audio/moodbar/pkg-descr b/audio/moodbar/pkg-descr
new file mode 100644
index 000000000000..c4f048d54774
--- /dev/null
+++ b/audio/moodbar/pkg-descr
@@ -0,0 +1,8 @@
+Moodbar is a stand-alone moodbar file generator. These files can
+be used by audio players to display a visual representation or
+"mood" of an audio track.
+
+The original moodbar generator developed for Amarok has become
+abandonware. This is a new implementation based on GStreamer 1.x.
+
+WWW: https://github.com/exaile/moodbar