aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-07-18 03:35:48 +0800
committercrees <crees@FreeBSD.org>2011-07-18 03:35:48 +0800
commit8e31c95f9b6378103ed7cd0051f16ca9e2249a06 (patch)
treef1e98dda6da9e61c1aea50894661f61ffbb4a6ce /audio
parent425e7a6aee6e66551261cf968de1804c6f0a8844 (diff)
downloadfreebsd-ports-gnome-8e31c95f9b6378103ed7cd0051f16ca9e2249a06.tar.gz
freebsd-ports-gnome-8e31c95f9b6378103ed7cd0051f16ca9e2249a06.tar.zst
freebsd-ports-gnome-8e31c95f9b6378103ed7cd0051f16ca9e2249a06.zip
Stop autodetecting libsndfile --> now an OPTION, on by default
PR: ports/158999 Submitted by: David Demelier <demelier.david@gmail.com> Approved by: rene (mentor, implicit)
Diffstat (limited to 'audio')
-rw-r--r--audio/musicpd/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 46c04ad5bc3f..e3d11281df53 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= musicpd
PORTVERSION= 0.16.3
+PORTREVISION= 1
CATEGORIES= audio ipv6
MASTER_SITES= SF/${PORTNAME}/mpd/${PORTVERSION}
DISTNAME= mpd-${PORTVERSION}
@@ -57,6 +58,7 @@ OPTIONS= ID3TAG "Support ID3 v1/v2 tags" on \
PULSEAUDIO "Support PulseAudio sound server" off \
JACK "Support JACK audio server" off \
SHOUTCAST "Support for OGG Icecast and Shoutcast" off \
+ SNDFILE "Adds support for libsndfile" on \
LAME "Support for MP3 Icecast Streams" off \
HTTPD "Support for httpd output streaming" off \
SAMPLERATE "Support sample rate conversion" off
@@ -223,6 +225,13 @@ CONFIGURE_ARGS+=--enable-vorbis-encoder \
CONFIGURE_ARGS+=--disable-shout
.endif
+.if defined(WITH_SNDFILE)
+LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
+CONFIGURE_ARGS+= --enable-sndfile
+.else
+CONFIGURE_ARGS+= --disable-sndfile
+.endif
+
.if defined(WITHOUT_SAMPLERATE)
CONFIGURE_ARGS+=--disable-lsr
.else