aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-12-08 08:22:57 +0800
committeralane <alane@FreeBSD.org>2002-12-08 08:22:57 +0800
commit8eca87d589e142e3798a6fccbe27a8a1d3d9f082 (patch)
tree77f3891c65fce67f35ac8461530e2888f66d616f /audio
parent2f4517e2872d658b39e7acba9762c9fefe535396 (diff)
downloadfreebsd-ports-gnome-8eca87d589e142e3798a6fccbe27a8a1d3d9f082.tar.gz
freebsd-ports-gnome-8eca87d589e142e3798a6fccbe27a8a1d3d9f082.tar.zst
freebsd-ports-gnome-8eca87d589e142e3798a6fccbe27a8a1d3d9f082.zip
Patch pthread options into flags so library will build.
PR: 46075 Approved by: kris
Diffstat (limited to 'audio')
-rw-r--r--audio/ruby-xmms/Makefile2
-rw-r--r--audio/ruby-xmms/files/patch-extconf.rb13
2 files changed, 15 insertions, 0 deletions
diff --git a/audio/ruby-xmms/Makefile b/audio/ruby-xmms/Makefile
index 4065a8ea46e4..da0eed5e4511 100644
--- a/audio/ruby-xmms/Makefile
+++ b/audio/ruby-xmms/Makefile
@@ -25,6 +25,8 @@ INSTALL_TARGET= site-install
DOCS= AUTHORS COPYING ChangeLog README doc
+CONFIGURE_ENV+= CFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
diff --git a/audio/ruby-xmms/files/patch-extconf.rb b/audio/ruby-xmms/files/patch-extconf.rb
new file mode 100644
index 000000000000..85e32931f791
--- /dev/null
+++ b/audio/ruby-xmms/files/patch-extconf.rb
@@ -0,0 +1,13 @@
+--- extconf.rb~ Sun May 5 03:16:11 2002
++++ extconf.rb Sat Dec 7 09:30:02 2002
+@@ -2,8 +2,8 @@
+
+ xmms_config = with_config("xmms-config", "xmms-config")
+
+-$CFLAGS << ' ' << `#{xmms_config} --cflags`.chomp
+-$LDFLAGS << ' ' << `#{xmms_config} --libs`.chomp
++$CFLAGS << ' ' << ENV["CFLAGS"] << ' ' << `#{xmms_config} --cflags`.chomp
++$LDFLAGS << ' ' << ENV["LDFLAGS"] << ' ' << `#{xmms_config} --libs`.chomp
+
+ have_library("xmms", "xmms_remote_get_version") and
+ create_makefile("xmms")