aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2016-04-28 00:36:41 +0800
committerswills <swills@FreeBSD.org>2016-04-28 00:36:41 +0800
commit900b8428054e4288c9669f4f17359be2ae8a45c3 (patch)
tree146c1b1aad08357a95df3348dea477d956cd3816 /audio
parentc5f5d48270cbe2ede4cb24ba577ced5ea769dd2f (diff)
downloadfreebsd-ports-gnome-900b8428054e4288c9669f4f17359be2ae8a45c3.tar.gz
freebsd-ports-gnome-900b8428054e4288c9669f4f17359be2ae8a45c3.tar.zst
freebsd-ports-gnome-900b8428054e4288c9669f4f17359be2ae8a45c3.zip
create USES=gem and update rubygem- ports to use it
Note that for now ports still have to have USE_RUBY=yes to use USES=gem PR: 209041 Differential Revision: https://reviews.freebsd.org/D6070
Diffstat (limited to 'audio')
-rw-r--r--audio/rubygem-librmpd/Makefile3
-rw-r--r--audio/rubygem-ruby-mp3info/Makefile3
-rw-r--r--audio/rubygem-ruby-ogginfo/Makefile3
-rw-r--r--audio/rubygem-ruby-shout/Makefile3
4 files changed, 4 insertions, 8 deletions
diff --git a/audio/rubygem-librmpd/Makefile b/audio/rubygem-librmpd/Makefile
index 2c3627904305..2fd2023790e6 100644
--- a/audio/rubygem-librmpd/Makefile
+++ b/audio/rubygem-librmpd/Makefile
@@ -12,7 +12,6 @@ COMMENT= Is a simple yet powerful Music Player Daemon library
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/audio/rubygem-ruby-mp3info/Makefile b/audio/rubygem-ruby-mp3info/Makefile
index 8602ae62c87e..52a4d41e1cf0 100644
--- a/audio/rubygem-ruby-mp3info/Makefile
+++ b/audio/rubygem-ruby-mp3info/Makefile
@@ -14,7 +14,6 @@ LICENSE= MIT
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/audio/rubygem-ruby-ogginfo/Makefile b/audio/rubygem-ruby-ogginfo/Makefile
index a6cb11c2c774..2118a700a03e 100644
--- a/audio/rubygem-ruby-ogginfo/Makefile
+++ b/audio/rubygem-ruby-ogginfo/Makefile
@@ -13,7 +13,6 @@ LICENSE= GPLv3
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/audio/rubygem-ruby-shout/Makefile b/audio/rubygem-ruby-shout/Makefile
index db4d11c8eda5..cbe85aa94c50 100644
--- a/audio/rubygem-ruby-shout/Makefile
+++ b/audio/rubygem-ruby-shout/Makefile
@@ -16,7 +16,6 @@ LIB_DEPENDS= libshout.so:audio/libshout
CONFIGURE_ARGS= --with-opt-include="${LOCALBASE}/include"
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>