aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2015-07-27 21:44:45 +0800
committerrm <rm@FreeBSD.org>2015-07-27 21:44:45 +0800
commit90d62cbd90c8415e9be708056ef32fa65ba44d04 (patch)
treea685004d1e740440c70d794c55d0bb3be653b997 /audio
parent283596d004a0b211cc1461f4c202ce24213da8c9 (diff)
downloadfreebsd-ports-gnome-90d62cbd90c8415e9be708056ef32fa65ba44d04.tar.gz
freebsd-ports-gnome-90d62cbd90c8415e9be708056ef32fa65ba44d04.tar.zst
freebsd-ports-gnome-90d62cbd90c8415e9be708056ef32fa65ba44d04.zip
audio/audacity: fix build with new ffmpeg
- add patch to fix build with ffmpeg 2.7 - add ffmpeg to LIB_DEPENDS to fix build in rare cases PR: 201589 Submitted by: Christian Heckendorf <heckendorfc@gmail.com> Approved by: xxjack12xx@gmail.com
Diffstat (limited to 'audio')
-rw-r--r--audio/audacity/Makefile4
-rw-r--r--audio/audacity/files/patch-src_FFmpeg.h29
2 files changed, 32 insertions, 1 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index f7ac9314147a..f1f60a14d8ab 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -3,6 +3,7 @@
PORTNAME= audacity
PORTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-minsrc-${PORTVERSION}
@@ -62,7 +63,8 @@ CONFIGURE_ARGS+= --disable-sse
DEBUG_CONFIGURE_WITH= debug
FFMPEG_CONFIGURE_WITH= ffmpeg
-FFMPEG_RUN_DEPENDS= ${LOCALBASE}/bin/ffmpeg:${PORTSDIR}/multimedia/ffmpeg
+FFMPEG_RUN_DEPENDS= ${LOCALBASE}/bin/ffmpeg:${PORTSDIR}/multimedia/ffmpeg
+FFMPEG_LIB_DEPENDS= libavformat.so:${PORTSDIR}/multimedia/ffmpeg
FFMPEG_CFLAGS= -I${LOCALBASE}/include/ffmpeg
FFMPEG_CPPFLAGS= -I${LOCALBASE}/include/ffmpeg
FFMPEG_CXXFLAGS= -I${LOCALBASE}/include/ffmpeg
diff --git a/audio/audacity/files/patch-src_FFmpeg.h b/audio/audacity/files/patch-src_FFmpeg.h
new file mode 100644
index 000000000000..4b9caeaa6355
--- /dev/null
+++ b/audio/audacity/files/patch-src_FFmpeg.h
@@ -0,0 +1,29 @@
+--- src/FFmpeg.h.orig 2015-03-02 01:06:57 UTC
++++ src/FFmpeg.h
+@@ -688,7 +688,7 @@ extern "C" {
+ FFMPEG_FUNCTION_WITH_RETURN(
+ AVOutputFormat*,
+ av_oformat_next,
+- (AVOutputFormat *f),
++ (const AVOutputFormat *f),
+ (f)
+ );
+ FFMPEG_FUNCTION_WITH_RETURN(
+@@ -755,7 +755,7 @@ extern "C" {
+ FFMPEG_FUNCTION_WITH_RETURN(
+ int,
+ av_fifo_size,
+- (AVFifoBuffer *f),
++ (const AVFifoBuffer *f),
+ (f)
+ );
+ FFMPEG_FUNCTION_WITH_RETURN(
+@@ -801,7 +801,7 @@ extern "C" {
+ FFMPEG_FUNCTION_WITH_RETURN(
+ AVDictionaryEntry *,
+ av_dict_get,
+- (AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
++ (const AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
+ (m, key, prev, flags)
+ );
+ FFMPEG_FUNCTION_WITH_RETURN(