aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-12-01 15:39:02 +0800
committerpav <pav@FreeBSD.org>2006-12-01 15:39:02 +0800
commit92d21b3194c49cedf08339e7514171807a9c6196 (patch)
tree9c146b3b2fdea9918389f3184052481e51ccf2f9 /audio
parent977deb3eb313758a6e81aa2d1d05565d53d51455 (diff)
downloadfreebsd-ports-gnome-92d21b3194c49cedf08339e7514171807a9c6196.tar.gz
freebsd-ports-gnome-92d21b3194c49cedf08339e7514171807a9c6196.tar.zst
freebsd-ports-gnome-92d21b3194c49cedf08339e7514171807a9c6196.zip
- Use features of bsd.wx.mk, especially USE_WX
PR: ports/101613 Submitted by: alepulver
Diffstat (limited to 'audio')
-rw-r--r--audio/audacity/Makefile5
-rw-r--r--audio/mbox/Makefile6
2 files changed, 5 insertions, 6 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 908cd6d9723e..bd930904d371 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= craig@yekse.gank.org
COMMENT= Audacity is a GUI editor for digital audio waveforms
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS= wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
CONFLICTS= audacity-devel-[0-9]*
@@ -24,6 +23,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GETTEXT= yes
+USE_WX= 2.6
MAN1= audacity.1
MANCOMPRESSED= yes
@@ -40,8 +40,7 @@ SSE_CFLAGS= -mno-sse -mno-sse2
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
- CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
- WX_CONFIG=${X11BASE}/bin/wxgtk2-2.6-config
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}"
.if !defined(NOPORTDOCS)
MAKE_ENV= DOC=yes
diff --git a/audio/mbox/Makefile b/audio/mbox/Makefile
index 78a18d2c69fd..b684abaf166d 100644
--- a/audio/mbox/Makefile
+++ b/audio/mbox/Makefile
@@ -12,17 +12,17 @@ MASTER_SITES= http://www.mbox.wz.cz/src/
MAINTAINER= ports@FreeBSD.org
COMMENT= Program intended to help with organizing your music files
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/wxPython/__init__.py:${PORTSDIR}/x11-toolkits/py-wxPython24 \
- ${PYTHON_SITELIBDIR}/ogg/__init__.py:${PORTSDIR}/audio/py-ogg \
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/ogg/__init__.py:${PORTSDIR}/audio/py-ogg \
${PYTHON_SITELIBDIR}/ogg/vorbis.so:${PORTSDIR}/audio/py-vorbis \
lame:${PORTSDIR}/audio/lame \
oggenc:${PORTSDIR}/audio/vorbis-tools \
mplayer:${PORTSDIR}/multimedia/mplayer
-LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24
USE_PYTHON= yes
USE_PYDISTUTILS=yes
USE_BZIP2= yes
+USE_WX= 2.4
+WX_COMPS= python
WRKSRC= ${WRKDIR}/mBox-${PORTVERSION}
.include <bsd.port.mk>