aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-11-22 09:25:29 +0800
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-11-22 09:25:29 +0800
commit96f0030f4cb2cd7815c69dce21d544da89e41fc2 (patch)
treec5f70c7663a1110e6613e975b7ed690ef81d7b99 /audio
parent37501f07e50a47c757b60f93d3bbe6513d950796 (diff)
downloadfreebsd-ports-gnome-96f0030f4cb2cd7815c69dce21d544da89e41fc2.tar.gz
freebsd-ports-gnome-96f0030f4cb2cd7815c69dce21d544da89e41fc2.tar.zst
freebsd-ports-gnome-96f0030f4cb2cd7815c69dce21d544da89e41fc2.zip
Do not link plugins to libsupc++ which is apparently PIC-unsafe with system
compiler, and thus remove requirement for GCC 4.5+ on amd64. Approved by: maintainer Feature safe: yes
Diffstat (limited to 'audio')
-rw-r--r--audio/deadbeef/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/audio/deadbeef/Makefile b/audio/deadbeef/Makefile
index 0996784942de..4355891d1968 100644
--- a/audio/deadbeef/Makefile
+++ b/audio/deadbeef/Makefile
@@ -69,10 +69,6 @@ OPTIONS= PULSE "PulseAudio output plugin (unsupported)" off\
.include <bsd.port.options.mk>
-.if ${ARCH} == "amd64"
-USE_GCC= 4.5+
-.endif
-
.if defined(WITHOUT_PULSE)
CONFIGURE_ARGS+= --disable-pulse
PLIST_SUB+= PULSE="@comment "
@@ -341,4 +337,12 @@ PLIST_SUB+= VFS_ZIP=""
LIB_DEPENDS+= zip.3:${PORTSDIR}/archivers/libzip
.endif
+post-patch:
+# Do not link to libsupc++ which may be PIC-unsafe (breaks 64-bit arches)
+ @${REINPLACE_CMD} -e 's, -lsupc++,,' \
+ ${WRKSRC}/plugins/adplug/Makefile.in \
+ ${WRKSRC}/plugins/gme/Makefile.in \
+ ${WRKSRC}/plugins/sid/Makefile.in \
+ ${WRKSRC}/plugins/supereq/Makefile.in
+
.include <bsd.port.mk>