aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-09-08 00:21:01 +0800
committermiwi <miwi@FreeBSD.org>2008-09-08 00:21:01 +0800
commit9a5fef987f85998f955b1c8eb9529501d34a9888 (patch)
tree4e03db9857a21046a56223cbb8b84494bda0b10b /audio
parent25555bf627c12a84e6ad2fb7e179581d3a7f0993 (diff)
downloadfreebsd-ports-gnome-9a5fef987f85998f955b1c8eb9529501d34a9888.tar.gz
freebsd-ports-gnome-9a5fef987f85998f955b1c8eb9529501d34a9888.tar.zst
freebsd-ports-gnome-9a5fef987f85998f955b1c8eb9529501d34a9888.zip
- Update to 0.7
PR: 127175 Submitted by: Bernhard Froehlich <decke@bluelife.at> (maintainer)
Diffstat (limited to 'audio')
-rw-r--r--audio/vagalume/Makefile35
-rw-r--r--audio/vagalume/distinfo6
-rw-r--r--audio/vagalume/files/patch-configure.ac66
-rw-r--r--audio/vagalume/files/patch-scripst-vagalumectl11
-rw-r--r--audio/vagalume/pkg-plist39
5 files changed, 135 insertions, 22 deletions
diff --git a/audio/vagalume/Makefile b/audio/vagalume/Makefile
index 17bb5a64947d..8fdd05af8210 100644
--- a/audio/vagalume/Makefile
+++ b/audio/vagalume/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= vagalume
-PORTVERSION= 0.6
+PORTVERSION= 0.7
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
MASTER_SITE_SUBDIR= pool/main/v/vagalume/
@@ -21,26 +21,35 @@ LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool:15
-USE_GETTEXT= yes
+USE_AUTOTOOLS= libtool:15 autoconf:262
USE_GNOME= pkgconfig gtk20
USE_GSTREAMER= good mad
INSTALLS_ICONS= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
MAN1= vagalume.1
-OPTIONS= IMSTATUS "Build with IM status support" off \
- TRAY "Build with tray icon and libnotify support" on
+OPTIONS= DBUS "Build with DBUS support" on \
+ TRAY "Build with tray icon and libnotify support" on
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_IMSTATUS)
-CONFIGURE_ARGS+=--enable-im-status
-LIB_DEPEND+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if !defined(WITHOUT_DBUS)
+CONFIGURE_ARGS+=--enable-dbus --enable-im-status
+LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+PLIST_SUB+= DBUS=""
+MAN1+= vagalumectl.1
.else
-CONFIGURE_ARGS+=--disable-im-status
+CONFIGURE_ARGS+=--disable-dbus --disable-im-status
+PLIST_SUB+= DBUS="@comment "
.endif
.if !defined(WITHOUT_TRAY)
@@ -56,4 +65,8 @@ USE_GNOME+= gconf2
CONFIGURE_ARGS+=--enable-gconf
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|serviceentrydir = @serviceentrydir@|serviceentrydir = ${PREFIX}/share/dbus-1/services|' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.post.mk>
diff --git a/audio/vagalume/distinfo b/audio/vagalume/distinfo
index 303e99018643..e229a16a61ff 100644
--- a/audio/vagalume/distinfo
+++ b/audio/vagalume/distinfo
@@ -1,3 +1,3 @@
-MD5 (vagalume_0.6.orig.tar.gz) = c46e2cc182f7f427196a5bb682f10428
-SHA256 (vagalume_0.6.orig.tar.gz) = bd9b6d1689fc01b186f160ed1f2bb813826a20d4118d525122c446fbf0ab3dd8
-SIZE (vagalume_0.6.orig.tar.gz) = 555331
+MD5 (vagalume_0.7.orig.tar.gz) = 97e1497eed21ef0ac82514ead94c5ee4
+SHA256 (vagalume_0.7.orig.tar.gz) = 82b42534276018809aec934b572845e495ea19fc0c6abf6b6ef1e8571b91ccee
+SIZE (vagalume_0.7.orig.tar.gz) = 607507
diff --git a/audio/vagalume/files/patch-configure.ac b/audio/vagalume/files/patch-configure.ac
new file mode 100644
index 000000000000..7b6f0bd74e7a
--- /dev/null
+++ b/audio/vagalume/files/patch-configure.ac
@@ -0,0 +1,66 @@
+--- configure.ac 2008/08/30 00:00:58 400
++++ configure.ac 2008/09/04 11:41:50 409
+@@ -124,6 +124,19 @@
+ fi
+ PLATFORMVERS=""
+
++# Check whether to use dbus-glib
++AC_ARG_ENABLE(dbus, [
++ --enable-dbus Compile with D-BUS support (default if available)
++ --disable-dbus Don't compile with D-BUS support],
++ use_dbus_glib=$enableval, use_dbus_glib=$have_dbus_glib)
++
++if test "$use_dbus_glib" = "yes" -a "$have_dbus_glib" = "no"; then
++ AC_MSG_ERROR([dbus-glib not found, install it or use --disable-dbus])
++elif test "$use_dbus_glib" = "yes"; then
++ EXTRA_CFLAGS="$EXTRA_CFLAGS $dbus_glib_CFLAGS"
++ EXTRA_LIBS="$EXTRA_LIBS $dbus_glib_LIBS"
++fi
++
+ # Check whether to use libgcrypt
+ AC_ARG_ENABLE(libgcrypt, [
+ --enable-libgcrypt use libgcrypt if glib doesn't support MD5
+@@ -164,14 +177,12 @@
+ AC_ARG_ENABLE(im-status, [
+ --enable-im-status Enable "Set IM status" feature (default if available)
+ --disable-im-status Disable "Set IM status" feature],
+- set_im_status=$enableval, set_im_status=$have_dbus_glib)
++ set_im_status=$enableval, set_im_status=$use_dbus_glib)
+
+-if test "$set_im_status" = "yes" -a "$have_dbus_glib" = "no"; then
++if test "$set_im_status" = "yes" -a "$use_dbus_glib" = "no"; then
+ AC_MSG_ERROR([dbus-glib not found, install it or use --disable-im-status])
+ elif test "$set_im_status" = "yes"; then
+ AC_DEFINE([SET_IM_STATUS],[1],[Defined if "Set IM Status" is enabled])
+- EXTRA_CFLAGS="$EXTRA_CFLAGS $dbus_glib_CFLAGS"
+- EXTRA_LIBS="$EXTRA_LIBS $dbus_glib_LIBS"
+ echo "\"Set IM status\" feature enabled"
+ else
+ echo "\"Set IM status\" feature disabled"
+@@ -304,7 +315,7 @@
+ # Desktop screen resolution
+ scr_resolution=desktop
+
+- if test "$have_dbus_glib" = "yes"; then
++ if test "$use_dbus_glib" = "yes"; then
+ serviceentrydir=`$PKG_CONFIG dbus-1 --variable=session_bus_services_dir`
+ AC_DEFINE([HAVE_GSD_MEDIA_PLAYER_KEYS], [1],
+ [Media player keys in some keyboards])
+@@ -333,7 +344,7 @@
+ # Disable tray icon support on Moblin
+ have_tray_icon="no"
+
+- if test "$have_dbus_glib" = "yes"; then
++ if test "$use_dbus_glib" = "yes"; then
+ serviceentrydir=`$PKG_CONFIG dbus-1 --variable=session_bus_services_dir`
+ fi
+ desktopentrydir="\${datadir}/applications"
+@@ -447,7 +458,7 @@
+ echo "Maemo status bar plugin enabled: $have_sb_plugin"
+ echo "Libconic support: $have_conic"
+ fi
+-echo "D-Bus Support enabled:" $have_dbus_glib
++echo "D-Bus Support enabled:" $use_dbus_glib
+ echo "Target display: $scr_resolution"
+ echo ""
+ echo "Type 'make' to compile Vagalume"
diff --git a/audio/vagalume/files/patch-scripst-vagalumectl b/audio/vagalume/files/patch-scripst-vagalumectl
new file mode 100644
index 000000000000..d7884ff89f63
--- /dev/null
+++ b/audio/vagalume/files/patch-scripst-vagalumectl
@@ -0,0 +1,11 @@
+--- scripts/vagalumectl 2008-08-06 16:53:19.000000000 +0200
++++ scripts/vagalumectl 2008-08-06 16:53:39.000000000 +0200
+@@ -151,7 +151,7 @@
+ fi
+
+ # Check whether vagalume is or not already running
+-if ! pidof vagalume > /dev/null; then
++if ! pgrep -x vagalume > /dev/null; then
+ if [ ${COMMAND} = "close" ]; then
+ # Exit cleanly without executing the 'close' command when Vagalume is not running
+ echo "Vagalume not running: no need to close it";
diff --git a/audio/vagalume/pkg-plist b/audio/vagalume/pkg-plist
index 137ba59b0fc9..12fdba7ed276 100644
--- a/audio/vagalume/pkg-plist
+++ b/audio/vagalume/pkg-plist
@@ -1,14 +1,9 @@
+@comment $FreeBSD$
bin/vagalume
+%%DBUS%%bin/vagalumectl
share/applications/vagalume.desktop
+%%DBUS%%share/dbus-1/services/vagalume.service
share/icons/hicolor/48x48/apps/vagalume.png
-share/locale/de/LC_MESSAGES/vagalume.mo
-share/locale/es/LC_MESSAGES/vagalume.mo
-share/locale/es_MX/LC_MESSAGES/vagalume.mo
-share/locale/fi/LC_MESSAGES/vagalume.mo
-share/locale/gl/LC_MESSAGES/vagalume.mo
-share/locale/it/LC_MESSAGES/vagalume.mo
-share/locale/pt/LC_MESSAGES/vagalume.mo
-share/locale/pt_BR/LC_MESSAGES/vagalume.mo
share/pixmaps/vagalume.xpm
%%DATADIR%%/cover.png
%%DATADIR%%/icons/hicolor/scalable/actions/accessories-text-editor.svg
@@ -20,6 +15,15 @@ share/pixmaps/vagalume.xpm
%%DATADIR%%/icons/hicolor/scalable/actions/media-playback-stop.svg
%%DATADIR%%/icons/hicolor/scalable/actions/media-skip-forward.svg
%%DATADIR%%/icons/hicolor/scalable/actions/process-stop.svg
+%%NLS%%share/locale/de/LC_MESSAGES/vagalume.mo
+%%NLS%%share/locale/es/LC_MESSAGES/vagalume.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/vagalume.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/vagalume.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/vagalume.mo
+%%NLS%%share/locale/it/LC_MESSAGES/vagalume.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/vagalume.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/vagalume.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/vagalume.mo
@dirrm %%DATADIR%%/icons/hicolor/scalable/actions
@dirrm %%DATADIR%%/icons/hicolor/scalable
@dirrm %%DATADIR%%/icons/hicolor
@@ -29,4 +33,23 @@ share/pixmaps/vagalume.xpm
@dirrmtry share/icons/hicolor/48x48
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
+%%NLS%%@dirrmtry share/locale/de/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/de
+%%NLS%%@dirrmtry share/locale/es/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/es
+%%NLS%%@dirrmtry share/locale/fi/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fi
+%%NLS%%@dirrmtry share/locale/fr/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fr
+%%NLS%%@dirrmtry share/locale/gl/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/gl
+%%NLS%%@dirrmtry share/locale/it/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/it
+%%NLS%%@dirrmtry share/locale/lv/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/lv
+%%NLS%%@dirrmtry share/locale/pt/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/pt
+%%NLS%%@dirrmtry share/locale/pt_BR/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/pt_BR
+%%NLS%%@dirrmtry share/locale
@dirrmtry share/applications