aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-11-25 02:38:14 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-11-25 02:38:14 +0800
commit9b19507efcd5651af85c4d67d2de2ae4fa0a8573 (patch)
tree77b3824138564dd3948dfdb39d9ce1bc7eacd701 /audio
parent2882f8e46401e1344bfab0e16a742fbd43666aaa (diff)
downloadfreebsd-ports-gnome-9b19507efcd5651af85c4d67d2de2ae4fa0a8573.tar.gz
freebsd-ports-gnome-9b19507efcd5651af85c4d67d2de2ae4fa0a8573.tar.zst
freebsd-ports-gnome-9b19507efcd5651af85c4d67d2de2ae4fa0a8573.zip
Support staging
Strip binaries
Diffstat (limited to 'audio')
-rw-r--r--audio/autotalent/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/audio/autotalent/Makefile b/audio/autotalent/Makefile
index bcbf468c23c3..268e764aaf80 100644
--- a/audio/autotalent/Makefile
+++ b/audio/autotalent/Makefile
@@ -12,7 +12,6 @@ COMMENT= Real-time pitch correction plugin for LADSPA
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
RUN_DEPENDS:= ${BUILD_DEPENDS}
-NO_STAGE= yes
USES= gmake
MAKE_ARGS= CXX="${CXX}" CC=${CC} CPP=${CPP} \
@@ -28,7 +27,7 @@ post-patch:
${REINPLACE_CMD} -e "s,-O3 -Wall -fomit-frame-pointer -fstrength-reduce -funroll-loops -ffast-math,${CFLAGS}," ${WRKSRC}/Makefile
do-install:
- @${MKDIR} ${PREFIX}/lib/ladspa
- ${INSTALL_DATA} ${WRKSRC}/autotalent.so ${PREFIX}/lib/ladspa
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/ladspa
+ ${INSTALL_LIB} ${WRKSRC}/autotalent.so ${STAGEDIR}${PREFIX}/lib/ladspa
.include <bsd.port.mk>