aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2014-05-18 15:12:26 +0800
committerriggs <riggs@FreeBSD.org>2014-05-18 15:12:26 +0800
commit9baa1b99336381313a873695024c0a3aa22db4d0 (patch)
tree82505edba5680f589e7fcca9f62329b7319a81fa /audio
parent503126223a0bc9434714818309036f9b22e2593a (diff)
downloadfreebsd-ports-gnome-9baa1b99336381313a873695024c0a3aa22db4d0.tar.gz
freebsd-ports-gnome-9baa1b99336381313a873695024c0a3aa22db4d0.tar.zst
freebsd-ports-gnome-9baa1b99336381313a873695024c0a3aa22db4d0.zip
- Introduce OPTION for using boost_regex
- Fix stripping of installed binaries - USE_* -> USES - Bump PORTREVISION Approved by: thierry (mentor)
Diffstat (limited to 'audio')
-rw-r--r--audio/pms/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/audio/pms/Makefile b/audio/pms/Makefile
index b8bcdfba01c7..c0ceb3c2e7ad 100644
--- a/audio/pms/Makefile
+++ b/audio/pms/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pms
PORTVERSION= 0.42
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${PORTVERSION}
@@ -13,19 +13,23 @@ COMMENT= A ncurses-based client for the Music Player Daemon
LICENSE= GPLv3
-LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs
-
-USES= pkgconfig
-USE_BZIP2= yes
+USES= pkgconfig tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= glib20
PLIST_FILES= bin/${PORTNAME} \
man/man1/pms.1.gz
-CONFIGURE_ENV= STRIP=${STRIP_CMD}
-
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= REGEX
+
+REGEX_DESC= Support boost regex pattern matching
+
+REGEX_LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs
+REGEX_CONFIGURE_ENABLE= regex
+
+INSTALL_TARGET= install-strip
+
.include <bsd.port.mk>