aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-18 19:40:34 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-18 19:40:34 +0800
commit9f619b541ca19104bf40683c4ab8b7645c17a06b (patch)
treee0d0204e7b904e419d061398fec005a74bf585ff /audio
parent135200716e245e3e9f84762fa6f1b406cd538628 (diff)
downloadfreebsd-ports-gnome-9f619b541ca19104bf40683c4ab8b7645c17a06b.tar.gz
freebsd-ports-gnome-9f619b541ca19104bf40683c4ab8b7645c17a06b.tar.zst
freebsd-ports-gnome-9f619b541ca19104bf40683c4ab8b7645c17a06b.zip
- Fix typo in post-patch sed expression
- Add explicit LDFLAGS Submitted by: marino Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'audio')
-rw-r--r--audio/mpc/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/audio/mpc/Makefile b/audio/mpc/Makefile
index d1256de0fbdb..1537eccb29dd 100644
--- a/audio/mpc/Makefile
+++ b/audio/mpc/Makefile
@@ -33,12 +33,13 @@ PLIST_FILES= bin/${PORTNAME}
.if ${PORT_OPTIONS:MICONV}
USES+= iconv
+LDFLAGS+= ${ICONV_LIB}
.else
CONFIGURE_ARGS+=--disable-iconv
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-lintl|-l${ICONV_LIB}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lintl|${ICONV_LIB}|g' ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin