aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-11 22:49:59 +0800
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-11 22:49:59 +0800
commit9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /audio
parent0533abe3e7aae5c19e0a0ce9c1e82ed5e94f63e8 (diff)
downloadfreebsd-ports-gnome-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.tar.gz
freebsd-ports-gnome-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.tar.zst
freebsd-ports-gnome-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.zip
Support LIBS like LDFLAGS.
- Add LIBS="${LIBS}" to MAKE_ENV and CONFIGURE_ENV. - Add an option helper for LIBS. - Adjust all ports that already use LIBS. Also remove references to PTHREAD_CFLAGS and PTHREAD_LIBS while here. - Some ports did not support having a LIBS environment variable and required additional patches. Somewhat simplified a linker command line looks like: ${CC} ${src_LDFLAGS} ${LDFLAGS} ${src_LIBS} ${LIBS} where src_LDFLAGS and src_LIBS are controlled by upstream and LDFLAGS and LIBS can be controlled by us. If possible -L and -l flags need to be added to LIBS to make sure they appear after any -L and -l flags set by upstream. Many ports currently add -L${LOCALBASE}/lib to LDFLAGS but this may appear too early on the command line causing installed libraries to be linked in instead of freshly built ones. Additional changes: benchmarks/netio: Replace WITH_IPV6 with an IPV6 option. comms/gnokii: Replace some patches with USES=pathfix. Also remove -fPIC. graphics/gimageview: USES=libtool and install desktop file in DESKTOPDIR. graphics/visionworkbench: Remove FreeBSD 7 support. multimedia/libmovtar: New LIB_DEPENDS syntax. multimedia/opencinematools: Use standard do-build. net/siproxd: USES=libtool:keepla (port actually needs .la files for plugins) net-mgmt/nagios: Remove -fPIC. net-mgmt/nagios4: Remove -fPIC. print/cups-base: Only add -lssp_nonshared on i386 and OSVERSION < 1000036. security/p11-kit: Replace PTHREAD_LIBS in CONFIGURE_ENV with ac_cv_func_pthread_mutexattr_init=no in CONFIGURE_ARGS. This skips a test in configure that falsely detects pthread_mutexattr_init in our libc. sysutils/dar: Fix iconv detection. x11/rxvt-unicode: Remove -lstdc++ and patch configure to remove a FreeBSD hack and use $CXX as linker as on other platforms. PR: 190592 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'audio')
-rw-r--r--audio/deadbeef/Makefile6
-rw-r--r--audio/fdk-aac/Makefile2
-rw-r--r--audio/festival/Makefile22
-rw-r--r--audio/firefly/Makefile4
-rw-r--r--audio/jack/Makefile3
-rw-r--r--audio/mp3plot/Makefile5
-rw-r--r--audio/playgsf/Makefile19
-rw-r--r--audio/pulseaudio/Makefile3
-rw-r--r--audio/rhythmbox/Makefile3
-rw-r--r--audio/rplay/Makefile2
-rw-r--r--audio/spiralsynthmodular/Makefile4
11 files changed, 32 insertions, 41 deletions
diff --git a/audio/deadbeef/Makefile b/audio/deadbeef/Makefile
index 2fe0511889b3..249ff394de89 100644
--- a/audio/deadbeef/Makefile
+++ b/audio/deadbeef/Makefile
@@ -21,9 +21,9 @@ GNU_CONFIGURE= yes
USES= gmake pkgconfig gettext iconv shebangfix tar:bzip2 desktop-file-utils \
libtool
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --disable-alsa --disable-nullout \
- CPPFLAGS="-I../dumb/dumb-kode54/include -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" LIBS="-lexecinfo -lintl"
+CONFIGURE_ARGS= --disable-alsa --disable-nullout
+CPPFLAGS+= -I../dumb/dumb-kode54/include -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib -lexecinfo -lintl
WANT_GNOME= yes
INSTALLS_ICONS= yes
CONFIGURE_ENV+= CONFIG_SHELL="${LOCALBASE}/bin/bash"
diff --git a/audio/fdk-aac/Makefile b/audio/fdk-aac/Makefile
index 7b6a45b606cb..20b0595a8769 100644
--- a/audio/fdk-aac/Makefile
+++ b/audio/fdk-aac/Makefile
@@ -17,7 +17,7 @@ LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
NOT_FOR_ARCHS= sparc64
NOT_FOR_ARCHS_REASON= not yet ported to this architecture
-CONFIGURE_ENV= LIBS="-lm"
+LIBS+= -lm
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USES= pathfix
diff --git a/audio/festival/Makefile b/audio/festival/Makefile
index 41a5815e5ec3..5fb2cd5cca13 100644
--- a/audio/festival/Makefile
+++ b/audio/festival/Makefile
@@ -37,11 +37,9 @@ CONFIGURE_WRKSRC= ${WRKDIR}/festival
USES= gmake
SPEECHTOOLS= ${WRKSRC}/speech_tools
FESTIVAL= ${WRKSRC}/festival
-MAKE_ENV+= GCC="${CC}" \
- GXX="${CXX}" \
- EST_HOME=${SPEECHTOOLS} \
- EGCS_CC="${CC}" \
- EGCS_CXX="${CXX}"
+MAKE_ARGS+= CC="${CC}" GCC="${CC}" \
+ CXX="${CXX}" GXX="${CXX}" \
+ EST_HOME=${SPEECHTOOLS}
WRKSRC= ${WRKDIR}
SPT_PATCHES= base__class_EST__TVector.cc \
@@ -60,14 +58,13 @@ SPT_PATCHES= base__class_EST__TVector.cc \
do-build:
.for d in speech_tools festival
- ${SETENV} ${MAKE_ENV} ${GMAKE} -C ${WRKDIR}/$d ${MAKE_FLAGS} Makefile \
- ${MAKE_ARGS}
+ ${MAKE_CMD} -C ${WRKDIR}/$d ${MAKE_FLAGS} Makefile ${MAKE_ARGS}
.endfor
# Can not make test in `festival', because the voices may not be installed
# XXX: this should fail, if the verdict is not "CORRECT"...
post-build test:
- ${SETENV} ${MAKE_ENV} ${GMAKE} -C ${WRKDIR}/speech_tools test
+ ${MAKE_CMD} -C ${WRKDIR}/speech_tools test
# The below is needed, because Debian's patches expect a different
# directory-name
@@ -96,8 +93,8 @@ CONFIGURE_ARGS+=--disable-$m
do-configure:
.for d in speech_tools festival
@cd ${WRKDIR}/$d && \
- if ! ${SETENV} CC="${CC}" CXX="${CXX}" \
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ if ! ${SETENV} CC="${CC}" CPP="${CPP}" CXX="${CXX}" \
+ CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" CXXFLAGS="${CXXFLAGS}" \
${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}; then \
${ECHO_CMD} "===> configuration script for $d failed."; \
${FALSE}; \
@@ -105,8 +102,9 @@ do-configure:
# This step helps non-i386 systems and is harmless on i386
-${LN} -s ix86_FreeBSD.mak ${WRKDIR}/$d/config/systems/${ARCH}_unknown.mak
.endfor
- ${REINPLACE_CMD} -E -e 's,^(CC|CXX) *=,\1 ?=,' \
- -e 's,^(CFLAGS|CXXFLAGS) *=,\1 +=,' \
+ ${REINPLACE_CMD} \
+ -e '/^CFLAGS *=/s|$$| ${CFLAGS}|' \
+ -e '/^CXXFLAGS *=/s|$$| ${CXXFLAGS}|' \
-e 's,^OPTIMI,#OPTIMI,' \
${WRKSRC}/speech_tools/config/compilers/gcc*.mak
# This step helps to use a compiler, the vendor has not seen before:
diff --git a/audio/firefly/Makefile b/audio/firefly/Makefile
index cd2ef0feb58e..15f3c5334c05 100644
--- a/audio/firefly/Makefile
+++ b/audio/firefly/Makefile
@@ -24,10 +24,8 @@ LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg \
GNU_CONFIGURE= yes
NO_STAGE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CFLAGS+= ${PTHREAD_CFLAGS}
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --prefix=${PREFIX} --with-id3tag=${PREFIX} \
--enable-sqlite3 --enable-oggvorbis --enable-flac
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index 04b09b32df56..55cdb5a3ee19 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -20,11 +20,10 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USES= gmake pathfix pkgconfig libtool:keepla
-CONFIGURE_ENV= LIBS="-pthread"
CONFIGURE_ARGS= --enable-portaudio \
--with-default-tmpdir=/tmp
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
LATEST_LINK= jack
diff --git a/audio/mp3plot/Makefile b/audio/mp3plot/Makefile
index 43d6c75c5f9c..91aa6bf2cb5c 100644
--- a/audio/mp3plot/Makefile
+++ b/audio/mp3plot/Makefile
@@ -20,12 +20,11 @@ LICENSE= GPLv2
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-boost-program-options=boost_program_options \
--with-boost-thread=boost_thread
-CONFIGURE_ENV+= "LIBS=-lboost_system"
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib -lboost_system
.include <bsd.port.options.mk>
diff --git a/audio/playgsf/Makefile b/audio/playgsf/Makefile
index a11a23539eeb..dda730b3ee72 100644
--- a/audio/playgsf/Makefile
+++ b/audio/playgsf/Makefile
@@ -19,8 +19,6 @@ GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_ENV+= LIBS="${LDFLAGS}"
-CONFIGURE_ENV+= LIBS="${LDFLAGS}"
CONFIGURE_ARGS+= --enable-ccore --disable-optimisations
PLIST_FILES= bin/playgsf
@@ -29,7 +27,7 @@ ONLY_FOR_ARCHS= i386 amd64
PORTSCOUT= skipv:0.7.2
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${OSVERSION} >= 901000
EXTRA_PATCHES= ${FILESDIR}/extrapatch-VBA__Util.cpp
@@ -37,19 +35,20 @@ EXTRA_PATCHES= ${FILESDIR}/extrapatch-VBA__Util.cpp
post-patch:
@${REINPLACE_CMD} \
- -e 's|\(@LDFLAGS@\)|\1 ${LDFLAGS}|' \
-e 's|\([[:space:]]*\).*configure.*|\1@true|' \
${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|^\(CFLAGS="\)\(-DLINUX\)|\1${CFLAGS} \2|' \
+ @${REINPLACE_CMD} \
+ -e '/^CFLAGS="-DLINUX/s|"$$| ${CFLAGS}"|' \
+ -e '/^LDFLAGS="-lz/s|"$$| ${LDFLAGS}"|' \
${WRKSRC}/configure
post-configure:
- @(cd ${WRKSRC}/libresample-0.1.3; ./configure ${CONFIGURE_ENV})
+ @(cd ${WRKSRC}/libresample-0.1.3 && ${SETENV} \
+ CC="${CC}" CPP="${CPP}" CXX="${CXX}" \
+ CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ ${CONFIGURE_ENV} ./configure)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
-post-install:
- ${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index 1a3f12688f5a..09b3e04e933e 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -35,10 +35,9 @@ CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
OPENSSL_CFLAGS="-I/usr/include" \
OPENSSL_LIBS="-lcrypto -lssl" \
- LIBS="-lm -lintl" \
ac_cv_header_linux_input_h=
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lm -lintl
.if ${CC} == clang
CFLAGS+= -fheinous-gnu-extensions
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index 64b131c5a8e6..737782a3bdf2 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -36,10 +36,9 @@ CONFIGURE_ARGS= --disable-vala --with-libbrasero-media \
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-CONFIGURE_ENV= LIBS="-lm"
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lm
GCONF_SCHEMAS= rhythmbox.schemas
diff --git a/audio/rplay/Makefile b/audio/rplay/Makefile
index 5a7ea8355d80..d77645a51f4c 100644
--- a/audio/rplay/Makefile
+++ b/audio/rplay/Makefile
@@ -14,8 +14,8 @@ LIB_DEPENDS= libgsm.so:${PORTSDIR}/audio/gsm
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
INFO= RPLAY RPTP librplay rplayd
diff --git a/audio/spiralsynthmodular/Makefile b/audio/spiralsynthmodular/Makefile
index 27d8616ff278..aa14603cbb63 100644
--- a/audio/spiralsynthmodular/Makefile
+++ b/audio/spiralsynthmodular/Makefile
@@ -19,9 +19,9 @@ LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk \
USE_XORG= x11
GNU_CONFIGURE= yes
-CONFIGURE_ENV= FLTK_CONFIG="${FLTK_CONFIG}" \
- LIBS="${LIBS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ENV= FLTK_CONFIG="${FLTK_CONFIG}"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/spiralmodular-0.2.2