aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2012-10-06 22:52:14 +0800
committereadler <eadler@FreeBSD.org>2012-10-06 22:52:14 +0800
commita3b4457f8ab58865bdcd036d62541e5dd5c0481e (patch)
treebb78ece5203a433b6199fb23bce1cd4695c4e65e /audio
parentdc9934c5e3c6bb534269d9ab0600e3a98e73c26a (diff)
downloadfreebsd-ports-gnome-a3b4457f8ab58865bdcd036d62541e5dd5c0481e.tar.gz
freebsd-ports-gnome-a3b4457f8ab58865bdcd036d62541e5dd5c0481e.tar.zst
freebsd-ports-gnome-a3b4457f8ab58865bdcd036d62541e5dd5c0481e.zip
Covert to OptionsNG
Trim header file Remove extraneous LICENSE_FILE
Diffstat (limited to 'audio')
-rw-r--r--audio/audex/Makefile27
1 files changed, 9 insertions, 18 deletions
diff --git a/audio/audex/Makefile b/audio/audex/Makefile
index 49811a3da36b..f1d3d5ed1a29 100644
--- a/audio/audex/Makefile
+++ b/audio/audex/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: audex
-# Date Created: 2009-05-20
-# Whom: Jason E. Hale <bsdkaffee@gmail.com>
-#
# $FreeBSD$
-#
PORTNAME= audex
DISTVERSION= 0.74b1
@@ -25,18 +20,14 @@ USE_QT4= gui dbus network svg xml \
MAKE_JOBS_SAFE= yes
LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/LICENCE
-OPTIONS= NLS "Native language support" on \
- FAAC "Depend on audio/faac for m4a encoding" off \
- FLAC "Depend on audio/flac for flac encoding" on \
- LAME "Depend on audio/lame for mp3 encoding" off \
- EYED3 "Depend on audio/py-eyed3 for Unicode mp3 tags" off \
- OGG "Depend on audio/vorbis-tools for ogg encoding" on
+OPTIONS_DEFINE= FAAC FLAC LAME EYED3 OGG
+OPTIONS_DEFAULT= FLAC OGG
+EYED3_DESC= Unicode mp3 tags support
.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
+.if !${PORT_OPTIONS:MNLS}
CMAKE_ARGS+= -DDISABLE_ALL_OPTIONAL_SUBDIRECTORIES=TRUE
PLIST_SUB+= NLS="@comment "
.else
@@ -44,23 +35,23 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
-.if defined(WITH_FAAC)
+.if ${PORT_OPTIONS:MFAAC}
RUN_DEPENDS+= faac:${PORTSDIR}/audio/faac
.endif
-.if defined(WITH_FLAC)
+.if ${PORT_OPTIONS:MFLAC}
RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
.endif
-.if defined(WITH_LAME)
+.if ${PORT_OPTIONS:MLAME}
RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
.endif
-.if defined(WITH_EYED3)
+.if ${PORT_OPTIONS:MEYED3}
RUN_DEPENDS+= eyeD3:${PORTSDIR}/audio/py-eyed3
.endif
-.if defined(WITH_OGG)
+.if ${PORT_OPTIONS:MOGG}
RUN_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
.endif