aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2003-11-12 07:26:45 +0800
committerfjoe <fjoe@FreeBSD.org>2003-11-12 07:26:45 +0800
commita4d1343b2b7fbdfd6b1866094c2716f2c0e6c534 (patch)
treea3f21fa456b89ef9ad59b85190836cddf95ae359 /audio
parent812a1789ad2f79f1dac5a0537cb56df0e540aea3 (diff)
downloadfreebsd-ports-gnome-a4d1343b2b7fbdfd6b1866094c2716f2c0e6c534.tar.gz
freebsd-ports-gnome-a4d1343b2b7fbdfd6b1866094c2716f2c0e6c534.tar.zst
freebsd-ports-gnome-a4d1343b2b7fbdfd6b1866094c2716f2c0e6c534.zip
New port: xmms-arts -- aRts plugin for xmms.
LD_PRELOAD magic is needed to run xmms-arts atm. (see pkg-message).
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/xmms-arts/Makefile32
-rw-r--r--audio/xmms-arts/distinfo1
-rw-r--r--audio/xmms-arts/files/patch-ltmain.sh25
-rw-r--r--audio/xmms-arts/files/pkg-message.in16
-rw-r--r--audio/xmms-arts/pkg-descr7
-rw-r--r--audio/xmms-arts/pkg-plist3
7 files changed, 85 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 11d1f72c284b..c0c8913c1aca 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -359,6 +359,7 @@
SUBDIR += xmixer
SUBDIR += xmmix
SUBDIR += xmms-a52dec
+ SUBDIR += xmms-arts
SUBDIR += xmms-audiofile
SUBDIR += xmms-bonk
SUBDIR += xmms-cdparanoia
diff --git a/audio/xmms-arts/Makefile b/audio/xmms-arts/Makefile
new file mode 100644
index 000000000000..00ad9b91f708
--- /dev/null
+++ b/audio/xmms-arts/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: xmms-arts
+# Date created: 12 Nov 2003
+# Whom: Max Khon <fjoe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-arts
+PORTVERSION= 0.6.0
+CATEGORIES= audio
+MASTER_SITES= http://havardk.xmms.org/plugins/arts_output/
+DISTNAME= arts_output-${PORTVERSION}
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= aRts output plugin for XMMS.
+
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
+ artsc.0:${PORTSDIR}/audio/arts
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk12
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-install:
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ <${FILESDIR}/pkg-message.in >${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-arts/distinfo b/audio/xmms-arts/distinfo
new file mode 100644
index 000000000000..77233619b400
--- /dev/null
+++ b/audio/xmms-arts/distinfo
@@ -0,0 +1 @@
+MD5 (arts_output-0.6.0.tar.gz) = 6539123bd1dbebcf57073392da13d992
diff --git a/audio/xmms-arts/files/patch-ltmain.sh b/audio/xmms-arts/files/patch-ltmain.sh
new file mode 100644
index 000000000000..f9b9343c2295
--- /dev/null
+++ b/audio/xmms-arts/files/patch-ltmain.sh
@@ -0,0 +1,25 @@
+--- ltmain.sh.orig Wed Aug 6 19:13:39 2003
++++ ltmain.sh Tue Nov 11 22:47:49 2003
+@@ -1075,7 +1075,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1084,6 +1084,13 @@
+ deplibs="$deplibs $arg"
+ continue
+ ;;
++
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
+
+ -module)
+ module=yes
diff --git a/audio/xmms-arts/files/pkg-message.in b/audio/xmms-arts/files/pkg-message.in
new file mode 100644
index 000000000000..7293221d73b0
--- /dev/null
+++ b/audio/xmms-arts/files/pkg-message.in
@@ -0,0 +1,16 @@
+In order to use aRts plugin on FreeBSD you must to do the following:
+
+1) Move xmms binary to xmms.bin:
+
+cd %%PREFIX%%/bin && mv xmms xmms.bin
+
+2) Write custom xmms script:
+
+--- cut here ---
+#!/bin/sh
+LD_PRELOAD=/usr/lib/libstdc++.so exec %%PREFIX%%/bin/xmms.bin "$@"
+--- cut here ---
+
+and put it to %%PREFIX%%/bin
+
+/fjoe
diff --git a/audio/xmms-arts/pkg-descr b/audio/xmms-arts/pkg-descr
new file mode 100644
index 000000000000..b9c4b37aba38
--- /dev/null
+++ b/audio/xmms-arts/pkg-descr
@@ -0,0 +1,7 @@
+Xmms-CdRead is a input plugin for XMMS (www.xmms.org) that
+read the CDDA (audio) discs as data via IDE bus, provides
+more quality sound and allowing XMMS to use that for
+visualization.
+
+Author: Willem Monsuwe <willem@stack.nl>
+Mountainer: Sergey V. Belov (aka Argail) <argail@visit.ru>
diff --git a/audio/xmms-arts/pkg-plist b/audio/xmms-arts/pkg-plist
new file mode 100644
index 000000000000..11e315bb9cb9
--- /dev/null
+++ b/audio/xmms-arts/pkg-plist
@@ -0,0 +1,3 @@
+lib/xmms/Output/libarts.a
+lib/xmms/Output/libarts.la
+lib/xmms/Output/libarts.so