aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2017-04-18 11:26:48 +0800
committermiwi <miwi@FreeBSD.org>2017-04-18 11:26:48 +0800
commita4fdf6ff8b00608f8fdb710e4f5159fb20e6ae77 (patch)
tree8a316d25eb842aa9b0cbb47a246558c4c99d6b0b /audio
parent6102b071af7474147316d4575686f4eba9100438 (diff)
downloadfreebsd-ports-gnome-a4fdf6ff8b00608f8fdb710e4f5159fb20e6ae77.tar.gz
freebsd-ports-gnome-a4fdf6ff8b00608f8fdb710e4f5159fb20e6ae77.tar.zst
freebsd-ports-gnome-a4fdf6ff8b00608f8fdb710e4f5159fb20e6ae77.zip
- Switch to options helper
- Fix shebangs
Diffstat (limited to 'audio')
-rw-r--r--audio/py-shout/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/audio/py-shout/Makefile b/audio/py-shout/Makefile
index d358a3ad442b..7126f24d0502 100644
--- a/audio/py-shout/Makefile
+++ b/audio/py-shout/Makefile
@@ -3,7 +3,7 @@
PORTNAME= shout
PORTVERSION= 0.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio python
MASTER_SITES= http://downloads.us.xiph.org/releases/libshout/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,16 +14,19 @@ COMMENT= Python bindings for libshout2
LICENSE= LGPL20
+OPTIONS_DEFINE= EXAMPLES
+
LIB_DEPENDS= libshout.so:audio/libshout
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
-USES= pkgconfig python:2
+USES= pkgconfig python:2 shebangfix
+SHEBANG_FILES= example.py
USE_PYTHON= distutils autoplist
PORTEXAMPLES= example.py
-post-install:
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${CP} ${WRKSRC}/example.py ${STAGEDIR}${EXAMPLESDIR}