aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-10-26 15:55:22 +0800
committernemysis <nemysis@FreeBSD.org>2013-10-26 15:55:22 +0800
commita723d5876fc651b14204835fe635da5efe24b64f (patch)
tree7bccf171f1845202ffcfc7016a07205558a45e9d /audio
parent1fed3a8d0e2983bf3fa925369ad3516e9e9bfe89 (diff)
downloadfreebsd-ports-gnome-a723d5876fc651b14204835fe635da5efe24b64f.tar.gz
freebsd-ports-gnome-a723d5876fc651b14204835fe635da5efe24b64f.tar.zst
freebsd-ports-gnome-a723d5876fc651b14204835fe635da5efe24b64f.zip
- Bump PORTREVISION for dependency change
- Fix portaudio2 dependency due to recent commit - Support STAGEDIR and add OPTIONS_SUB Approved by: pawel / wg (mentors, implicit)
Diffstat (limited to 'audio')
-rw-r--r--audio/fmit/Makefile55
1 files changed, 21 insertions, 34 deletions
diff --git a/audio/fmit/Makefile b/audio/fmit/Makefile
index 3dc6c2fff262..423fda154c8b 100644
--- a/audio/fmit/Makefile
+++ b/audio/fmit/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fmit
PORTVERSION= 0.99.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://download.gna.org/fmit/
DISTNAME= ${PORTNAME}-${PORTVERSION}-Source
@@ -15,11 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3
-OPTIONS_DEFINE= OSS ALSA PORTAUDIO JACK
-OPTIONS_DEFAULT= OSS JACK
-
USE_BZIP2= yes
-NO_STAGE= yes
USE_XORG= xmu
USE_QT4= corelib gui opengl \
linguist_build moc_build qmake_build rcc_build uic_build
@@ -27,34 +23,25 @@ USE_GL= glut
USES= cmake
INSTALLS_ICONS= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MOSS}
-CMAKE_ARGS+= -DSOUNDSYSTEM_USE_OSS:BOOL=true
-.else
-CMAKE_ARGS+= -DSOUNDSYSTEM_USE_OSS:BOOL=false
-.endif
-
-.if ${PORT_OPTIONS:MALSA}
-LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
-CMAKE_ARGS+= -DSOUNDSYSTEM_USE_ALSA:BOOL=true
-.else
-CMAKE_ARGS+= -DSOUNDSYSTEM_USE_ALSA:BOOL=false
-.endif
-
-.if ${PORT_OPTIONS:MPORTAUDIO}
-BUILD_DEPENDS+= portaudio>=19:${PORTSDIR}/audio/portaudio2
-RUN_DEPENDS+= portaudio>=19:${PORTSDIR}/audio/portaudio2
-CMAKE_ARGS+= -DSOUNDSYSTEM_USE_PORTAUDIO:BOOL=true
-.else
-CMAKE_ARGS+= -DSOUNDSYSTEM_USE_PORTAUDIO:BOOL=false
-.endif
-
-.if ${PORT_OPTIONS:MJACK}
-LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
-CMAKE_ARGS+= -DSOUNDSYSTEM_USE_JACK:BOOL=true
-.else
-CMAKE_ARGS+= -DSOUNDSYSTEM_USE_JACK:BOOL=false
-.endif
+OPTIONS_DEFINE= ALSA JACK OSS PORTAUDIO
+OPTIONS_DEFAULT= JACK OSS
+
+OPTIONS_SUB= yes
+
+ALSA_LIB_DEPENDS= libasound.so.2:${PORTSDIR}/audio/alsa-lib
+ALSA_CMAKE_ON= -DSOUNDSYSTEM_USE_ALSA:BOOL=true
+ALSA_CMAKE_OFF= -DSOUNDSYSTEM_USE_ALSA:BOOL=false
+
+OSS_CMAKE_ON= -DSOUNDSYSTEM_USE_OSS:BOOL=true
+OSS_CMAKE_OFF= -DSOUNDSYSTEM_USE_OSS:BOOL=false
+
+JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
+JACK_CMAKE_ON= -DSOUNDSYSTEM_USE_JACK:BOOL=true
+JACK_CMAKE_OFF= -DSOUNDSYSTEM_USE_JACK:BOOL=false
+
+PORTAUDIO_BUILD_DEPENDS= portaudio2>=0:${PORTSDIR}/audio/portaudio2
+PORTAUDIO_RUN_DEPENDS= portaudio2>=0:${PORTSDIR}/audio/portaudio2
+PORTAUDIO_CMAKE_ON= -DSOUNDSYSTEM_USE_PORTAUDIO:BOOL=true
+PORTAUDIO_CMAKE_OFF= -DSOUNDSYSTEM_USE_PORTAUDIO:BOOL=false
.include <bsd.port.mk>
pan> * Use the SORT macro from bsd.port.mk.trevor2004-01-2212-12/+6 * I have no idea how these features* files made the way to my machine,alex2004-01-221-10/+0 * . Add ${LOCALBASE}/lib to the default search path for JNI libraries forglewis2004-01-212-3/+21 * . Add ${LOCALBASE}/lib to the default search path for libraries when usingglewis2004-01-202-1/+19 * . Add ${LOCALBASE}/lib to the default search path for libraries when usingglewis2004-01-202-2/+17 * . Convert spaces to tabs.glewis2004-01-201-8/+8 * . More standard format for substitution in pkg-message.glewis2004-01-202-2/+7 * Update to 1.2.6arved2004-01-194-37/+13 * Fix install.nork2004-01-182-3/+9 * . Check the return value of stat(2) when trying to read the javawsglewis2004-01-176-0/+51 * . Install an updated cacerts file. This was produced by taking theglewis2004-01-172-1/+2 * . Install an updated cacerts file. This was produced by taking theglewis2004-01-172-0/+2 * . Adjust download instructions for new download URL.glewis2004-01-171-2/+3 * . Convert a space to a tab.glewis2004-01-171-2/+3 * . Add cacerts file missed in last commit.glewis2004-01-171-0/+0 * . Install the cacerts file from Sun's 1.3.1_10 release to avoid someglewis2004-01-171-1/+2 * . Update to 1.3.1 SR6 [1]glewis2004-01-173-2/+3 * . Install an updated cacerts file. This was produced by taking theglewis2004-01-162-0/+3 * . Use the correct variables for appending to CPPFLAGS and LDFLAGS. Thisglewis2004-01-161-0/+15 * . Update to 1.4.2 patchset 6.glewis2004-01-1521-114/+60 * . Install the cacerts file from Sun's 1.3.1_10 release to avoid someglewis2004-01-152-0/+2 * Add missing rundepends to eclipse-emf (reminded by olgeni),alex2004-01-141-1/+3 * Improved download URL to be more specific.znerd2004-01-141-1/+1 * Improved download URL to be more specific.znerd2004-01-141-1/+1 * Minor patch to remove bogus dependancy and to stop portlint FATAL error.znerd2004-01-143-9/+0 * First-class GUI building tools for Eclipsealex2004-01-145-0/+777 * Add Eclipse Modeling Frameworkalex2004-01-145-0/+459 * Add Eclipse XML Schema Infoset Modelalex2004-01-145-0/+256 * . Use MASTER_SITE_APACHE_JAKARTA to fetch the distfile.glewis2004-01-141-1/+2 * Add phpeclipse_phphelp 1.0.4, PHP Eclipse Help for the Eclipse IDEalex2004-01-135-0/+39 * Add phpeclipse_tidy 1.0.2, PHP Eclipse HTML tidier plugin for Eclipsealex2004-01-135-0/+46 * Add phpeclipse_sql 1.0.1, PHP Eclipse SQL Utility plugin for Eclipse IDEalex2004-01-135-0/+71 * Add phpeclipse 1.0.8, PHP Eclipse adds PHP support to the Eclipse IDEalex2004-01-135-0/+128 * Log:znerd2004-01-133-71/+169 * Removed share/nls/POSIX and share/nls/en_US.US-ASCII.znerd2004-01-132-4/+0 * Using MASTER_SITE_APACHE_JAKARTA.znerd2004-01-132-3/+5 * . Update to 0.38.glewis2004-01-122-2/+2 * Add jai-imageio 1.0, which is JAI Image I/O Tools provides reader,nork2004-01-117-0/+129 * Add jai 1.1.2, which is Java Advanced Imaging (JAI) API providesnork2004-01-117-0/+130 * o Print pkg-message for setting libmap.conf.nork2004-01-114-7/+62 * . Update to 1.3.1_10.glewis2004-01-112-9/+5 * Add eclipse-pmd 1.1.2, scan Java source code and look for potentialpetef2004-01-105-0/+92 * assign maintainer to java@, requested by maintainer des.alfred2004-01-091-1/+1 * Update to 2.1.2.nork2004-01-083-454/+1981 * Update to 3.2.3 and enable building from source. It remains to belinimon2004-01-079-5232/+120 * . Update to 1.4.2-rc1.glewis2004-01-073-438/+88 * [maintainer update] java/kaffe-devel update to 1.1.3edwin2004-01-035-35/+38 * Don't use a leading zero in PORTREVISION, it confuses the pkg* tools andalfred2004-01-031-4/+4 * Improved DOWNLOAD_URL.znerd2004-01-021-1/+1 * Add Linux Blackdown Java3D 1.3.1, provides a set of object-orientednork2003-12-305-0/+564 * Remove java/orion again, it was a duplicate of www/orionedwin2003-12-298-459/+0 * [new port]: java/orionedwin2003-12-298-0/+459 * New port: Sun JDK 1.5.x for Linux.znerd2003-12-2413-0/+4071 * . Update to 1.3.1 patchset 9.glewis2003-12-2016-1347/+16 * Don't use patch release number while setting up BUILD_DEPENDS forphantom2003-12-163-6/+9 * . Update to 3.2.glewis2003-12-163-190/+22 * Add a port of jaxen:glewis2003-12-165-0/+64 * . Update to jmp 0.37.glewis2003-12-162-2/+2 * Update to 1.4.2_03.znerd2003-12-152-6/+5 * Updated message:znerd2003-12-151-2/+2 * . Simplify the documentation handling using PORTDOCS. This also meansglewis2003-12-102-498/+68 * . Simplify the packing list by using PORTDOCS.glewis2003-12-092-360/+8 * New port jakarta-commons-primitives:glewis2003-12-095-0/+58 * . Wrap the PORTDOCS setting in .if !defined(NOPORTDOCS) .. .endif.glewis2003-12-091-0/+2 * New port java/avalon-logkit:glewis2003-12-095-0/+68 * Upgrade to Eclipse 2.1.2.olgeni2003-12-0411-1510/+1528 * . Simplify packing list [1]glewis2003-11-213-73/+2 * . Simplify the packing list [1]glewis2003-11-212-43/+3 * USE_REINPLACE need be defined only when REINPLACE_CMD is used.trevor2003-11-174-4/+0 * Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.trevor2003-11-136-8/+9 * Fix path to patched file.phantom2003-11-123-6/+6 * Fix bootstrap jdk detection process, so it work in case if no valid jdkphantom2003-11-123-12/+33 * Add patch to fix build problems on 5.x system reported by many people.phantom2003-11-123-0/+39 * add jfreechart 0.9.13ijliao2003-11-125-0/+39 * add jcommon 0.8.8ijliao2003-11-125-0/+36 * . Update to 1.4.2_02.glewis2003-11-122-5/+4 * Update to 1.4.2p5.phantom2003-11-1233-858/+855 * Update commons-[dbcp|pool] to 1.1.osa2003-11-116-101/+107 * Add iconv encoding support.archie2003-11-111-0/+5 * Don't redefine ECHO_MSG to echo explicitly. It b0rked IGNORE messages.phantom2003-11-103-3/+0 * . Update to 3.2.2glewis2003-11-059-165/+2886 * Reset maintainer on ports owned by the following committers who havekris2003-11-031-1/+1 * undo previous commit.edwin2003-11-021-1/+1 * ports with possibly unreachable MAINTAINERsedwin2003-11-021-1/+1 * ports with possibly unreachable MAINTAINERsedwin2003-11-021-1/+1 * Fix email addressedwin2003-11-021-1/+1 * - Chase MAINTAINER e-mail changessergei2003-10-301-1/+1 * Fix a comment, the first line was "apache New ports" (apache -> #).olgeni2003-10-301-1/+1 * People should report problems with this port to maintainers. Make thekan2003-10-301-1/+0 * . Add fix for "runaway process" problem. It should fix of stalledphantom2003-10-299-6/+285 * . Fix the plugin build when LOCALBASE is not /usr/local.glewis2003-10-291-1/+2 * Update to 1.8.fjoe2003-10-285-11/+69 * . Update to 1.4.1 Service Release 1.glewis2003-10-243-71/+5 * . Add PLIST_SUB settings that somehow didn't get committed. This unbreaksglewis2003-10-231-0/+4 * . Sort PTHREAD_FILES.glewis2003-10-213-6/+9 * . Update to 1.1.16.glewis2003-10-176-85/+339 * . Fix pre-everything target.glewis2003-10-171-1/+1 * BROKEN on 5.x: does not compilekris2003-10-161-1/+7 * . Add a missing BUILD_DEPENDS on NSPR so the plugin builds.glewis2003-10-143-3/+6 * . Override PKGINSTALL to place it in WRKDIR, which is writeable, ratherglewis2003-10-134-0/+4 * . Install system preferences during post-install to avoid annoying errorglewis2003-10-113-1/+28 * . Update to 1.4.1p4.glewis2003-10-1124-177/+1839 * . Unset -Werror when compiling the NIO stuff. GCC 3.3.1 tends to generateglewis2003-10-113-0/+39 * . Update to 1.3glewis2003-10-102-5/+7 * [maintainer update] Update java/jakarta-oroedwin2003-10-102-3/+4 * Add slash to WWW tag.osa2003-10-082-4/+2 * . Use ${PTHREAD_LIBS} rather than -pthread.glewis2003-10-082-1/+30 * . Make HotSpot compile with gcc 3.3.1.glewis2003-10-084-0/+151 * . Update to 1.2.2.017.glewis2003-10-073-5/+7 * New port: Jakarta Commons DBCP.znerd2003-10-066-0/+149 * New port: Jakarta Commons Pool.znerd2003-10-065-0/+105 * . Update to 0.35.glewis2003-10-052-2/+2 * . Sync with the change to linux-sun-jdk14 (it now installs inglewis2003-10-023-3/+3 * . Install in ${LOCALBASE}/linux-sun-jdk1.4.2, notglewis2003-10-011-3/+5 * . Unbreak this port. The binaries call the program "arch" to determineglewis2003-09-304-6/+47 * [new port] java/gj[-jdk11]: Generic Javaedwin2003-09-299-0/+714 * [new port] java/gj[-jdk11]: Generic Javaedwin2003-09-291-0/+1 * New port: java/linux-blackdown-jre11: Blackdown Linux JRE 1.1.8edwin2003-09-297-0/+199