aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2004-11-23 11:57:49 +0800
committerahze <ahze@FreeBSD.org>2004-11-23 11:57:49 +0800
commita7eb053e8f29ba8ca7b2caf447589cc4ae404a0c (patch)
tree2302a5897b2b0b3fac9c1ffea8d89cb46f2a7323 /audio
parent7b07354d4efb5ac41219f79342f0485c32a3d75a (diff)
downloadfreebsd-ports-gnome-a7eb053e8f29ba8ca7b2caf447589cc4ae404a0c.tar.gz
freebsd-ports-gnome-a7eb053e8f29ba8ca7b2caf447589cc4ae404a0c.tar.zst
freebsd-ports-gnome-a7eb053e8f29ba8ca7b2caf447589cc4ae404a0c.zip
Don't build not needed libraries
PR: ports/72176 Approved by: maintainer timeout (20 days) adamw (mentor)
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms-faad/Makefile11
-rw-r--r--audio/xmms-faad/files/patch-plugins_xmms_src_Makefile.in12
2 files changed, 15 insertions, 8 deletions
diff --git a/audio/xmms-faad/Makefile b/audio/xmms-faad/Makefile
index a93ec4c5d83d..909959e7d8f2 100644
--- a/audio/xmms-faad/Makefile
+++ b/audio/xmms-faad/Makefile
@@ -42,6 +42,9 @@ DESCR= ${PORTSDIR}/audio/faad/pkg-descr
MD5_FILE= ${PORTSDIR}/audio/faad/distinfo
PLIST_FILES= lib/xmms/Input/libmp4.so
+BUILD_WRKSRC= ${WRKSRC}/plugins/xmms/src
+INSTALL_WRKSRC= ${WRKSRC}/plugins/xmms/src
+
pre-patch: build-depends
post-patch:
@@ -58,12 +61,4 @@ post-patch:
${REINPLACE_CMD} -e \
's|-O2|${CFLAGS}|'
-do-build:
- @cd ${WRKSRC}/libfaad && ${MAKE}
- @cd ${WRKSRC}/common/mp4v2 && ${MAKE}
- @cd ${WRKSRC}/plugins/xmms/src && ${MAKE}
-
-do-install:
- @cd ${WRKSRC}/plugins/xmms/src && ${MAKE} install
-
.include <bsd.port.mk>
diff --git a/audio/xmms-faad/files/patch-plugins_xmms_src_Makefile.in b/audio/xmms-faad/files/patch-plugins_xmms_src_Makefile.in
new file mode 100644
index 000000000000..b53d2218625e
--- /dev/null
+++ b/audio/xmms-faad/files/patch-plugins_xmms_src_Makefile.in
@@ -0,0 +1,12 @@
+--- plugins/xmms/src/Makefile.am.orig Wed Sep 29 13:33:13 2004
++++ plugins/xmms/src/Makefile.am Wed Sep 29 13:34:27 2004
+@@ -5,8 +5,7 @@
+ `$(GTK_CONFIG) --cflags` -DHAVE_GLIB_H=1 \
+ -I$(top_srcdir)/include -I$(top_srcdir)/common/mp4v2
+
+-libmp4_la_LIBADD = $(top_builddir)/libfaad/libfaad.la \
+- $(top_builddir)/common/mp4v2/libmp4v2.la
++LIBS= -lfaad -lmp4v2
+
+ libmp4_la_LDFLAGS = -module -avoid-version `$(XMMS_CONFIG) --libs` \
+ `$(GTK_CONFIG) --libs` -lpthread -lstdc++