aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2013-06-15 20:41:52 +0800
committernivit <nivit@FreeBSD.org>2013-06-15 20:41:52 +0800
commitab8f7d9ede25867f0be1141b0a563be1b84f8bcb (patch)
tree630a8c3ce00186fd46c0f144c06103b055ed3ca4 /audio
parent36821bfe8bd5f12047c656900bf18abc13611e85 (diff)
downloadfreebsd-ports-gnome-ab8f7d9ede25867f0be1141b0a563be1b84f8bcb.tar.gz
freebsd-ports-gnome-ab8f7d9ede25867f0be1141b0a563be1b84f8bcb.tar.zst
freebsd-ports-gnome-ab8f7d9ede25867f0be1141b0a563be1b84f8bcb.zip
- Update to 1.47.11
- Trim Makefile header - Add LICENSE (GPLv3) - Add radio option AUDIO_SYSTEM (default PORTAUDIO) - Remove USE_GCC - Convert to the new option framework - Remove Author field from pkg-descr, fix WWW one Build log: http://goo.gl/BWger
Diffstat (limited to 'audio')
-rw-r--r--audio/espeak/Makefile46
-rw-r--r--audio/espeak/distinfo4
-rw-r--r--audio/espeak/pkg-descr3
-rw-r--r--audio/espeak/pkg-plist156
4 files changed, 129 insertions, 80 deletions
diff --git a/audio/espeak/Makefile b/audio/espeak/Makefile
index 290d1f7ef04d..1958d8042130 100644
--- a/audio/espeak/Makefile
+++ b/audio/espeak/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: espeak
-# Date created: 2006-03-25
-# Whom: Nicola Vitale <nivit@email.it>
-#
+# Created by: Nicola Vitale <nivit@email.it>
# $FreeBSD$
-#
PORTNAME= espeak
-PORTVERSION= 1.46.02
-PORTREVISION= 1
+PORTVERSION= 1.47.11
+PORTREVISION= 0
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -15,22 +11,19 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-source
MAINTAINER= nivit@FreeBSD.org
COMMENT= A software speech synthesizer
+LICENSE= GPLv3
+
# default is runtime audio detection
LIB_DEPENDS= ${PORTAUDIOLIB} \
${PULSEAUDIOLIB}
-PULSEAUDIOLIB= pulse:${PORTSDIR}/audio/pulseaudio
-PORTAUDIOLIB= portaudio:${PORTSDIR}/audio/portaudio
+OPTIONS_DEFAULT= PORTAUDIO
+OPTIONS_RADIO= AUDIO_SYSTEM
+OPTIONS_RADIO_AUDIO_SYSTEM= PORTAUDIO PULSEAUDIO RUNTIME
+RUNTIME_DESC= Sound interface selected at runtime
-.if (!defined(WITH_PULSEAUDIO) && !defined(WITH_PORTAUDIO)) || (defined(WITH_PULSEAUDIO) && defined(WITH_PORTAUDIO))
-AUDIO= "runtime"
-.elif defined(WITH_PULSEAUDIO)
-AUDIO= "pulseaudio"
-PORTAUDIOLIB=
-.else
-AUDIO= "portaudio"
-PULSEAUDIOLIB=
-.endif
+PORTAUDIOLIB= portaudio:${PORTSDIR}/audio/portaudio
+PULSEAUDIOLIB= pulse:${PORTSDIR}/audio/pulseaudio
CONFLICTS= speak-1.[0-9]
@@ -40,7 +33,6 @@ MAKE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
CXXFLAGS+= -I${LOCALBASE}/include
USE_GMAKE= yes
-USE_GCC= 4.2+
USE_LDCONFIG= yes
USE_ZIP= yes
@@ -51,11 +43,25 @@ INSTALL_WRKSRC= ${WRKSRC}/src
REINPLACE_FILES= Makefile speech.h
REINPLACE_ARGS= -i.bak -e "s|%%DATADIR%%|${DATADIR}|g"
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MRUNTIME}
+AUDIO= "runtime"
+.endif
+.if ${PORT_OPTIONS:MPULSEAUDIO}
+AUDIO= "pulseaudio"
+PORTAUDIOLIB=
+.endif
+.if ${PORT_OPTIONS:MPORTAUDIO}
+AUDIO= "portaudio"
+PULSEAUDIOLIB=
+.endif
+
post-patch:
cd ${BUILD_WRKSRC} && ${REINPLACE_CMD} ${REINPLACE_FILES}
+.if ${PORT_OPTIONS:MDOCS}
post-install:
-.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
diff --git a/audio/espeak/distinfo b/audio/espeak/distinfo
index 3a31a19d265d..4672080f9f2e 100644
--- a/audio/espeak/distinfo
+++ b/audio/espeak/distinfo
@@ -1,2 +1,2 @@
-SHA256 (espeak-1.46.02-source.zip) = ef8beba25bd261718582d5cbb1f10293007eb525b705ff79c9fb3f505dd954ba
-SIZE (espeak-1.46.02-source.zip) = 2387543
+SHA256 (espeak-1.47.11-source.zip) = 9bd4d0569af48a2cb13fa76704dec3124d27025a3f21c87598457976472b360c
+SIZE (espeak-1.47.11-source.zip) = 2813649
diff --git a/audio/espeak/pkg-descr b/audio/espeak/pkg-descr
index c717c4e35f51..c22f1f8370f0 100644
--- a/audio/espeak/pkg-descr
+++ b/audio/espeak/pkg-descr
@@ -8,5 +8,4 @@ articulation clearer and easier to listen to for long periods.
It can run as a command line program to speak text from a file or
from stdin.
-Author: Jonathan Duddington
-WWW: http://espeak.sourceforge.net/
+WWW: http://espeak.sourceforge.net/
diff --git a/audio/espeak/pkg-plist b/audio/espeak/pkg-plist
index 78672da8ab64..ea4e9e741152 100644
--- a/audio/espeak/pkg-plist
+++ b/audio/espeak/pkg-plist
@@ -4,7 +4,7 @@ include/espeak/speak_lib.h
lib/libespeak.a
lib/libespeak.so
lib/libespeak.so.1
-lib/libespeak.so.1.1.46
+lib/libespeak.so.1.1.47
%%PORTDOCS%%%%DOCSDIR%%/add_language.html
%%PORTDOCS%%%%DOCSDIR%%/analyse.html
%%PORTDOCS%%%%DOCSDIR%%/commands.html
@@ -24,20 +24,25 @@ lib/libespeak.so.1.1.46
%%PORTDOCS%%%%DOCSDIR%%/ssml.html
%%PORTDOCS%%%%DOCSDIR%%/voices.html
%%DATADIR%%/espeak-data/af_dict
+%%DATADIR%%/espeak-data/am_dict
+%%DATADIR%%/espeak-data/an_dict
+%%DATADIR%%/espeak-data/az_dict
%%DATADIR%%/espeak-data/bg_dict
+%%DATADIR%%/espeak-data/bn_dict
%%DATADIR%%/espeak-data/ca_dict
%%DATADIR%%/espeak-data/cs_dict
%%DATADIR%%/espeak-data/cy_dict
%%DATADIR%%/espeak-data/da_dict
%%DATADIR%%/espeak-data/de_dict
-%%DATADIR%%/espeak-data/dv_dict
%%DATADIR%%/espeak-data/el_dict
%%DATADIR%%/espeak-data/en_dict
%%DATADIR%%/espeak-data/eo_dict
%%DATADIR%%/espeak-data/es_dict
%%DATADIR%%/espeak-data/et_dict
+%%DATADIR%%/espeak-data/fa_dict
%%DATADIR%%/espeak-data/fi_dict
%%DATADIR%%/espeak-data/fr_dict
+%%DATADIR%%/espeak-data/ga_dict
%%DATADIR%%/espeak-data/grc_dict
%%DATADIR%%/espeak-data/hbs_dict
%%DATADIR%%/espeak-data/hi_dict
@@ -49,9 +54,12 @@ lib/libespeak.so.1.1.46
%%DATADIR%%/espeak-data/it_dict
%%DATADIR%%/espeak-data/jbo_dict
%%DATADIR%%/espeak-data/ka_dict
+%%DATADIR%%/espeak-data/kl_dict
%%DATADIR%%/espeak-data/kn_dict
+%%DATADIR%%/espeak-data/ko_dict
%%DATADIR%%/espeak-data/ku_dict
%%DATADIR%%/espeak-data/la_dict
+%%DATADIR%%/espeak-data/lt_dict
%%DATADIR%%/espeak-data/lv_dict
%%DATADIR%%/espeak-data/mbrola_ph/af1_phtrans
%%DATADIR%%/espeak-data/mbrola_ph/ca1_phtrans
@@ -66,12 +74,16 @@ lib/libespeak.so.1.1.46
%%DATADIR%%/espeak-data/mbrola_ph/fr1_phtrans
%%DATADIR%%/espeak-data/mbrola_ph/gr2_phtrans
%%DATADIR%%/espeak-data/mbrola_ph/grc-de6_phtrans
+%%DATADIR%%/espeak-data/mbrola_ph/hn1_phtrans
%%DATADIR%%/espeak-data/mbrola_ph/hu1_phtrans
%%DATADIR%%/espeak-data/mbrola_ph/ic1_phtrans
%%DATADIR%%/espeak-data/mbrola_ph/id1_phtrans
%%DATADIR%%/espeak-data/mbrola_ph/in1_phtrans
+%%DATADIR%%/espeak-data/mbrola_ph/ir1_phtrans
%%DATADIR%%/espeak-data/mbrola_ph/it3_phtrans
%%DATADIR%%/espeak-data/mbrola_ph/la1_phtrans
+%%DATADIR%%/espeak-data/mbrola_ph/lt1_phtrans
+%%DATADIR%%/espeak-data/mbrola_ph/lt2_phtrans
%%DATADIR%%/espeak-data/mbrola_ph/mx1_phtrans
%%DATADIR%%/espeak-data/mbrola_ph/mx2_phtrans
%%DATADIR%%/espeak-data/mbrola_ph/nl_phtrans
@@ -89,23 +101,31 @@ lib/libespeak.so.1.1.46
%%DATADIR%%/espeak-data/mbrola_ph/vz_phtrans
%%DATADIR%%/espeak-data/mk_dict
%%DATADIR%%/espeak-data/ml_dict
+%%DATADIR%%/espeak-data/ms_dict
%%DATADIR%%/espeak-data/nci_dict
+%%DATADIR%%/espeak-data/ne_dict
%%DATADIR%%/espeak-data/nl_dict
%%DATADIR%%/espeak-data/no_dict
+%%DATADIR%%/espeak-data/pa_dict
%%DATADIR%%/espeak-data/pap_dict
%%DATADIR%%/espeak-data/phondata
+%%DATADIR%%/espeak-data/phondata-manifest
%%DATADIR%%/espeak-data/phonindex
%%DATADIR%%/espeak-data/phontab
%%DATADIR%%/espeak-data/pl_dict
%%DATADIR%%/espeak-data/pt_dict
%%DATADIR%%/espeak-data/ro_dict
%%DATADIR%%/espeak-data/ru_dict
+%%DATADIR%%/espeak-data/si_dict
%%DATADIR%%/espeak-data/sk_dict
+%%DATADIR%%/espeak-data/sl_dict
%%DATADIR%%/espeak-data/sq_dict
%%DATADIR%%/espeak-data/sv_dict
%%DATADIR%%/espeak-data/sw_dict
%%DATADIR%%/espeak-data/ta_dict
+%%DATADIR%%/espeak-data/te_dict
%%DATADIR%%/espeak-data/tr_dict
+%%DATADIR%%/espeak-data/ur_dict
%%DATADIR%%/espeak-data/vi_dict
%%DATADIR%%/espeak-data/voices/!v/croak
%%DATADIR%%/espeak-data/voices/!v/f1
@@ -116,6 +136,7 @@ lib/libespeak.so.1.1.46
%%DATADIR%%/espeak-data/voices/!v/klatt
%%DATADIR%%/espeak-data/voices/!v/klatt2
%%DATADIR%%/espeak-data/voices/!v/klatt3
+%%DATADIR%%/espeak-data/voices/!v/klatt4
%%DATADIR%%/espeak-data/voices/!v/m1
%%DATADIR%%/espeak-data/voices/!v/m2
%%DATADIR%%/espeak-data/voices/!v/m3
@@ -125,43 +146,62 @@ lib/libespeak.so.1.1.46
%%DATADIR%%/espeak-data/voices/!v/m7
%%DATADIR%%/espeak-data/voices/!v/whisper
%%DATADIR%%/espeak-data/voices/!v/whisperf
-%%DATADIR%%/espeak-data/voices/af
-%%DATADIR%%/espeak-data/voices/bg
-%%DATADIR%%/espeak-data/voices/bs
-%%DATADIR%%/espeak-data/voices/ca
-%%DATADIR%%/espeak-data/voices/cs
-%%DATADIR%%/espeak-data/voices/cy
-%%DATADIR%%/espeak-data/voices/da
+%%DATADIR%%/espeak-data/voices/asia/fa
+%%DATADIR%%/espeak-data/voices/asia/fa-pin
+%%DATADIR%%/espeak-data/voices/asia/hi
+%%DATADIR%%/espeak-data/voices/asia/hy
+%%DATADIR%%/espeak-data/voices/asia/hy-west
+%%DATADIR%%/espeak-data/voices/asia/id
+%%DATADIR%%/espeak-data/voices/asia/ka
+%%DATADIR%%/espeak-data/voices/asia/kn
+%%DATADIR%%/espeak-data/voices/asia/ku
+%%DATADIR%%/espeak-data/voices/asia/ml
+%%DATADIR%%/espeak-data/voices/asia/ms
+%%DATADIR%%/espeak-data/voices/asia/ne
+%%DATADIR%%/espeak-data/voices/asia/pa
+%%DATADIR%%/espeak-data/voices/asia/ta
+%%DATADIR%%/espeak-data/voices/asia/tr
+%%DATADIR%%/espeak-data/voices/asia/vi
+%%DATADIR%%/espeak-data/voices/asia/vi-hue
+%%DATADIR%%/espeak-data/voices/asia/vi-sgn
+%%DATADIR%%/espeak-data/voices/asia/zh
+%%DATADIR%%/espeak-data/voices/asia/zh-yue
%%DATADIR%%/espeak-data/voices/de
%%DATADIR%%/espeak-data/voices/default
-%%DATADIR%%/espeak-data/voices/el
-%%DATADIR%%/espeak-data/voices/en/en
-%%DATADIR%%/espeak-data/voices/en/en-n
-%%DATADIR%%/espeak-data/voices/en/en-rp
-%%DATADIR%%/espeak-data/voices/en/en-sc
-%%DATADIR%%/espeak-data/voices/en/en-us
-%%DATADIR%%/espeak-data/voices/en/en-wi
-%%DATADIR%%/espeak-data/voices/en/en-wm
-%%DATADIR%%/espeak-data/voices/eo
-%%DATADIR%%/espeak-data/voices/es
+%%DATADIR%%/espeak-data/voices/en
+%%DATADIR%%/espeak-data/voices/en-us
%%DATADIR%%/espeak-data/voices/es-la
-%%DATADIR%%/espeak-data/voices/et
-%%DATADIR%%/espeak-data/voices/fi
+%%DATADIR%%/espeak-data/voices/europe/an
+%%DATADIR%%/espeak-data/voices/europe/bg
+%%DATADIR%%/espeak-data/voices/europe/bs
+%%DATADIR%%/espeak-data/voices/europe/ca
+%%DATADIR%%/espeak-data/voices/europe/cs
+%%DATADIR%%/espeak-data/voices/europe/cy
+%%DATADIR%%/espeak-data/voices/europe/da
+%%DATADIR%%/espeak-data/voices/europe/el
+%%DATADIR%%/espeak-data/voices/europe/es
+%%DATADIR%%/espeak-data/voices/europe/et
+%%DATADIR%%/espeak-data/voices/europe/fi
+%%DATADIR%%/espeak-data/voices/europe/fr-be
+%%DATADIR%%/espeak-data/voices/europe/ga
+%%DATADIR%%/espeak-data/voices/europe/hr
+%%DATADIR%%/espeak-data/voices/europe/hu
+%%DATADIR%%/espeak-data/voices/europe/is
+%%DATADIR%%/espeak-data/voices/europe/it
+%%DATADIR%%/espeak-data/voices/europe/lt
+%%DATADIR%%/espeak-data/voices/europe/lv
+%%DATADIR%%/espeak-data/voices/europe/mk
+%%DATADIR%%/espeak-data/voices/europe/nl
+%%DATADIR%%/espeak-data/voices/europe/no
+%%DATADIR%%/espeak-data/voices/europe/pl
+%%DATADIR%%/espeak-data/voices/europe/pt-pt
+%%DATADIR%%/espeak-data/voices/europe/ro
+%%DATADIR%%/espeak-data/voices/europe/ru
+%%DATADIR%%/espeak-data/voices/europe/sk
+%%DATADIR%%/espeak-data/voices/europe/sq
+%%DATADIR%%/espeak-data/voices/europe/sr
+%%DATADIR%%/espeak-data/voices/europe/sv
%%DATADIR%%/espeak-data/voices/fr
-%%DATADIR%%/espeak-data/voices/fr-be
-%%DATADIR%%/espeak-data/voices/hi
-%%DATADIR%%/espeak-data/voices/hr
-%%DATADIR%%/espeak-data/voices/hu
-%%DATADIR%%/espeak-data/voices/hy
-%%DATADIR%%/espeak-data/voices/hy-west
-%%DATADIR%%/espeak-data/voices/id
-%%DATADIR%%/espeak-data/voices/is
-%%DATADIR%%/espeak-data/voices/it
-%%DATADIR%%/espeak-data/voices/ka
-%%DATADIR%%/espeak-data/voices/kn
-%%DATADIR%%/espeak-data/voices/ku
-%%DATADIR%%/espeak-data/voices/la
-%%DATADIR%%/espeak-data/voices/lv
%%DATADIR%%/espeak-data/voices/mb/mb-af1
%%DATADIR%%/espeak-data/voices/mb/mb-af1-en
%%DATADIR%%/espeak-data/voices/mb/mb-br1
@@ -170,6 +210,7 @@ lib/libespeak.so.1.1.46
%%DATADIR%%/espeak-data/voices/mb/mb-cr1
%%DATADIR%%/espeak-data/voices/mb/mb-cz2
%%DATADIR%%/espeak-data/voices/mb/mb-de2
+%%DATADIR%%/espeak-data/voices/mb/mb-de3
%%DATADIR%%/espeak-data/voices/mb/mb-de4
%%DATADIR%%/espeak-data/voices/mb/mb-de4-en
%%DATADIR%%/espeak-data/voices/mb/mb-de5
@@ -191,6 +232,7 @@ lib/libespeak.so.1.1.46
%%DATADIR%%/espeak-data/voices/mb/mb-hu1-en
%%DATADIR%%/espeak-data/voices/mb/mb-ic1
%%DATADIR%%/espeak-data/voices/mb/mb-id1
+%%DATADIR%%/espeak-data/voices/mb/mb-ir1
%%DATADIR%%/espeak-data/voices/mb/mb-it3
%%DATADIR%%/espeak-data/voices/mb/mb-it4
%%DATADIR%%/espeak-data/voices/mb/mb-la1
@@ -213,34 +255,36 @@ lib/libespeak.so.1.1.46
%%DATADIR%%/espeak-data/voices/mb/mb-us2
%%DATADIR%%/espeak-data/voices/mb/mb-us3
%%DATADIR%%/espeak-data/voices/mb/mb-vz1
-%%DATADIR%%/espeak-data/voices/mk
-%%DATADIR%%/espeak-data/voices/ml
-%%DATADIR%%/espeak-data/voices/nl
-%%DATADIR%%/espeak-data/voices/no
-%%DATADIR%%/espeak-data/voices/pl
+%%DATADIR%%/espeak-data/voices/other/af
+%%DATADIR%%/espeak-data/voices/other/en-n
+%%DATADIR%%/espeak-data/voices/other/en-rp
+%%DATADIR%%/espeak-data/voices/other/en-sc
+%%DATADIR%%/espeak-data/voices/other/en-wi
+%%DATADIR%%/espeak-data/voices/other/en-wm
+%%DATADIR%%/espeak-data/voices/other/eo
+%%DATADIR%%/espeak-data/voices/other/grc
+%%DATADIR%%/espeak-data/voices/other/jbo
+%%DATADIR%%/espeak-data/voices/other/la
+%%DATADIR%%/espeak-data/voices/other/sw
%%DATADIR%%/espeak-data/voices/pt
-%%DATADIR%%/espeak-data/voices/pt-pt
-%%DATADIR%%/espeak-data/voices/ro
-%%DATADIR%%/espeak-data/voices/ru
-%%DATADIR%%/espeak-data/voices/sk
-%%DATADIR%%/espeak-data/voices/sq
-%%DATADIR%%/espeak-data/voices/sr
-%%DATADIR%%/espeak-data/voices/sv
-%%DATADIR%%/espeak-data/voices/sw
-%%DATADIR%%/espeak-data/voices/ta
-%%DATADIR%%/espeak-data/voices/test/grc
-%%DATADIR%%/espeak-data/voices/test/jbo
+%%DATADIR%%/espeak-data/voices/test/am
+%%DATADIR%%/espeak-data/voices/test/az
+%%DATADIR%%/espeak-data/voices/test/bn
+%%DATADIR%%/espeak-data/voices/test/kl
+%%DATADIR%%/espeak-data/voices/test/ko
%%DATADIR%%/espeak-data/voices/test/nci
%%DATADIR%%/espeak-data/voices/test/pap
-%%DATADIR%%/espeak-data/voices/tr
-%%DATADIR%%/espeak-data/voices/vi
-%%DATADIR%%/espeak-data/voices/zh
-%%DATADIR%%/espeak-data/voices/zh-yue
+%%DATADIR%%/espeak-data/voices/test/si
+%%DATADIR%%/espeak-data/voices/test/sl
+%%DATADIR%%/espeak-data/voices/test/te
+%%DATADIR%%/espeak-data/voices/test/ur
%%DATADIR%%/espeak-data/zh_dict
%%DATADIR%%/espeak-data/zhy_dict
@dirrm %%DATADIR%%/espeak-data/voices/test
+@dirrm %%DATADIR%%/espeak-data/voices/other
@dirrm %%DATADIR%%/espeak-data/voices/mb
-@dirrm %%DATADIR%%/espeak-data/voices/en
+@dirrm %%DATADIR%%/espeak-data/voices/europe
+@dirrm %%DATADIR%%/espeak-data/voices/asia
@dirrm %%DATADIR%%/espeak-data/voices/!v
@dirrm %%DATADIR%%/espeak-data/voices
@dirrm %%DATADIR%%/espeak-data/soundicons