aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2018-09-01 22:40:59 +0800
committerehaupt <ehaupt@FreeBSD.org>2018-09-01 22:40:59 +0800
commitaea6f9bae16bd7393fd8853aec87c5a5c8e9e630 (patch)
tree7ec344c1e1edd9d92b88adcd481c024c81e14dcf /audio
parente3fef19f8270fda8325f853a0d92e698432e4e7f (diff)
downloadfreebsd-ports-gnome-aea6f9bae16bd7393fd8853aec87c5a5c8e9e630.tar.gz
freebsd-ports-gnome-aea6f9bae16bd7393fd8853aec87c5a5c8e9e630.tar.zst
freebsd-ports-gnome-aea6f9bae16bd7393fd8853aec87c5a5c8e9e630.zip
Update to 2.74
Diffstat (limited to 'audio')
-rw-r--r--audio/goattracker/Makefile5
-rw-r--r--audio/goattracker/distinfo6
-rw-r--r--audio/goattracker/files/patch-src_bme_makefile11
-rw-r--r--audio/goattracker/files/patch-src_makefile6
-rw-r--r--audio/goattracker/files/patch-src_makefile.common6
5 files changed, 19 insertions, 15 deletions
diff --git a/audio/goattracker/Makefile b/audio/goattracker/Makefile
index d8582700095f..1f90e9ed9e7d 100644
--- a/audio/goattracker/Makefile
+++ b/audio/goattracker/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= goattracker
-PORTVERSION= 2.73
+PORTVERSION= 2.74
CATEGORIES= audio
MASTER_SITES= SF/goattracker2/GoatTracker%202/${PORTVERSION}
DISTNAME= GoatTracker_${PORTVERSION}
@@ -22,9 +22,6 @@ MAKEFILE= makefile
OPTIONS_DEFINE= DOCS EXAMPLES
-CFLAGS+= `sdl-config --cflags`
-LIBS+= `sdl-config --libs`
-
DESKTOP_ENTRIES="GoatTracker 2" \
"${COMMENT}" \
"${PREFIX}/share/pixmaps/goattrk2.ico" \
diff --git a/audio/goattracker/distinfo b/audio/goattracker/distinfo
index 51d64974a76d..bbe8fdc768cd 100644
--- a/audio/goattracker/distinfo
+++ b/audio/goattracker/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1493416360
-SHA256 (GoatTracker_2.73.zip) = 4d24c5919f47c69791ea7b457586849621e205a20e4c3ad5eb37d1a0cbcf9563
-SIZE (GoatTracker_2.73.zip) = 1168212
+TIMESTAMP = 1535794368
+SHA256 (GoatTracker_2.74.zip) = 91a859a70e0f3524adebce2d28f00289db1a93344f126b5da6e22a8bd646f249
+SIZE (GoatTracker_2.74.zip) = 1228568
diff --git a/audio/goattracker/files/patch-src_bme_makefile b/audio/goattracker/files/patch-src_bme_makefile
index 1964ed321870..baeb28ad5db2 100644
--- a/audio/goattracker/files/patch-src_bme_makefile
+++ b/audio/goattracker/files/patch-src_bme_makefile
@@ -1,6 +1,11 @@
---- src/bme/makefile.orig 2017-04-29 15:05:37 UTC
+--- src/bme/makefile.orig 2018-09-01 09:19:43 UTC
+++ src/bme/makefile
-@@ -1,10 +1,10 @@
+@@ -1,10 +1,15 @@
++CC?=gcc
++CFLAGS+=`sdl-config --cflags`
++LIBS+=`sdl-config --libs`
++
++
all: dat2inc datafile
datafile: datafile.c bme_end.c
@@ -10,6 +15,6 @@
dat2inc: dat2inc.c
- gcc -o dat2inc dat2inc.c
-+ $(CC) $(CFLAGS) -o dat2inc dat2inc.c
++ $(CC) $(LIBS) -o dat2inc dat2inc.c
strip dat2inc
diff --git a/audio/goattracker/files/patch-src_makefile b/audio/goattracker/files/patch-src_makefile
index 8c80e0c187ab..929356310b86 100644
--- a/audio/goattracker/files/patch-src_makefile
+++ b/audio/goattracker/files/patch-src_makefile
@@ -1,12 +1,14 @@
---- src/makefile.orig 2017-04-29 15:05:37 UTC
+--- src/makefile.orig 2018-09-01 09:01:40 UTC
+++ src/makefile
-@@ -2,9 +2,7 @@
+@@ -2,9 +2,9 @@
# Linux makefile
#
-CFLAGS=`sdl-config --cflags`
++CFLAGS+=`sdl-config --cflags`
PREFIX=../linux/
SUFFIX=
-LIBS=`sdl-config --libs`
++LIBS+=`sdl-config --libs`
include makefile.common
diff --git a/audio/goattracker/files/patch-src_makefile.common b/audio/goattracker/files/patch-src_makefile.common
index 54e4bc02acb0..2073241513ce 100644
--- a/audio/goattracker/files/patch-src_makefile.common
+++ b/audio/goattracker/files/patch-src_makefile.common
@@ -1,11 +1,11 @@
---- src/makefile.common.orig 2017-04-29 15:05:37 UTC
+--- src/makefile.common.orig 2018-09-01 09:14:51 UTC
+++ src/makefile.common
@@ -1,9 +1,9 @@
# common makefile directives for linux and win32 build
-CC=gcc
-CXX=g++
--CFLAGS+=-O3 -Wall -Ibme -Iasm
+-CFLAGS+=-O3 -Wall -Ibme -Iasm -fpermissive
-CXXFLAGS=$(CFLAGS)
+CC?=gcc
+CXX?=g++
@@ -14,7 +14,7 @@
EXE= $(PREFIX)goattrk2$(SUFFIX) \
$(PREFIX)gt2reloc$(SUFFIX) \
-@@ -48,26 +48,26 @@ bme/bme_gfx.o bme/bme_snd.o bme/bme_win.
+@@ -43,26 +43,26 @@ bme/bme_gfx.o bme/bme_snd.o bme/bme_win.
strip $@
$(PREFIX)mod2sng$(SUFFIX): mod2sng.o bme/bme_end.o
ader'>* - Update KOffice to 2.3.1.avilla2011-03-252-2/+2 | | | | - Force dependency on new libwpg. * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.1 and KDE PIMavilla2011-03-253-56/+240 | | | | | | | | | 4.4.10. The official 4.6.1 release notes can be found at: http://www.kde.org/announcements/announce-4.6.1.php We'd like to say thanks to all helpers and submitters. Tested by: exp-run via miwi * - Update my email to FreeBSDpawel2011-03-242-2/+2 | | | | Approved by: miwi, wen (mentors) * - Get Rid MD5 supportmiwi2011-03-1912-14/+0 | | | | With hat: portmgr (myself) * - Update to 1.10.1wen2011-03-152-5/+6 | | | | | PR: ports/155551 Submitted by: Marcin Wisnicki <mwisnicki+freebsd@gmail.com> (maintainer) * - update to version 0.3.0miwi2011-02-234-147/+223 | | | | | | | | | | - take maintainership - mark MAKE_JOBS_SAFE - add LICENSE info - add optional building of several plugins PR: 154919 Submitted by: "Pawel Pekala" <c0rn@o2.pl> (maintainer) * - Remove unnecessary PKGNAMEPREFIX declarationsunpoet2011-01-095-5/+0 | | | | | | | | - Remove obsolete MD5 checksum while I'm here PR: ports/153634 Submitted by: sunpoet (myself) Approved by: pav (with portmgr hat) * - The KDE FreeBSD team is proud to announce the release of KDE 4.5.5fluffy2011-01-081-2/+2 | | | | | | for FreeBSD. It's a bugfix-only release, January 2011 set. * - Add LICENSE infomakc2010-12-196-27/+45 | | | | | | | | | | | - Mark MAKE_JOBS_SAFE - Install KDE4 integration file - Add patch so that location of 7z binary is not badly hardcoded - Don't install some non essential files - Remove md5 sum PR: based on ports/152619 Submitted by: Pawel Pekala (maintainer) * KDE FreeBSD team presents KDE SC 4.5.4.makc2010-12-032-2/+3 | * KDE FreeBSD team presents KDE SC 4.5.3.makc2010-11-042-3/+18 | * KDE FreeBSD team presents KDE SC 4.5.2.makc2010-10-062-3/+44 | | | | | | | | kdebase4-workspace is now shipped with FreeBSD-branded wallpapers [1] (set by default for new accounts). Thanks to Ivan Cukic from KDE for making the wallpapers! [1] http://ivan.fomentgroup.org/blog/2010/09/05/stripes-kde-be-free-freebsd/ * Autotools update. Read ports/UPDATING 20100915 for details.ade2010-09-162-4/+2 | | | | | Approved by: portmgr (for Mk/bsd.port.mk part) Tested by: Multiple -exp runs * KDE FreeBSD team presents KDE SC 4.5.1.makc2010-09-033-224/+55 | | | | | New ports added: misc/kde4-l10n-ia - Interlingua localization for KDE * Update KOffice l10n ports to 2.2.2makc2010-08-284-6/+8 | * Present KDE SC 4.4.5 for FreeBSD.makc2010-06-301-3/+3 | | | | Feature safe: yes