aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-08-20 06:10:15 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-08-20 06:10:15 +0800
commitaf3ea665018e973a576da554ebbb8d516bf883c2 (patch)
tree24ed71361143bf83dcc6f92df8de9465e2755e34 /audio
parent40b05c75a5401b580f560078bcec0eeed9280db2 (diff)
downloadfreebsd-ports-gnome-af3ea665018e973a576da554ebbb8d516bf883c2.tar.gz
freebsd-ports-gnome-af3ea665018e973a576da554ebbb8d516bf883c2.tar.zst
freebsd-ports-gnome-af3ea665018e973a576da554ebbb8d516bf883c2.zip
A simple program to help novice guitarist faster (and better) to
tune your guitar. WWW: http://code.google.com/p/wxguitar/
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/wxguitar/Makefile42
-rw-r--r--audio/wxguitar/distinfo3
-rw-r--r--audio/wxguitar/pkg-descr4
-rw-r--r--audio/wxguitar/pkg-plist15
5 files changed, 65 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8c2d752027e9..44e462527159 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -757,6 +757,7 @@
SUBDIR += workman
SUBDIR += wsoundprefs
SUBDIR += wsoundserver
+ SUBDIR += wxguitar
SUBDIR += x11amp
SUBDIR += xanalyser
SUBDIR += xaylet
diff --git a/audio/wxguitar/Makefile b/audio/wxguitar/Makefile
new file mode 100644
index 000000000000..2849bc084524
--- /dev/null
+++ b/audio/wxguitar/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: wxguitar
+# Date created: 19 Aug 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wxguitar
+PORTVERSION= 1.01
+CATEGORIES= audio
+MASTER_SITES= GOOGLE_CODE \
+ http://mirror.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= A simple guitar tuning assistant
+
+RUN_DEPENDS= wavplay:${PORTSDIR}/audio/wavplay
+
+GNU_CONFIGURE= yes
+USE_WX= 2.8+
+WX_UNICODE= yes
+CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_JOBS_SAFE= yes
+
+WRKSRC= ${WRKDIR}/wxGuitar
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/wxguitar|${DATADIR}|' \
+ ${WRKSRC}/src/wxGuitarMain.cpp ${WRKSRC}/data/wxGuitar.desktop
+ @${REINPLACE_CMD} -e 's|aplay|wavplay|' \
+ ${WRKSRC}/src/wxGuitarMain.cpp
+
+.include <bsd.port.mk>
diff --git a/audio/wxguitar/distinfo b/audio/wxguitar/distinfo
new file mode 100644
index 000000000000..df757bf9f0d6
--- /dev/null
+++ b/audio/wxguitar/distinfo
@@ -0,0 +1,3 @@
+MD5 (wxguitar-1.01.tar.gz) = cc60ac7d0b8d29b2f33522a014690652
+SHA256 (wxguitar-1.01.tar.gz) = a6599c31f0e0555dbef33d77a475e80e7f0ccac94595e987187519b725ae6247
+SIZE (wxguitar-1.01.tar.gz) = 672762
diff --git a/audio/wxguitar/pkg-descr b/audio/wxguitar/pkg-descr
new file mode 100644
index 000000000000..6a44e232eef8
--- /dev/null
+++ b/audio/wxguitar/pkg-descr
@@ -0,0 +1,4 @@
+A simple program to help novice guitarist faster (and better) to
+tune your guitar.
+
+WWW: http://code.google.com/p/wxguitar/
diff --git a/audio/wxguitar/pkg-plist b/audio/wxguitar/pkg-plist
new file mode 100644
index 000000000000..e1178ce27951
--- /dev/null
+++ b/audio/wxguitar/pkg-plist
@@ -0,0 +1,15 @@
+bin/wxguitar
+share/applications/wxGuitar.desktop
+%%NLS%%share/locale/ru/LC_MESSAGES/wxguitar.mo
+%%DATADIR%%/pixmaps/gitara.png
+%%DATADIR%%/pixmaps/gitara_icon_64.ico
+%%DATADIR%%/sounds/A1.wav
+%%DATADIR%%/sounds/D1.wav
+%%DATADIR%%/sounds/E1.wav
+%%DATADIR%%/sounds/E2.wav
+%%DATADIR%%/sounds/G1.wav
+%%DATADIR%%/sounds/H1.wav
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/pixmaps
+@dirrm %%DATADIR%%
+@dirrmtry share/applications