aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-01 20:42:16 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-01 20:42:16 +0800
commitb454ad1972c9e39f12499268a6b5f18c70481668 (patch)
tree3a40df42ee182be7e84031eaff06b8084a8a0496 /audio
parent9f09f791205c8be117f81c2e11aa0c63d52836b2 (diff)
downloadfreebsd-ports-gnome-b454ad1972c9e39f12499268a6b5f18c70481668.tar.gz
freebsd-ports-gnome-b454ad1972c9e39f12499268a6b5f18c70481668.tar.zst
freebsd-ports-gnome-b454ad1972c9e39f12499268a6b5f18c70481668.zip
audio/sidplay2: oops, fix typo in r433015
Diffstat (limited to 'audio')
-rw-r--r--audio/sidplay2/Makefile2
-rw-r--r--audio/sidplay2/files/patch-src_args.cpp3
2 files changed, 3 insertions, 2 deletions
diff --git a/audio/sidplay2/Makefile b/audio/sidplay2/Makefile
index a3151aefd60e..d8e6c46e7311 100644
--- a/audio/sidplay2/Makefile
+++ b/audio/sidplay2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sidplay2
PORTVERSION= 2.0.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio emulators
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/sidplay-${PORTVERSION}
DISTNAME= sidplay-${PORTVERSION}
diff --git a/audio/sidplay2/files/patch-src_args.cpp b/audio/sidplay2/files/patch-src_args.cpp
index 99213f69711a..4793c1d19592 100644
--- a/audio/sidplay2/files/patch-src_args.cpp
+++ b/audio/sidplay2/files/patch-src_args.cpp
@@ -14,8 +14,9 @@
{ // Read in MM:SS format
int val;
- *sep = '\0';
+- val = atoi (str);
+ char *tmp = strndup(str, sep - str);
- val = atoi (str);
++ val = atoi (tmp);
+ free(tmp);
if (val < 0 || val > 99)
return false;