aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2011-07-21 13:03:02 +0800
committerlinimon <linimon@FreeBSD.org>2011-07-21 13:03:02 +0800
commitb52944915a792d1df1b4539b6ffef32bb06c623c (patch)
tree2d2342fe8b657b24efa68b7b0eedf07f0880f0b9 /audio
parentcf6c4b2a7fb04e6bebe556711940aa746e81c384 (diff)
downloadfreebsd-ports-gnome-b52944915a792d1df1b4539b6ffef32bb06c623c.tar.gz
freebsd-ports-gnome-b52944915a792d1df1b4539b6ffef32bb06c623c.tar.zst
freebsd-ports-gnome-b52944915a792d1df1b4539b6ffef32bb06c623c.zip
Now that the Java 1.3 and Java 1.4 ports are deprecated and will expire soon,
remove support for them from bsd.java.mk. As Jikes is not available in Java 1.5 or higher, remove it from bsd.java.mk too (suggested by hq@) and from the ports which used it (only occurences were USE_JIKES=no). Support for the Blackdown VM is also removed, as it is not available in Java 1.5 and higher. Also remove the mapping from Java 1.1-1.4 to Java 1.5+ in bsd.java.mk to detect old, broken ports; therefore bump the minimal value of JAVA_VERSION to 1.5. While here, replace static values of JAVA_VERSION in files/*.in by %%JAVA_VERSION%% . PR: ports/158969 Submitted by: rene Tested on: pointyhat-west -exp
Diffstat (limited to 'audio')
-rw-r--r--audio/jid3lib/Makefile2
-rw-r--r--audio/jmusic/Makefile2
-rw-r--r--audio/jxm/Makefile2
-rw-r--r--audio/jxm/files/jxm.sh.in2
-rw-r--r--audio/musiccontrol/Makefile2
-rw-r--r--audio/tuxguitar/Makefile4
-rw-r--r--audio/tuxguitar/files/patch-build.properties2
7 files changed, 8 insertions, 8 deletions
diff --git a/audio/jid3lib/Makefile b/audio/jid3lib/Makefile
index 5fb666f9de3b..5086f32034d7 100644
--- a/audio/jid3lib/Makefile
+++ b/audio/jid3lib/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Java ID3 Tag Library
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
USE_ANT= yes
PLIST_FILES= %%JAVAJARDIR%%/jid3lib.jar
diff --git a/audio/jmusic/Makefile b/audio/jmusic/Makefile
index a73f458cff04..41722a18e91d 100644
--- a/audio/jmusic/Makefile
+++ b/audio/jmusic/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Composition in Java
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/audio/jxm/Makefile b/audio/jxm/Makefile
index 4e00db097133..7d59e212a3af 100644
--- a/audio/jxm/Makefile
+++ b/audio/jxm/Makefile
@@ -19,7 +19,7 @@ COMMENT= XMPCR (USB XM radio) control software
RUN_DEPENDS= ${JAVA_HOME}/jre/lib/ext/CommDriver.jar:${PORTSDIR}/comms/java-commapi-freebsd
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
JAVA_OS= native
NO_BUILD= yes
diff --git a/audio/jxm/files/jxm.sh.in b/audio/jxm/files/jxm.sh.in
index 3e6bdd9d75c4..6a88cdc34772 100644
--- a/audio/jxm/files/jxm.sh.in
+++ b/audio/jxm/files/jxm.sh.in
@@ -2,4 +2,4 @@
#
# $FreeBSD$
-JAVA_VERSION="1.4+" JAVA_OS="native" "%%LOCALBASE%%/bin/java" -jar "%%JAVAJARDIR%%/jxm.jar" "$@"
+JAVA_VERSION="%%JAVA_VERSION%%" JAVA_OS="native" "%%LOCALBASE%%/bin/java" -jar "%%JAVAJARDIR%%/jxm.jar" "$@"
diff --git a/audio/musiccontrol/Makefile b/audio/musiccontrol/Makefile
index c383f4aefbe5..33827de66f5b 100644
--- a/audio/musiccontrol/Makefile
+++ b/audio/musiccontrol/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/mpg123:${PORTSDIR}/audio/mpg123 \
${LOCALBASE}/bin/simplemod:${PORTSDIR}/audio/simplemod
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
PLIST_FILES= share/java/classes/MusicControl-${PORTVERSION}.jar bin/musiccontrol
diff --git a/audio/tuxguitar/Makefile b/audio/tuxguitar/Makefile
index 422446ced22b..ff78d7d54667 100644
--- a/audio/tuxguitar/Makefile
+++ b/audio/tuxguitar/Makefile
@@ -36,8 +36,8 @@ USE_ANT= yes
USE_GECKO= libxul
USE_GMAKE= yes
USE_LDCONFIG= yes
-JAVA_VERSION= 1.4+
-JAVA_VENDOR= freebsd bsdjava sun blackdown
+JAVA_VERSION= 1.5+
+JAVA_VENDOR= freebsd bsdjava sun
NOCCACHE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}/TuxGuitar
diff --git a/audio/tuxguitar/files/patch-build.properties b/audio/tuxguitar/files/patch-build.properties
index 7f319b850bcd..763a91da11d1 100644
--- a/audio/tuxguitar/files/patch-build.properties
+++ b/audio/tuxguitar/files/patch-build.properties
@@ -1,7 +1,7 @@
--- build.properties.orig 2010-02-26 12:11:41.000000000 +0100
+++ build.properties 2010-02-26 12:13:52.000000000 +0100
@@ -5,15 +5,15 @@
- ant.build.javac.target=1.4
+ ant.build.javac.target=1.5
########## DEFAULT LINUX BUILD PROPERTIES ##########
-lib.swt.jni=lib/