aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2002-09-03 07:46:52 +0800
committernaddy <naddy@FreeBSD.org>2002-09-03 07:46:52 +0800
commitb53629dafbc9bddce9311abaa627ad65302e89fb (patch)
treeb01b00d8ece30dd261c4a2222bef54ba75961900 /audio
parenta2dee7563a35ac4863f0ef51b107df347f6791a7 (diff)
downloadfreebsd-ports-gnome-b53629dafbc9bddce9311abaa627ad65302e89fb.tar.gz
freebsd-ports-gnome-b53629dafbc9bddce9311abaa627ad65302e89fb.tar.zst
freebsd-ports-gnome-b53629dafbc9bddce9311abaa627ad65302e89fb.zip
Fix format string bugs.
Submitted by: Moritz Jodeit <moritz@jodeit.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/mpg321/Makefile2
-rw-r--r--audio/mpg321/files/patch-mpg321.c20
2 files changed, 20 insertions, 2 deletions
diff --git a/audio/mpg321/Makefile b/audio/mpg321/Makefile
index e1b009446ece..f0b612de3b1b 100644
--- a/audio/mpg321/Makefile
+++ b/audio/mpg321/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpg321
PORTVERSION= 0.2.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mpg321
diff --git a/audio/mpg321/files/patch-mpg321.c b/audio/mpg321/files/patch-mpg321.c
index 577535662338..ec792ebd7091 100644
--- a/audio/mpg321/files/patch-mpg321.c
+++ b/audio/mpg321/files/patch-mpg321.c
@@ -2,7 +2,25 @@
$FreeBSD$
--- mpg321.c.orig Sun Mar 24 06:49:20 2002
-+++ mpg321.c Tue Aug 27 22:01:26 2002
++++ mpg321.c Tue Sep 3 01:29:40 2002
+@@ -188,7 +188,7 @@
+
+ else
+ {
+- printf(names[i]);
++ printf("%s", names[i]);
+ free(names[i]);
+ }
+ }
+@@ -203,7 +203,7 @@
+ if (!names[i]) {
+ fprintf (stderr, emptystring);
+ } else {
+- fprintf (stderr, names[i]);
++ fprintf (stderr, "%s", names[i]);
+ free (names[i]);
+ }
+ if (i%2) fprintf (stderr, "\n");
@@ -509,9 +509,6 @@
mad_decoder_finish(&decoder);