aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-06-09 11:53:58 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2019-06-09 11:53:58 +0800
commitb65e40305e381f5f272d5ced0c8e9ba78f341cee (patch)
tree4205c78eefecc1bb7b1f22212fe86ff5fbfe41d7 /audio
parentf1fe62633680d2602f6382f2ca89a7918bcf0700 (diff)
downloadfreebsd-ports-gnome-b65e40305e381f5f272d5ced0c8e9ba78f341cee.tar.gz
freebsd-ports-gnome-b65e40305e381f5f272d5ced0c8e9ba78f341cee.tar.zst
freebsd-ports-gnome-b65e40305e381f5f272d5ced0c8e9ba78f341cee.zip
audio/zam-plugins-lv2: Update 3.10-13 -> 3.11-1
Reported by: portscout
Diffstat (limited to 'audio')
-rw-r--r--audio/zam-plugins-lv2/Makefile14
-rw-r--r--audio/zam-plugins-lv2/distinfo10
-rw-r--r--audio/zam-plugins-lv2/files/patch-Makefile.mk25
-rw-r--r--audio/zam-plugins-lv2/files/patch-dpf_dgl_Makefile.mk18
-rw-r--r--audio/zam-plugins-lv2/files/patch-dpf_dgl_src_Window.cpp15
5 files changed, 11 insertions, 71 deletions
diff --git a/audio/zam-plugins-lv2/Makefile b/audio/zam-plugins-lv2/Makefile
index 228901eb95b7..8282bb5d903b 100644
--- a/audio/zam-plugins-lv2/Makefile
+++ b/audio/zam-plugins-lv2/Makefile
@@ -1,17 +1,16 @@
# $FreeBSD$
PORTNAME= zam-plugins
-DISTVERSION= 3.10-13
-DISTVERSIONSUFFIX= -gfbdbf08
-PORTREVISION= 3
+DISTVERSION= 3.11-1
+DISTVERSIONSUFFIX= -gce45995
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
MAINTAINER= yuri@FreeBSD.org
COMMENT= Collection of LADSPA/LV2/VST/JACK audio plugins
-LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= lv2>0:audio/lv2 \
${LOCALBASE}/include/fftw3.h:math/fftw3
@@ -23,12 +22,12 @@ LIB_DEPENDS= libfftw3f.so:math/fftw3-float \
USES= compiler:c++11-lib gl gmake localbase:ldflags pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= zamaudio
-GH_TUPLE= DISTRHO:DPF:2786991:d/dpf
+GH_TUPLE= DISTRHO:DPF:68b3a57:d/dpf
USE_GL= gl
USE_XORG= x11
CFLAGS+= -I${FILESDIR}
-MAKE_ARGS+= USE_SYSTEM_LIBS=1
+MAKE_ARGS+= USE_SYSTEM_LIBS=1 HAVE_ZITA_CONVOLVER=true
.include <bsd.port.pre.mk>
@@ -36,7 +35,6 @@ post-extract:
@${RM} -r ${WRKSRC}/lib/zita-convolver-*
post-patch:
- #@${REINPLACE_CMD} -e 's|#include "../../lib/zita-convolver-.*/zita-convolver.h"|#include <zita-convolver.h>|' ${WRKSRC}/plugins/Zam*/convolution.*pp
@${REINPLACE_CMD} -e 's|#!/bin/bash|#!/bin/sh|' ${WRKSRC}/dpf/utils/generate-ttl.sh
.if ${ARCH} == aarch64 || ${ARCH:Marmv*} || ${ARCH:Mmips*} || ${ARCH:Mpowerpc*} || ${ARCH} == sparc64
${REINPLACE_CMD} -e '/-mfpmath=sse/d' \
diff --git a/audio/zam-plugins-lv2/distinfo b/audio/zam-plugins-lv2/distinfo
index a42d78bb1dce..7d7eab1b4b82 100644
--- a/audio/zam-plugins-lv2/distinfo
+++ b/audio/zam-plugins-lv2/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1528555837
-SHA256 (zamaudio-zam-plugins-3.10-13-gfbdbf08_GH0.tar.gz) = 5cb7a1a95ab2571ad8a3797f0f4d2a5c27f29a89f1171312d576213cfe573b5c
-SIZE (zamaudio-zam-plugins-3.10-13-gfbdbf08_GH0.tar.gz) = 23932828
-SHA256 (DISTRHO-DPF-2786991_GH0.tar.gz) = dc2b8d2708926d1a2b8043bf5a3e4670530246949af01f5c959439e3a6ecdbc8
-SIZE (DISTRHO-DPF-2786991_GH0.tar.gz) = 1600005
+TIMESTAMP = 1560051677
+SHA256 (zamaudio-zam-plugins-3.11-1-gce45995_GH0.tar.gz) = 5b1a60afae86636d330096e851be11a639fe776583d9a54aca5bba5a57480d05
+SIZE (zamaudio-zam-plugins-3.11-1-gce45995_GH0.tar.gz) = 23926863
+SHA256 (DISTRHO-DPF-68b3a57_GH0.tar.gz) = c5e188808d6887119bc5311433558331fd7192cff37f1dbf5ed97f25d44a378a
+SIZE (DISTRHO-DPF-68b3a57_GH0.tar.gz) = 1624216
diff --git a/audio/zam-plugins-lv2/files/patch-Makefile.mk b/audio/zam-plugins-lv2/files/patch-Makefile.mk
deleted file mode 100644
index 90fa6b72151c..000000000000
--- a/audio/zam-plugins-lv2/files/patch-Makefile.mk
+++ /dev/null
@@ -1,25 +0,0 @@
---- Makefile.mk.orig 2018-05-29 08:20:20 UTC
-+++ Makefile.mk
-@@ -35,19 +35,19 @@ ifeq ($(MACOS),true)
- LINK_OPTS = -fdata-sections -ffunction-sections -Wl,-dead_strip -Wl,-dead_strip_dylibs
- else
- # Common linker flags
--LINK_OPTS = -fdata-sections -ffunction-sections -Wl,--gc-sections -Wl,-O1 -Wl,--as-needed -Wl,--strip-all
-+LINK_OPTS = -fdata-sections -ffunction-sections -Wl,--gc-sections -Wl,-O1 -Wl,--strip-all
- endif
-
- ifeq ($(RASPPI),true)
- # Raspberry-Pi optimization flags
- BASE_OPTS = -O2 -ffast-math -march=armv6 -mfpu=vfp -mfloat-abi=hard
--LINK_OPTS = -Wl,-O1 -Wl,--as-needed -Wl,--strip-all
-+LINK_OPTS = -Wl,-O1 -Wl,--strip-all
- endif
-
- ifeq ($(PANDORA),true)
- # OpenPandora optimization flags
- BASE_OPTS = -O2 -ffast-math -march=armv7-a -mcpu=cortex-a8 -mtune=cortex-a8 -mfpu=neon -mfloat-abi=softfp
--LINK_OPTS = -Wl,-O1 -Wl,--as-needed -Wl,--strip-all
-+LINK_OPTS = -Wl,-O1 -Wl,--strip-all
- endif
-
- ifeq ($(NOOPT),true)
diff --git a/audio/zam-plugins-lv2/files/patch-dpf_dgl_Makefile.mk b/audio/zam-plugins-lv2/files/patch-dpf_dgl_Makefile.mk
deleted file mode 100644
index 5d6ce8204adb..000000000000
--- a/audio/zam-plugins-lv2/files/patch-dpf_dgl_Makefile.mk
+++ /dev/null
@@ -1,18 +0,0 @@
---- dpf/dgl/Makefile.mk.orig 2018-05-29 08:20:51 UTC
-+++ dpf/dgl/Makefile.mk
-@@ -30,13 +30,13 @@ ifeq ($(MACOS),true)
- LINK_OPTS = -fdata-sections -ffunction-sections -Wl,-dead_strip -Wl,-dead_strip_dylibs
- else
- # Common linker flags
--LINK_OPTS = -fdata-sections -ffunction-sections -Wl,--gc-sections -Wl,-O1 -Wl,--as-needed -Wl,--strip-all
-+LINK_OPTS = -fdata-sections -ffunction-sections -Wl,--gc-sections -Wl,-O1 -Wl,--strip-all
- endif
-
- ifeq ($(RASPPI),true)
- # Raspberry-Pi optimization flags
- BASE_OPTS = -O2 -march=armv6 -mfpu=vfp -mfloat-abi=hard
--LINK_OPTS = -Wl,-O1 -Wl,--as-needed -Wl,--strip-all
-+LINK_OPTS = -Wl,-O1 -Wl,--strip-all
- endif
-
- ifeq ($(NOOPT),true)
diff --git a/audio/zam-plugins-lv2/files/patch-dpf_dgl_src_Window.cpp b/audio/zam-plugins-lv2/files/patch-dpf_dgl_src_Window.cpp
deleted file mode 100644
index 8d5eb8efc3da..000000000000
--- a/audio/zam-plugins-lv2/files/patch-dpf_dgl_src_Window.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- dpf/dgl/src/Window.cpp.orig 2018-04-11 22:29:29 UTC
-+++ dpf/dgl/src/Window.cpp
-@@ -1148,10 +1148,11 @@ bool Window::openFileBrowser(const FileB
- // TODO: cross-platform
-
- String startDir(options.startDir);
-+ static char buf[1024];
-
- if (startDir.isEmpty())
- {
-- if (char* const dir_name = get_current_dir_name())
-+ if (char* const dir_name = getwd(buf))
- {
- startDir = dir_name;
- std::free(dir_name);