aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-10-09 07:01:38 +0800
committerwg <wg@FreeBSD.org>2013-10-09 07:01:38 +0800
commitb782c5471b18fd954a9eb2b278ef6ac4b20ae6d7 (patch)
tree1342f6777b2f286f952dd7557455df2843a6a4a4 /audio
parent236e593542b8fa53e8b45d2830727eca5c624c51 (diff)
downloadfreebsd-ports-gnome-b782c5471b18fd954a9eb2b278ef6ac4b20ae6d7.tar.gz
freebsd-ports-gnome-b782c5471b18fd954a9eb2b278ef6ac4b20ae6d7.tar.zst
freebsd-ports-gnome-b782c5471b18fd954a9eb2b278ef6ac4b20ae6d7.zip
audio/deadbeef: link using ffmpeg0
- Link using ffmpeg0 Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'audio')
-rw-r--r--audio/deadbeef/Makefile14
-rw-r--r--audio/deadbeef/files/patch-plugins-ffmpeg-Makefile.in16
-rw-r--r--audio/deadbeef/files/patch-plugins-ffmpeg-ffmpeg.c32
3 files changed, 58 insertions, 4 deletions
diff --git a/audio/deadbeef/Makefile b/audio/deadbeef/Makefile
index 2090c4cdf1e2..4f308c08a065 100644
--- a/audio/deadbeef/Makefile
+++ b/audio/deadbeef/Makefile
@@ -3,7 +3,7 @@
PORTNAME= deadbeef
PORTVERSION= 0.5.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}
@@ -166,9 +166,10 @@ PLIST_SUB+= OGG="@comment "
.if ${PORT_OPTIONS:MFFMPEG}
PLIST_SUB+= FFMPEG=""
-LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg \
- avformat:${PORTSDIR}/multimedia/ffmpeg \
- avutil:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= libavcodec0.so:${PORTSDIR}/multimedia/ffmpeg0 \
+ libavformat0.so:${PORTSDIR}/multimedia/ffmpeg0 \
+ libavutil0.so:${PORTSDIR}/multimedia/ffmpeg0
+CONFIGURE_ARGS+= --enable-ffmpeg
.else
CONFIGURE_ARGS+= --disable-ffmpeg
PLIST_SUB+= FFMPEG="@comment "
@@ -359,6 +360,11 @@ post-patch:
${WRKSRC}/plugins/supereq/Makefile.in
@${REINPLACE_CMD} -e 's,/etc/timidity++/timidity-freepats.cfg:/etc/timidity/freepats.cfg:/etc/timidity/,${LOCALBASE}/share/,' \
${WRKSRC}/plugins/wildmidi/wildmidiplug.c
+ @${REINPLACE_CMD} \
+ -e 's,libavcodec ,libavcodec0 ,g' \
+ -e 's,libavutil ,libavutil0 ,g' \
+ -e 's,libavformat ,libavformat0 ,g' \
+ ${WRKSRC}/configure
.include <bsd.port.pre.mk>
diff --git a/audio/deadbeef/files/patch-plugins-ffmpeg-Makefile.in b/audio/deadbeef/files/patch-plugins-ffmpeg-Makefile.in
new file mode 100644
index 000000000000..c225d1f19074
--- /dev/null
+++ b/audio/deadbeef/files/patch-plugins-ffmpeg-Makefile.in
@@ -0,0 +1,16 @@
+--- plugins/ffmpeg/Makefile.in.orig 2013-10-08 19:57:17.298159051 -0300
++++ plugins/ffmpeg/Makefile.in 2013-10-08 19:57:32.774264065 -0300
+@@ -108,11 +108,11 @@
+ depcomp = $(SHELL) $(top_srcdir)/depcomp
+ am__depfiles_maybe = depfiles
+ am__mv = mv -f
+-COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
++COMPILE = $(CC) $(DEFS) $(AM_CFLAGS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+ $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ LTCOMPILE = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
+ $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) \
+- $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
++ $(AM_CFLAGS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
+ $(AM_CFLAGS) $(CFLAGS)
+ AM_V_CC = $(am__v_CC_@AM_V@)
+ am__v_CC_ = $(am__v_CC_@AM_DEFAULT_V@)
diff --git a/audio/deadbeef/files/patch-plugins-ffmpeg-ffmpeg.c b/audio/deadbeef/files/patch-plugins-ffmpeg-ffmpeg.c
new file mode 100644
index 000000000000..5f3c4dad926c
--- /dev/null
+++ b/audio/deadbeef/files/patch-plugins-ffmpeg-ffmpeg.c
@@ -0,0 +1,32 @@
+--- plugins/ffmpeg/ffmpeg.c.orig 2013-10-08 19:54:33.943158658 -0300
++++ plugins/ffmpeg/ffmpeg.c 2013-10-08 19:54:44.352159132 -0300
+@@ -25,20 +25,11 @@
+
+ #include "../../deadbeef.h"
+
+-#if !FFMPEG_OLD
+-
+ #include <libavformat/avformat.h>
+ #include <libavcodec/avcodec.h>
+ #include <libavutil/avutil.h>
+ #include <libavutil/avstring.h>
+
+-#else
+-
+-#include <ffmpeg/avformat.h>
+-#include <ffmpeg/avcodec.h>
+-#include <ffmpeg/avutil.h>
+-#include <ffmpeg/avstring.h>
+-
+ #define AVERROR_EOF AVERROR(EPIPE)
+
+ #if LIBAVFORMAT_VERSION_MAJOR < 53
+@@ -49,8 +40,6 @@
+ #define AV_VERSION_INT(a, b, c) (a<<16 | b<<8 | c)
+ #endif
+
+-#endif
+-
+ //#define trace(...) { fprintf(stderr, __VA_ARGS__); }
+ #define trace(fmt,...)
+