aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-07-21 04:10:17 +0800
committeryuri <yuri@FreeBSD.org>2018-07-21 04:10:17 +0800
commitbbcb67694e3c40445876cc1b5cf4771b037029b0 (patch)
treef7ac0abb7facd49af862b45e342462464b0a46bf /audio
parent83052281b5355257d2eacaab5c953b3db78b0c9a (diff)
downloadfreebsd-ports-gnome-bbcb67694e3c40445876cc1b5cf4771b037029b0.tar.gz
freebsd-ports-gnome-bbcb67694e3c40445876cc1b5cf4771b037029b0.tar.zst
freebsd-ports-gnome-bbcb67694e3c40445876cc1b5cf4771b037029b0.zip
New port: audio/faustlive: Standalone application that embeds Faust
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/faustlive/Makefile63
-rw-r--r--audio/faustlive/distinfo3
-rw-r--r--audio/faustlive/pkg-descr7
4 files changed, 74 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 75125f256aa5..19304cdc9d16 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -147,6 +147,7 @@
SUBDIR += fabla2-lv2
SUBDIR += fapg
SUBDIR += faust
+ SUBDIR += faustlive
SUBDIR += fcplay
SUBDIR += fdk-aac
SUBDIR += fdmf
diff --git a/audio/faustlive/Makefile b/audio/faustlive/Makefile
new file mode 100644
index 000000000000..c911ccb5f1a7
--- /dev/null
+++ b/audio/faustlive/Makefile
@@ -0,0 +1,63 @@
+# $FreeBSD$
+
+PORTNAME= faustlive
+PORTVERSION= g20171205
+CATEGORIES= audio
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Standalone application that embeds Faust
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/GPL.txt
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libfaust.a:audio/faust
+LIB_DEPENDS= libLLVM-${LLVM_VERSION:C/([1-9])([0-9])/\1.\2/}.so:devel/llvm${LLVM_VERSION} \
+ libasound.so:audio/alsa-lib \
+ libcurl.so:ftp/curl \
+ libjack.so:audio/jack \
+ libmicrohttpd.so:www/libmicrohttpd \
+ libqrencode.so:graphics/libqrencode # audio/alsa-lib isn't really needed: https://github.com/grame-cncm/faustlive/issues/3
+
+USES= compiler:c++11-lang gmake qt:5 ssl
+USE_GITHUB= yes
+GH_ACCOUNT= grame-cncm
+GH_TAGNAME= 281fcb8
+USE_QT= core gui network widgets buildtools_build qmake_build
+USE_GL= gl
+
+LLVM_VERSION= 60 # llvm verion should be the same as in audio/faust
+CXXFLAGS+= $$(llvm-config${LLVM_VERSION} --cflags)
+LDFLAGS+= -lexecinfo
+
+PLIST_FILES= bin/FaustLive \
+ share/applications/FaustLive.desktop \
+ share/icons/hicolor/32x32/apps/Faustlive.png \
+ share/icons/hicolor/scalable/apps/Faustlive.svg \
+ share/pixmaps/Faustlive.xpm
+
+OPTIONS_DEFINE= PORTAUDIO
+
+PORTAUDIO_MAKE_ARGS= PORTAUDIO=1
+PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
+
+post-patch:
+ @${MV} ${WRKSRC}/Build/Linux ${WRKSRC}/Build/FreeBSD
+ @${REINPLACE_CMD} -e ' \
+ s|SPEC := ""|SPEC := "FaustLive.pro"|; \
+ s|PREFIX :=|PREFIX ?=|; \
+ s|DESTDIR :=|DESTDIR ?=|; \
+ s|llvm-config|llvm-config${LLVM_VERSION}|g' \
+ ${WRKSRC}/Build/FreeBSD/Makefile
+ @${REINPLACE_CMD} -e ' \
+ s|########## LIBS AND FLAGS|CXXFLAGS+=$$$$system($$$$LLVM_CONFIG --cflags)| ; \
+ s|/use/local|${LOCALBASE}| ; \
+ s|-L/opt/local/lib$$|-L${LOCALBASE}/lib -lexecinfo|' \
+ ${WRKSRC}/Build/FreeBSD/FaustLive.pro
+ @${REINPLACE_CMD} -e ' \
+ s|#!/bin/bash|#!/bin/sh|' \
+ ${WRKSRC}/Build/FreeBSD/buildversion
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/FaustLive
+
+.include <bsd.port.mk>
diff --git a/audio/faustlive/distinfo b/audio/faustlive/distinfo
new file mode 100644
index 000000000000..36735caf8774
--- /dev/null
+++ b/audio/faustlive/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532114000
+SHA256 (grame-cncm-faustlive-g20171205-281fcb8_GH0.tar.gz) = 18b832ae42ceb7747992c7e78df71d5470d93eee1f3af6e797625d0d10c8da20
+SIZE (grame-cncm-faustlive-g20171205-281fcb8_GH0.tar.gz) = 49027897
diff --git a/audio/faustlive/pkg-descr b/audio/faustlive/pkg-descr
new file mode 100644
index 000000000000..d89baad33be3
--- /dev/null
+++ b/audio/faustlive/pkg-descr
@@ -0,0 +1,7 @@
+A standalone application that embeds Faust (as the libfaust library) and
+LLVM compiler to provide dynamical compilation for the Faust programming
+language.
+
+FaustLive is in its alpha stage.
+
+WWW: https://github.com/grame-cncm/faustlive