aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-04-14 14:54:23 +0800
committerbapt <bapt@FreeBSD.org>2011-04-14 14:54:23 +0800
commitbbf045b1f6eb3bb7d8077170ee6e37b58b044121 (patch)
treefc9ab62ac55594d28f551f0decff8824f9a6a469 /audio
parent040d9345b220843aee77c26e3e2b8de428050b65 (diff)
downloadfreebsd-ports-gnome-bbf045b1f6eb3bb7d8077170ee6e37b58b044121.tar.gz
freebsd-ports-gnome-bbf045b1f6eb3bb7d8077170ee6e37b58b044121.tar.zst
freebsd-ports-gnome-bbf045b1f6eb3bb7d8077170ee6e37b58b044121.zip
fix installing when LOCALBASE != PREFIX
Diffstat (limited to 'audio')
-rw-r--r--audio/bmp-flac/Makefile1
-rw-r--r--audio/bmp-mac/Makefile1
-rw-r--r--audio/bmp-modplug/Makefile1
3 files changed, 3 insertions, 0 deletions
diff --git a/audio/bmp-flac/Makefile b/audio/bmp-flac/Makefile
index edfc41df444a..666a60d6a804 100644
--- a/audio/bmp-flac/Makefile
+++ b/audio/bmp-flac/Makefile
@@ -40,6 +40,7 @@ post-configure:
# This is to avoid libtool running ldconfig -m ${LOCALBASE}/lib/bmp/Input
do-install:
+ @${MKDIR} ${PREFIX}/lib/bmp/Input
${INSTALL_DATA} ${WRKSRC}/src/plugin_bmp/.libs/libbmp-flac.so ${PREFIX}/lib/bmp/Input
.include <bsd.port.pre.mk>
diff --git a/audio/bmp-mac/Makefile b/audio/bmp-mac/Makefile
index 0e880b925d59..744b696ef46d 100644
--- a/audio/bmp-mac/Makefile
+++ b/audio/bmp-mac/Makefile
@@ -32,6 +32,7 @@ post-patch:
's|-D.*_DISABLE_DEPRECATED||g'
do-install:
+ @${MKDIR} ${PREFIX}/${PLUGDIR}
${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/${PLUGFILE} ${PREFIX}/${PLUGDIR}/
.include <bsd.port.mk>
diff --git a/audio/bmp-modplug/Makefile b/audio/bmp-modplug/Makefile
index 42fbb23b172f..e6a2121b37f6 100644
--- a/audio/bmp-modplug/Makefile
+++ b/audio/bmp-modplug/Makefile
@@ -30,6 +30,7 @@ PLUGDIR?= lib/bmp/Input
PLIST_FILES= ${PLUGDIR}/libmodplugbmp.so
do-install:
+ @${MKDIR} ${PREFIX}/${PLUGDIR}/
${INSTALL_PROGRAM} ${WRKSRC}/modplugbmp/.libs/libmodplugbmp.so ${PREFIX}/${PLUGDIR}/
.include <bsd.port.mk>