aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-01-26 02:59:24 +0800
committerpav <pav@FreeBSD.org>2004-01-26 02:59:24 +0800
commitbe3ccbc1b4dc9d47423cb42b925fa1c7e6d82a4f (patch)
tree09845b1e31b8916b58f64f496cf79a0502996153 /audio
parent144838a278c539e7192496b0caba04a36c10d469 (diff)
downloadfreebsd-ports-gnome-be3ccbc1b4dc9d47423cb42b925fa1c7e6d82a4f.tar.gz
freebsd-ports-gnome-be3ccbc1b4dc9d47423cb42b925fa1c7e6d82a4f.tar.zst
freebsd-ports-gnome-be3ccbc1b4dc9d47423cb42b925fa1c7e6d82a4f.zip
- Update to 0.9.2
PR: ports/61880, ports/61897 Submitted by: Kay Lehmann <kay_lehmann@web.de> (maintainer)
Diffstat (limited to 'audio')
-rw-r--r--audio/prokyon3/Makefile40
-rw-r--r--audio/prokyon3/distinfo2
-rw-r--r--audio/prokyon3/files/patch-src-getopt.h18
-rw-r--r--audio/prokyon3/files/patch-src-tagger_mp3.cpp11
-rw-r--r--audio/prokyon3/files/patch-src_getopt.c11
-rw-r--r--audio/prokyon3/files/patch_prokburn8
-rw-r--r--audio/prokyon3/pkg-descr16
-rw-r--r--audio/prokyon3/pkg-message5
-rw-r--r--audio/prokyon3/pkg-plist14
9 files changed, 77 insertions, 48 deletions
diff --git a/audio/prokyon3/Makefile b/audio/prokyon3/Makefile
index b5dc0708a23b..d69e2845b183 100644
--- a/audio/prokyon3/Makefile
+++ b/audio/prokyon3/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME= prokyon3
-PORTVERSION= 0.9.1.r1
-PORTREVISION= 1
+PORTVERSION= 0.9.2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-r/}
MAINTAINER= kay_lehmann@web.de
COMMENT= Prokyon3 is a multithreaded MP3 manager and tag editor
@@ -21,17 +19,41 @@ LIB_DEPENDS= id3-3.8:${PORTSDIR}/audio/id3lib \
vorbis.3:${PORTSDIR}/audio/libvorbis
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
USE_QT_VER= 3
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GETOPT_LONG=yes
USE_REINPLACE= yes
-CONFIGURE_ARGS+= --with-qtdir=${X11BASE} --with-id3-libs=${LOCALBASE}\
- --with-ogg-libs=${LOCALBASE} --with-vorbis-libs=${LOCALBASE}
+USE_GETOPT_LONG=yes
+USE_MYSQL= yes
+CONFIGURE_ARGS+=--with-qtdir=${X11BASE} --with-id3-libs=${LOCALBASE}\
+ --with-ogg-libs=${LOCALBASE} --with-vorbis-libs=${LOCALBASE}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500041
+QT_NONSTANDARD= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include \
+ -I${QT_PREFIX}/include"
+.endif
+
+.if defined(WITH_BURN)
+RUN_DEPENDS+= cdrecord:${PORTSDIR}/sysutils/cdrtools \
+ mpg123:${PORTSDIR}/audio/mpg123 \
+ ogg123:${PORTSDIR}/audio/vorbis-tools \
+ normalize:${PORTSDIR}/audio/normalize \
+ bash:${PORTSDIR}/shells/bash2
+PLIST_FILES+= bin/prokburn
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|-g -O2|${CFLAGS}|; s|-lqt-mt|-lqt-mt ${PTHREAD_LIBS}|' ${WRKSRC}/configure
+.if !defined(WITH_BURN)
+ @${REINPLACE_CMD} -e 's|prokburn||' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e 's|prokburn||' ${WRKSRC}/Makefile.in
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+ @sleep 5
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/prokyon3/distinfo b/audio/prokyon3/distinfo
index db46cfaa66ba..d0debcf11685 100644
--- a/audio/prokyon3/distinfo
+++ b/audio/prokyon3/distinfo
@@ -1 +1 @@
-MD5 (prokyon3-0.9.1-r1.tar.gz) = 767f849e9ba4c5c4ec114f64ecf1824b
+MD5 (prokyon3-0.9.2.tar.gz) = 49e7b2662f4fffc3c366c4fb0ff53d4c
diff --git a/audio/prokyon3/files/patch-src-getopt.h b/audio/prokyon3/files/patch-src-getopt.h
deleted file mode 100644
index ddeb91f4686c..000000000000
--- a/audio/prokyon3/files/patch-src-getopt.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/getopt.h.orig Sun Dec 8 19:29:14 2002
-+++ src/getopt.h Mon Nov 24 21:07:44 2003
-@@ -15,9 +15,6 @@
- along with this program; if not, write to the Free Software
- Foundation, 675 Mass Ave, Cambridge, MA 02139, USA. */
-
--#ifndef _GETOPT_H
--#define _GETOPT_H 1
--
- #ifdef __cplusplus
- extern "C" {
- #endif
-@@ -125,5 +122,3 @@
- #ifdef __cplusplus
- }
- #endif
--
--#endif /* _GETOPT_H */
diff --git a/audio/prokyon3/files/patch-src-tagger_mp3.cpp b/audio/prokyon3/files/patch-src-tagger_mp3.cpp
deleted file mode 100644
index ef28d341e037..000000000000
--- a/audio/prokyon3/files/patch-src-tagger_mp3.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tagger_mp3.cpp.orig Mon Feb 17 00:01:44 2003
-+++ src/tagger_mp3.cpp Mon Nov 24 21:00:58 2003
-@@ -448,7 +448,7 @@
- if(mp3->id3.comment[28] == '\0') {
- mp3->id3.track[0] = mp3->id3.comment[29];
- }
-- mp3->file.readBlock(&(char)mp3->id3.genre[0], 1);
-+ mp3->file.readBlock((char*)&mp3->id3.genre[0], 1);
- unpad(mp3->id3.title);
- unpad(mp3->id3.artist);
- unpad(mp3->id3.album);
diff --git a/audio/prokyon3/files/patch-src_getopt.c b/audio/prokyon3/files/patch-src_getopt.c
new file mode 100644
index 000000000000..6c31966e4c51
--- /dev/null
+++ b/audio/prokyon3/files/patch-src_getopt.c
@@ -0,0 +1,11 @@
+--- src/getopt.c.orig Sat Sep 20 10:34:30 2003
++++ src/getopt.c Sat Sep 20 10:35:56 2003
+@@ -24,6 +24,8 @@
+ #include "config.h"
+ #endif
+
++#define _(String)(String)
++
+ #ifndef __STDC__
+ /* This is a separate conditional since some stdc systems
+ reject `defined (const)'. */
diff --git a/audio/prokyon3/files/patch_prokburn b/audio/prokyon3/files/patch_prokburn
new file mode 100644
index 000000000000..750d52acdee2
--- /dev/null
+++ b/audio/prokyon3/files/patch_prokburn
@@ -0,0 +1,8 @@
+--- prokburn.orig Sun Jan 25 11:25:18 2004
++++ prokburn Sun Jan 25 11:25:41 2004
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/local/bin/bash
+ ####################################################################################"
+ # A small bash utility to burn CD from prokyon3.
+ # PH FERME
diff --git a/audio/prokyon3/pkg-descr b/audio/prokyon3/pkg-descr
index febec2448eea..056a5dd372df 100644
--- a/audio/prokyon3/pkg-descr
+++ b/audio/prokyon3/pkg-descr
@@ -1,10 +1,8 @@
-prokyon3 is a multithreaded MP3 manager and tag editor for Linux.
-It was written in C++ using the Qt3 widget set and the MySQL database.
-prokyon3 can access MP3 files on harddisk, CDROM, SMB and NFS. Files
-can be played using XMMS, and can even be played when the files are on
-CD as prokyon3 identifies CDs by content. The files view is customizable
-and favorite artists are supported. prokyon3 also offers an editor for
-ID3 tags and has been designed to support tagging for multiple files en
+prokyon3 is a multithreaded MP3 manager and tag editor for Linux.
+It was written in C++ using the Qt3 widget set and the MySQL database.
+prokyon3 can access MP3 files on harddisk, CDROM, SMB and NFS. Files
+can be played using XMMS, and can even be played when the files are on
+CD as prokyon3 identifies CDs by content. The files view is customizable
+and favorite artists are supported. prokyon3 also offers an editor for
+ID3 tags and has been designed to support tagging for multiple files en
masse.
-
-WWW: http://prokyon3.sourceforge.net/
diff --git a/audio/prokyon3/pkg-message b/audio/prokyon3/pkg-message
new file mode 100644
index 000000000000..3bf701f290d6
--- /dev/null
+++ b/audio/prokyon3/pkg-message
@@ -0,0 +1,5 @@
+WARNING:
+prokyon-0.9.2 introduces rudimental burning-support, which needs to be
+enabled using WITH_BURN=yes when installing this port. This feature
+hasn't been tested at all. So you have been warned when anything weird
+happens using this feature.
diff --git a/audio/prokyon3/pkg-plist b/audio/prokyon3/pkg-plist
index 9a908a7326a0..a795fa2468ae 100644
--- a/audio/prokyon3/pkg-plist
+++ b/audio/prokyon3/pkg-plist
@@ -29,5 +29,19 @@ share/prokyon3/images/madsmiley.png
share/prokyon3/images/pink_marble.png
share/prokyon3/images/smiley.png
share/prokyon3/images/splash4.png
+share/locale/de/LC_MESSAGES/prokyon3.mo
+share/locale/fr/LC_MESSAGES/prokyon3.mo
+share/locale/nl/LC_MESSAGES/prokyon3.mo
+share/prokyon3/images/action_burncd.png
+share/prokyon3/images/action_documentation.png
+share/prokyon3/html/manual_one_file/images/docbook/important.png
+share/prokyon3/html/manual_one_file/images/docbook/note.png
+share/prokyon3/html/manual_one_file/images/docbook/tip.png
+share/prokyon3/html/manual_one_file/images/docbook/warning.png
+share/prokyon3/html/manual_one_file/index.html
@dirrm share/prokyon3/images
+@dirrm share/prokyon3/html/manual_one_file/images/docbook
+@dirrm share/prokyon3/html/manual_one_file/images
+@dirrm share/prokyon3/html/manual_one_file
+@dirrm share/prokyon3/html
@dirrm share/prokyon3