aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorkbyanc <kbyanc@FreeBSD.org>2006-05-06 06:39:25 +0800
committerkbyanc <kbyanc@FreeBSD.org>2006-05-06 06:39:25 +0800
commitbf5131229dbf031e3001e03d7e21a8dfc4e68b2b (patch)
tree4e9001ae8cb9913d0f14aab776e8bc4dfd95c77f /audio
parentb16aa1eff4bff1ea74cd60b66e1cb51dbb21d0f6 (diff)
downloadfreebsd-ports-gnome-bf5131229dbf031e3001e03d7e21a8dfc4e68b2b.tar.gz
freebsd-ports-gnome-bf5131229dbf031e3001e03d7e21a8dfc4e68b2b.tar.zst
freebsd-ports-gnome-bf5131229dbf031e3001e03d7e21a8dfc4e68b2b.zip
Python wrapper for the TagLib audio meta-data library. TagLib is a library
for reading and editing the meta-data of several popular audio formats. Currently it supports both ID3v1 and ID3v2 for MP3 files, Ogg Vorbis comments and ID3 tags and Vorbis comments in FLAC files.
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-taglib/Makefile28
-rw-r--r--audio/py-taglib/distinfo3
-rw-r--r--audio/py-taglib/pkg-descr6
-rw-r--r--audio/py-taglib/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 3cb5998f4d5e..892925e7c435 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -443,6 +443,7 @@
SUBDIR += py-openal
SUBDIR += py-sdl_mixer
SUBDIR += py-shellac
+ SUBDIR += py-taglib
SUBDIR += py-vorbis
SUBDIR += py-xmms
SUBDIR += py-xmms2
diff --git a/audio/py-taglib/Makefile b/audio/py-taglib/Makefile
new file mode 100644
index 000000000000..0046ecffc649
--- /dev/null
+++ b/audio/py-taglib/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-taglib
+# Date created: 5 May 2006
+# Whom: Kelly Yancey <kbyanc@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= taglib
+PORTVERSION= 1.3.3
+CATEGORIES= audio python
+MASTER_SITES= http://download.berlios.de/namingmuse/ \
+ http://download2.berlios.de/namingmuse/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-taglib-${PORTVERSION}
+
+MAINTAINER= kbyanc@FreeBSD.org
+COMMENT= Python bindings for the taglib audio file tagging library
+
+LIB_DEPENDS= tag.5:${PORTSDIR}/audio/taglib
+
+WRKSRC= ${WRKDIR}/python-taglib-${PORTVERSION}
+
+USE_PYTHON= yes
+USE_PYTHON_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/audio/py-taglib/distinfo b/audio/py-taglib/distinfo
new file mode 100644
index 000000000000..110df8d03369
--- /dev/null
+++ b/audio/py-taglib/distinfo
@@ -0,0 +1,3 @@
+MD5 (python-taglib-1.3.3.tar.gz) = ede76df44e0a82a64a0855f99e0cb4df
+SHA256 (python-taglib-1.3.3.tar.gz) = e33969f9c0676f31e13a3609c426465c58bcd1381754a84408aceb152d854de7
+SIZE (python-taglib-1.3.3.tar.gz) = 346933
diff --git a/audio/py-taglib/pkg-descr b/audio/py-taglib/pkg-descr
new file mode 100644
index 000000000000..94553a8aa46a
--- /dev/null
+++ b/audio/py-taglib/pkg-descr
@@ -0,0 +1,6 @@
+Python wrapper for the TagLib audio meta-data library. TagLib is a library
+for reading and editing the meta-data of several popular audio formats.
+Currently it supports both ID3v1 and ID3v2 for MP3 files, Ogg Vorbis comments
+and ID3 tags and Vorbis comments in FLAC files.
+
+WWW: http://developer.kde.org/~wheeler/taglib.html
diff --git a/audio/py-taglib/pkg-plist b/audio/py-taglib/pkg-plist
new file mode 100644
index 000000000000..56b822d89d30
--- /dev/null
+++ b/audio/py-taglib/pkg-plist
@@ -0,0 +1,5 @@
+%%PYTHON_SITELIBDIR%%/TagLib.py
+%%PYTHON_SITELIBDIR%%/TagLib.pyc
+%%PYTHON_SITELIBDIR%%/TagLib.pyo
+%%PYTHON_SITELIBDIR%%/_TagLib.so
+lib/libpython_taglib.so