aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-03-18 17:44:41 +0800
committermiwi <miwi@FreeBSD.org>2011-03-18 17:44:41 +0800
commitc03cce7bd44c6367a383bf83dfd123f06ff0df59 (patch)
treed89beee39e12d523d7616878a0082b9da8ea1816 /audio
parentf1f10960c57b3992412a7df4416805218be925d0 (diff)
downloadfreebsd-ports-gnome-c03cce7bd44c6367a383bf83dfd123f06ff0df59.tar.gz
freebsd-ports-gnome-c03cce7bd44c6367a383bf83dfd123f06ff0df59.tar.zst
freebsd-ports-gnome-c03cce7bd44c6367a383bf83dfd123f06ff0df59.zip
1. fix portlint complaint about incorrect whitespace in CONFIGURE_ARGS
assignment 2. instead of unconditionally setting LIBS in CONFIGURE_ENV use automake logc to correctly set library dependencies for the case when external libmp4v2 is used Fix #2 also fixes build with non-base gcc: configure stage would pass LIBS to all invocations of gcc and linking would fail because libmp4v2 is a C++ library, but non-base gcc (as opposed to g++) doesn't know where to look for the correct libstdc++. PR: 149765 Submitted by: Andriy Gapon <avg@icyb.net.ua>
Diffstat (limited to 'audio')
-rw-r--r--audio/faac/Makefile5
-rw-r--r--audio/faac/distinfo1
-rw-r--r--audio/faac/files/patch-configure.in12
-rw-r--r--audio/faac/files/patch-frontend_Makefile.am14
4 files changed, 25 insertions, 7 deletions
diff --git a/audio/faac/Makefile b/audio/faac/Makefile
index 822a90289b59..feedc7e7527a 100644
--- a/audio/faac/Makefile
+++ b/audio/faac/Makefile
@@ -25,10 +25,9 @@ MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS= aclocal autoheader automake autoconf libtool
ACLOCAL_ARGS= -I . -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing
-CONFIGURE_ARGS= --with-mp4v2
+CONFIGURE_ARGS= --with-mp4v2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- LIBS="-lmp4v2"
+ LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= yes
MAN1= faac.1
diff --git a/audio/faac/distinfo b/audio/faac/distinfo
index ebd6087d6889..1b1dfae5b86b 100644
--- a/audio/faac/distinfo
+++ b/audio/faac/distinfo
@@ -1,3 +1,2 @@
-MD5 (faac-1.28.tar.bz2) = c5dde68840cefe46532089c9392d1df0
SHA256 (faac-1.28.tar.bz2) = aac475e59d38ae9e29bff760e26bf72b507ccec037a6837cc33e3ac1db3ef352
SIZE (faac-1.28.tar.bz2) = 531256
diff --git a/audio/faac/files/patch-configure.in b/audio/faac/files/patch-configure.in
index cc2b5fc2d6f8..84197eadf8ee 100644
--- a/audio/faac/files/patch-configure.in
+++ b/audio/faac/files/patch-configure.in
@@ -1,5 +1,5 @@
---- ./configure.in.orig 2010-07-11 22:10:12.000000000 +0100
-+++ ./configure.in 2010-07-11 22:10:49.000000000 +0100
+--- configure.in.orig 2010-08-18 15:41:30.584845747 +0300
++++ configure.in 2010-08-18 15:42:51.184443581 +0300
@@ -1,7 +1,7 @@
AC_PREREQ(2.50)
AC_INIT(FAAC, 1.28, faac-dev@lists.sourceforge.net)
@@ -9,7 +9,12 @@
AM_CONFIG_HEADER(config.h)
-@@ -32,10 +32,11 @@
+@@ -28,14 +28,17 @@ AC_CHECK_DECL(strcasecmp, MY_DEFINE(HAVE
+ AC_CHECK_LIB(gnugetopt, getopt_long)
+
+ AM_CONDITIONAL(WITH_MP4V2, false)
++AM_CONDITIONAL(WITH_EXT_MP4V2, false)
+
AC_CHECK_DECLS([MP4Create, MP4MetadataDelete],
AC_CHECK_LIB(mp4v2, MP4MetadataDelete, external_mp4v2=yes,
external_mp4v2=no, -lstdc++),
@@ -18,6 +23,7 @@
if test x$external_mp4v2 = xyes; then
AC_MSG_NOTICE([*** Building with external mp4v2 ***])
++ AM_CONDITIONAL(WITH_EXT_MP4V2, true)
+ MY_DEFINE(HAVE_LIBMP4V2)
else
if test x$WITHMP4V2 = xyes; then
diff --git a/audio/faac/files/patch-frontend_Makefile.am b/audio/faac/files/patch-frontend_Makefile.am
new file mode 100644
index 000000000000..56fe905cd48d
--- /dev/null
+++ b/audio/faac/files/patch-frontend_Makefile.am
@@ -0,0 +1,14 @@
+--- frontend/Makefile.am.orig 2010-08-18 15:43:04.246728673 +0300
++++ frontend/Makefile.am 2010-08-18 15:45:44.922966543 +0300
+@@ -7,6 +7,11 @@ if WITH_MP4V2
+ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/common/mp4v2
+ LDADD = $(top_builddir)/libfaac/libfaac.la $(top_srcdir)/common/mp4v2/libmp4v2.a -lm -lstdc++
+ else
++if WITH_EXT_MP4V2
++INCLUDES = -I$(top_srcdir)/include
++LDADD = $(top_builddir)/libfaac/libfaac.la -lmp4v2 -lm -lstdc++
++else
+ INCLUDES = -I$(top_srcdir)/include
+ LDADD = $(top_builddir)/libfaac/libfaac.la -lm
+ endif
++endif