aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2011-11-12 22:41:55 +0800
committerrakuco <rakuco@FreeBSD.org>2011-11-12 22:41:55 +0800
commitc149948b342d8b43cb73d3bd3935cab1965c5ac2 (patch)
tree5cb7066b6a22d089ede4828dbc0818768dcaea9c /audio
parenta93057e56a65b48cc7a3e9a4f820b33304b69a04 (diff)
downloadfreebsd-ports-gnome-c149948b342d8b43cb73d3bd3935cab1965c5ac2.tar.gz
freebsd-ports-gnome-c149948b342d8b43cb73d3bd3935cab1965c5ac2.tar.zst
freebsd-ports-gnome-c149948b342d8b43cb73d3bd3935cab1965c5ac2.zip
Fix build after bsd.cmake.mk's r1.13.
Remove the part of files/patch-plugins__zynaddsubfx__CMakeLists.txt which actually removed the call which linked to pthread -- it is now needed since we do not rely on it being passed via LDFLAGS anymore. Approved by: avilla (mentor, implicit) Feature safe: yes
Diffstat (limited to 'audio')
-rw-r--r--audio/lmms/files/patch-plugins__zynaddsubfx__CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/lmms/files/patch-plugins__zynaddsubfx__CMakeLists.txt b/audio/lmms/files/patch-plugins__zynaddsubfx__CMakeLists.txt
index 7adaef165ef5..0c3a9fec248c 100644
--- a/audio/lmms/files/patch-plugins__zynaddsubfx__CMakeLists.txt
+++ b/audio/lmms/files/patch-plugins__zynaddsubfx__CMakeLists.txt
@@ -23,7 +23,7 @@
ADD_LIBRARY(ZynAddSubFxCore SHARED LocalZynAddSubFx.cpp ${MXML_SRC})
-TARGET_LINK_LIBRARIES(ZynAddSubFxCore ${ZASF_CORE_LIBS} ${FFTW3F_LIBRARIES} -lz -lpthread)
-+TARGET_LINK_LIBRARIES(ZynAddSubFxCore ${ZASF_CORE_LIBS} ${FFTW3F_LIBRARIES} -lz -L${FFTW3F_LIBRARY_DIRS})
++TARGET_LINK_LIBRARIES(ZynAddSubFxCore ${ZASF_CORE_LIBS} ${FFTW3F_LIBRARIES} -lz -lpthread -L${FFTW3F_LIBRARY_DIRS})
IF(LMMS_BUILD_WIN32)
TARGET_LINK_LIBRARIES(ZynAddSubFxCore -lwsock32)
INSTALL(TARGETS ZynAddSubFxCore DESTINATION ${PLUGIN_DIR})