aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2013-11-06 07:28:09 +0800
committerdb <db@FreeBSD.org>2013-11-06 07:28:09 +0800
commitc5b9bb542fd3336c501f7cfdc93b0ea6e74bd964 (patch)
tree4694a629e7442c635b38eb67a0f93a05423e37d4 /audio
parent4b996d2eda3d31d70dd180ec322603b1de6343e7 (diff)
downloadfreebsd-ports-gnome-c5b9bb542fd3336c501f7cfdc93b0ea6e74bd964.tar.gz
freebsd-ports-gnome-c5b9bb542fd3336c501f7cfdc93b0ea6e74bd964.tar.zst
freebsd-ports-gnome-c5b9bb542fd3336c501f7cfdc93b0ea6e74bd964.zip
- As described by Mamoru Iwaki <1wkmmr@gmail.com> in email
> I have just looked around audio/xoscope, not compiling it yet. Then, I > found a strange line in files/patch-ser_unix.c, as follows: > > 34 +#ifdef BSD > 35 + if (tcgetattr(fd, &svbuf) < 0 ) { > 36 +#else > 37 if (ioctl(fd, TCSETA, &svbuf) < 0) { > 38 +#endif > > I wonder tcgetattr(...) in line 35 should be tcsetattr(...). It should be, but the fd involved was for hardware that is no longer made but it is a trivial fix so fixed anyway. - Convert to stagedir while in here. Submitted by: 1wkmmr@gmail.com (for tcsetattr note)
Diffstat (limited to 'audio')
-rw-r--r--audio/xoscope/Makefile3
-rw-r--r--audio/xoscope/files/patch-ser_unix.c4
-rw-r--r--audio/xoscope/pkg-plist1
3 files changed, 4 insertions, 4 deletions
diff --git a/audio/xoscope/Makefile b/audio/xoscope/Makefile
index 4dce3f8e77d4..a9c288d9ffdc 100644
--- a/audio/xoscope/Makefile
+++ b/audio/xoscope/Makefile
@@ -10,9 +10,8 @@ MAINTAINER= db@FreeBSD.org
COMMENT= Sound card oscilloscope
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --sysconfdir=${PREFIX}
+CONFIGURE_ARGS= --prefix=${STAGEDIR}${PREFIX} --sysconfdir=${STAGEDIR}${PREFIX}
USES= gmake pkgconfig
-NO_STAGE= yes
USE_GNOME= gtk20
USE_XORG= x11
diff --git a/audio/xoscope/files/patch-ser_unix.c b/audio/xoscope/files/patch-ser_unix.c
index 90609fa51f31..24ef4dba3492 100644
--- a/audio/xoscope/files/patch-ser_unix.c
+++ b/audio/xoscope/files/patch-ser_unix.c
@@ -1,5 +1,5 @@
--- ser_unix.c.orig 2008-12-17 12:46:15.000000000 -0500
-+++ ser_unix.c 2012-11-04 09:22:00.000000000 -0500
++++ ser_unix.c 2013-11-05 18:03:15.000000000 -0500
@@ -14,7 +14,14 @@
#include <errno.h>
#include <unistd.h>
@@ -32,7 +32,7 @@
{
if (fd > 0) {
+#ifdef BSD
-+ if (tcgetattr(fd, &svbuf) < 0 ) {
++ if (tcsetattr(fd, TCSANOW, &svbuf) < 0 ) {
+#else
if (ioctl(fd, TCSETA, &svbuf) < 0) {
+#endif
diff --git a/audio/xoscope/pkg-plist b/audio/xoscope/pkg-plist
index d203db6f8159..13c51f588431 100644
--- a/audio/xoscope/pkg-plist
+++ b/audio/xoscope/pkg-plist
@@ -1 +1,2 @@
bin/xoscope
+man/man1/xoscope.1.gz