aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-09-01 07:42:23 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2020-09-01 07:42:23 +0800
commitc95a5a0bf4072cee5b9201c60f83066af44bc72b (patch)
tree57c61855a36369aa1fe448a80e999e870ab37039 /audio
parentdf055863e47a66c945ec3a4ab18a757c2976d3b5 (diff)
downloadfreebsd-ports-gnome-c95a5a0bf4072cee5b9201c60f83066af44bc72b.tar.gz
freebsd-ports-gnome-c95a5a0bf4072cee5b9201c60f83066af44bc72b.tar.zst
freebsd-ports-gnome-c95a5a0bf4072cee5b9201c60f83066af44bc72b.zip
New port: audio/dragonfly-reverb-lv2: Bundle of free audio effects
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/dragonfly-reverb-lv2/Makefile53
-rw-r--r--audio/dragonfly-reverb-lv2/distinfo5
-rw-r--r--audio/dragonfly-reverb-lv2/files/mntent.h64
-rw-r--r--audio/dragonfly-reverb-lv2/pkg-descr3
-rw-r--r--audio/dragonfly-reverb-lv2/pkg-plist28
6 files changed, 154 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8d8b5df3e696..8075628e1f70 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -117,6 +117,7 @@
SUBDIR += din
SUBDIR += discid
SUBDIR += dpf-plugins-lv2
+ SUBDIR += dragonfly-reverb-lv2
SUBDIR += drumgizmo
SUBDIR += drumkv1-lv2
SUBDIR += drumpiler
diff --git a/audio/dragonfly-reverb-lv2/Makefile b/audio/dragonfly-reverb-lv2/Makefile
new file mode 100644
index 000000000000..6fc1eb67b059
--- /dev/null
+++ b/audio/dragonfly-reverb-lv2/Makefile
@@ -0,0 +1,53 @@
+# $FreeBSD$
+
+PORTNAME= dragonfly-reverb
+DISTVERSION= 3.2.1
+CATEGORIES= audio multimedia
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Bundle of free audio effects
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+
+USES= compiler:c++11-lang gl gmake localbase pkgconfig shebangfix xorg
+SHEBANG_FILES= dpf/utils/generate-ttl.sh
+USE_GITHUB= yes
+GH_ACCOUNT= michaelwillis
+GH_TUPLE= DISTRHO:DPF:1e9e2067caa728fdb0b6d3b0001f37de721b0faa:DISTRHO_DPF/dpf
+USE_GL= gl
+USE_XORG= x11
+
+CXXFLAGS+= -I${FILESDIR}
+
+EFFECTS= DragonflyEarlyReflections DragonflyHallReverb DragonflyPlateReverb DragonflyRoomReverb
+
+OPTIONS_DEFINE= APPS VST
+OPTIONS_DEFAULT= APPS VST
+OPTIONS_SUB= yes
+
+APPS_DESC= Install apps instantiating effects in Jack sound server
+APPS_LIB_DEPENDS= libjack.so:audio/jack
+
+VST_DESC= Install VST plugins
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/lv2
+.for r in ${EFFECTS}
+ cd ${WRKSRC}/bin && ${COPYTREE_SHARE} ${r}.lv2 ${STAGEDIR}${PREFIX}/lib/lv2
+.endfor
+
+do-install-APPS-on:
+.for r in ${EFFECTS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${r} ${STAGEDIR}${PREFIX}/bin
+.endfor
+
+do-install-VST-on:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/vst
+.for r in ${EFFECTS}
+ ${INSTALL_LIB} ${WRKSRC}/bin/${r}-vst.so ${STAGEDIR}${PREFIX}/lib/vst
+.endfor
+
+.include <bsd.port.mk>
diff --git a/audio/dragonfly-reverb-lv2/distinfo b/audio/dragonfly-reverb-lv2/distinfo
new file mode 100644
index 000000000000..8d5a76d6c3d6
--- /dev/null
+++ b/audio/dragonfly-reverb-lv2/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1598914433
+SHA256 (michaelwillis-dragonfly-reverb-3.2.1_GH0.tar.gz) = 7d7300be23103e4be87640079d10936f3156ee1a5fb3dc9c46af918fd288071a
+SIZE (michaelwillis-dragonfly-reverb-3.2.1_GH0.tar.gz) = 20809474
+SHA256 (DISTRHO-DPF-1e9e2067caa728fdb0b6d3b0001f37de721b0faa_GH0.tar.gz) = fac6603dcf29f66ce9f98044a00775fa7c7534a01614b24bec53e8ce5d27b89c
+SIZE (DISTRHO-DPF-1e9e2067caa728fdb0b6d3b0001f37de721b0faa_GH0.tar.gz) = 2114583
diff --git a/audio/dragonfly-reverb-lv2/files/mntent.h b/audio/dragonfly-reverb-lv2/files/mntent.h
new file mode 100644
index 000000000000..5cdf9881ccca
--- /dev/null
+++ b/audio/dragonfly-reverb-lv2/files/mntent.h
@@ -0,0 +1,64 @@
+/*
+ * mntent
+ * mntent.h - compatability header for FreeBSD
+ *
+ * Copyright (c) 2001 David Rufino <daverufino@btinternet.com>
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ */
+
+// $FreeBSD$
+
+#if defined(HAVE_MNTENT_H)
+#include <mntent.h>
+#else
+#ifndef _MNTENT_H
+#define _MNTENT_H
+#include <stdio.h>
+
+#define MOUNTED "dummy"
+
+#define MNTTYPE_NFS "nfs"
+
+struct mntent {
+ char *mnt_fsname;
+ char *mnt_dir;
+ char *mnt_type;
+ char *mnt_opts;
+ int mnt_freq;
+ int mnt_passno;
+};
+
+#define setmntent(x,y) ((FILE *)0x1)
+#ifdef __cplusplus
+extern "C" {
+#endif
+struct mntent *getmntent __P ((FILE *fp));
+char *hasmntopt __P ((const struct mntent *mnt, const char *option));
+#ifdef __cplusplus
+}; // extern "C"
+#endif
+#define endmntent(x) ((int)1)
+
+#endif /* _MNTENT_H */
+#endif /* HAVE_MNTENT_H */
diff --git a/audio/dragonfly-reverb-lv2/pkg-descr b/audio/dragonfly-reverb-lv2/pkg-descr
new file mode 100644
index 000000000000..a1441f936ee5
--- /dev/null
+++ b/audio/dragonfly-reverb-lv2/pkg-descr
@@ -0,0 +1,3 @@
+Dragonfly Reverb is a bundle of free audio effects.
+
+WWW: https://github.com/michaelwillis/dragonfly-reverb
diff --git a/audio/dragonfly-reverb-lv2/pkg-plist b/audio/dragonfly-reverb-lv2/pkg-plist
new file mode 100644
index 000000000000..1002a5c55fb9
--- /dev/null
+++ b/audio/dragonfly-reverb-lv2/pkg-plist
@@ -0,0 +1,28 @@
+%%APPS%%bin/DragonflyEarlyReflections
+%%APPS%%bin/DragonflyHallReverb
+%%APPS%%bin/DragonflyPlateReverb
+%%APPS%%bin/DragonflyRoomReverb
+lib/lv2/DragonflyEarlyReflections.lv2/DragonflyEarlyReflections_dsp.so
+lib/lv2/DragonflyEarlyReflections.lv2/DragonflyEarlyReflections_dsp.ttl
+lib/lv2/DragonflyEarlyReflections.lv2/DragonflyEarlyReflections_ui.so
+lib/lv2/DragonflyEarlyReflections.lv2/DragonflyEarlyReflections_ui.ttl
+lib/lv2/DragonflyEarlyReflections.lv2/manifest.ttl
+lib/lv2/DragonflyHallReverb.lv2/DragonflyHallReverb_dsp.so
+lib/lv2/DragonflyHallReverb.lv2/DragonflyHallReverb_dsp.ttl
+lib/lv2/DragonflyHallReverb.lv2/DragonflyHallReverb_ui.so
+lib/lv2/DragonflyHallReverb.lv2/DragonflyHallReverb_ui.ttl
+lib/lv2/DragonflyHallReverb.lv2/manifest.ttl
+lib/lv2/DragonflyPlateReverb.lv2/DragonflyPlateReverb_dsp.so
+lib/lv2/DragonflyPlateReverb.lv2/DragonflyPlateReverb_dsp.ttl
+lib/lv2/DragonflyPlateReverb.lv2/DragonflyPlateReverb_ui.so
+lib/lv2/DragonflyPlateReverb.lv2/DragonflyPlateReverb_ui.ttl
+lib/lv2/DragonflyPlateReverb.lv2/manifest.ttl
+lib/lv2/DragonflyRoomReverb.lv2/DragonflyRoomReverb_dsp.so
+lib/lv2/DragonflyRoomReverb.lv2/DragonflyRoomReverb_dsp.ttl
+lib/lv2/DragonflyRoomReverb.lv2/DragonflyRoomReverb_ui.so
+lib/lv2/DragonflyRoomReverb.lv2/DragonflyRoomReverb_ui.ttl
+lib/lv2/DragonflyRoomReverb.lv2/manifest.ttl
+%%VST%%lib/vst/DragonflyEarlyReflections-vst.so
+%%VST%%lib/vst/DragonflyHallReverb-vst.so
+%%VST%%lib/vst/DragonflyPlateReverb-vst.so
+%%VST%%lib/vst/DragonflyRoomReverb-vst.so