aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-02-06 22:20:53 +0800
committerlofi <lofi@FreeBSD.org>2007-02-06 22:20:53 +0800
commitcd8677f9e366a92520219dc9bbccf56bf9797678 (patch)
tree7ce417d8100e26ed67c20b9c98be6757e0181253 /audio
parent501aebcdc009b7def2177f8f3de1851dbda8b66e (diff)
downloadfreebsd-ports-gnome-cd8677f9e366a92520219dc9bbccf56bf9797678.tar.gz
freebsd-ports-gnome-cd8677f9e366a92520219dc9bbccf56bf9797678.tar.zst
freebsd-ports-gnome-cd8677f9e366a92520219dc9bbccf56bf9797678.zip
Add last.fm 1.1.3, the official last.fm radio player.
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/last.fm/Makefile45
-rw-r--r--audio/last.fm/distinfo3
-rw-r--r--audio/last.fm/files/lastfm.protocol11
-rw-r--r--audio/last.fm/files/patch-configure33
-rw-r--r--audio/last.fm/files/patch-src_rtaudioplayback-rtaudioplayback.cpp11
-rw-r--r--audio/last.fm/files/patch-src_rtaudioplayback-rtaudioplayback.pro13
-rw-r--r--audio/last.fm/files/patch-src_rtaudioplayback_rtaudio-RtAudio.cpp11
-rw-r--r--audio/last.fm/files/pkg-deinstall.in24
-rw-r--r--audio/last.fm/files/pkg-install.in28
-rw-r--r--audio/last.fm/pkg-descr4
-rw-r--r--audio/last.fm/pkg-message7
-rw-r--r--audio/last.fm/pkg-plist120
13 files changed, 311 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 5f52abcdd8ae..bdb9cdd6655e 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -306,6 +306,7 @@
SUBDIR += ladspa
SUBDIR += lame
SUBDIR += lash
+ SUBDIR += last.fm
SUBDIR += laudio
SUBDIR += liba52
SUBDIR += liba52-devel
diff --git a/audio/last.fm/Makefile b/audio/last.fm/Makefile
new file mode 100644
index 000000000000..ab354e8d9f7c
--- /dev/null
+++ b/audio/last.fm/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: last.fm
+# Date created: February 5th, 2007
+# Whom: Michael Nottebrock <lofi@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= last.fm
+PORTVERSION= 1.1.3
+CATEGORIES= audio net
+MASTER_SITES= http://static.last.fm/client/Linux/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
+
+MAINTAINER= lofi@FreeBSD.org
+COMMENT= Official last.fm radio player
+
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+SUB_FILES= pkg-install pkg-deinstall
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui imageformats moc network uic xml
+HAS_CONFIGURE= yes
+
+CONFIGURE_ENV+= X11BASE=${X11BASE}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+post-build:
+ ${REINPLACE_CMD} -e 's|`dirname $$0`|${DATADIR}|g' \
+ ${WRKSRC}/bin/last.fm
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/last.fm ${PREFIX}/bin/last.fm
+ ${MKDIR} ${PREFIX}/share/services
+ ${INSTALL_DATA} ${FILESDIR}/lastfm.protocol ${PREFIX}/share/services
+ ${MKDIR} ${DATADIR}
+ ${CP} -Rp ${WRKSRC}/bin/* ${DATADIR}/
+
+post-install:
+.if !defined(PACKAGE_BUILDING)
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/last.fm/distinfo b/audio/last.fm/distinfo
new file mode 100644
index 000000000000..e6203f8265f9
--- /dev/null
+++ b/audio/last.fm/distinfo
@@ -0,0 +1,3 @@
+MD5 (last.fm-1.1.3.src.tar.bz2) = 237531e1b30f75c4c0c07e7e39e9a250
+SHA256 (last.fm-1.1.3.src.tar.bz2) = e05f9b1e177f6c4801295d33246e891690447c594b1138a292779dcef7d85cec
+SIZE (last.fm-1.1.3.src.tar.bz2) = 856755
diff --git a/audio/last.fm/files/lastfm.protocol b/audio/last.fm/files/lastfm.protocol
new file mode 100644
index 000000000000..1ca23d91e6b5
--- /dev/null
+++ b/audio/last.fm/files/lastfm.protocol
@@ -0,0 +1,11 @@
+[Protocol]
+exec=last.fm "%u"
+protocol=lastfm
+input=none
+output=none
+helper=true
+reading=false
+listing=false
+writing=false
+makedir=false
+deleting=false
diff --git a/audio/last.fm/files/patch-configure b/audio/last.fm/files/patch-configure
new file mode 100644
index 000000000000..007dd96c604f
--- /dev/null
+++ b/audio/last.fm/files/patch-configure
@@ -0,0 +1,33 @@
+--- configure.orig Mon Feb 5 23:02:40 2007
++++ configure Mon Feb 5 23:03:29 2007
+@@ -1,10 +1,10 @@
+-#!/bin/bash
++#!/bin/sh
+
+ echo -e '\E[0;34m'"\033[1mLast.fm-1.1.3 Configure\033[0m"
+
+ echo "Checking for qmake..."
+
+-qmake -v &> /dev/null
++qmake-qt4 -v &> /dev/null
+ if [[ $? = 127 ]]; then
+ ################################################################################
+ echo
+@@ -19,7 +19,7 @@
+ # QMake version 2.01a
+ # Using Qt version 4.2.2 in /opt/qt/4.2.2/lib
+
+-qmake -v | grep '^Using Qt version 4.2' --color=never &> /dev/null
++qmake-qt4 -v | grep '^Using Qt version 4.2' --color=never &> /dev/null
+
+ if [[ $? > 0 ]]; then
+ ################################################################################
+@@ -40,7 +40,7 @@
+
+ echo "Generating Makefiles..."
+
+-qmake -config release -after "CONFIG-=debug"
++qmake-qt4 -config release -after "CONFIG-=debug" "INCLUDEPATH+=${X11BASE}/include"
+
+ echo
+ echo "Good, your configure is finished. Now type 'make'"
diff --git a/audio/last.fm/files/patch-src_rtaudioplayback-rtaudioplayback.cpp b/audio/last.fm/files/patch-src_rtaudioplayback-rtaudioplayback.cpp
new file mode 100644
index 000000000000..f1d1f6a57b65
--- /dev/null
+++ b/audio/last.fm/files/patch-src_rtaudioplayback-rtaudioplayback.cpp
@@ -0,0 +1,11 @@
+--- src/rtaudioplayback/rtaudioplayback.cpp.orig Tue Feb 6 00:09:15 2007
++++ src/rtaudioplayback/rtaudioplayback.cpp Tue Feb 6 00:09:41 2007
+@@ -204,7 +204,7 @@
+ LOGL( 3, "Card ID " << settingsService()->soundCard() << " - translated to internal ID " << card );
+
+ #ifdef Q_WS_X11
+- api = RtAudio::LINUX_ALSA;
++ api = RtAudio::LINUX_OSS;
+ #endif
+
+ RtAudioDeviceInfo info = m_audio->getDeviceInfo( card );
diff --git a/audio/last.fm/files/patch-src_rtaudioplayback-rtaudioplayback.pro b/audio/last.fm/files/patch-src_rtaudioplayback-rtaudioplayback.pro
new file mode 100644
index 000000000000..b0a0eff47048
--- /dev/null
+++ b/audio/last.fm/files/patch-src_rtaudioplayback-rtaudioplayback.pro
@@ -0,0 +1,13 @@
+--- src/rtaudioplayback/rtaudioplayback.pro.orig Tue Feb 6 00:13:48 2007
++++ src/rtaudioplayback/rtaudioplayback.pro Tue Feb 6 00:14:18 2007
+@@ -25,10 +25,6 @@
+
+ QT += gui xml network
+
+-unix:!mac {
+- LIBS += -lasound
+-}
+-
+ win32 {
+ LIBS += -lwinmm -ldsound -lole32 -lgdi32 -luser32 -lshfolder
+ INCLUDEPATH += "c:\program files\microsoft directx sdk (april 2006)\include"
diff --git a/audio/last.fm/files/patch-src_rtaudioplayback_rtaudio-RtAudio.cpp b/audio/last.fm/files/patch-src_rtaudioplayback_rtaudio-RtAudio.cpp
new file mode 100644
index 000000000000..442f2cd5b4b1
--- /dev/null
+++ b/audio/last.fm/files/patch-src_rtaudioplayback_rtaudio-RtAudio.cpp
@@ -0,0 +1,11 @@
+--- src/rtaudioplayback/rtaudio/RtAudio.cpp.orig Tue Feb 6 00:07:31 2007
++++ src/rtaudioplayback/rtaudio/RtAudio.cpp Tue Feb 6 00:08:41 2007
+@@ -42,7 +42,7 @@
+ #include <QtGui>
+
+ #ifdef Q_WS_X11
+- #define __LINUX_ALSA__
++ #define __LINUX_OSS__
+ #endif
+ #ifdef Q_WS_FREEBSD
+ #define __LINUX_OSS__
diff --git a/audio/last.fm/files/pkg-deinstall.in b/audio/last.fm/files/pkg-deinstall.in
new file mode 100644
index 000000000000..82660dd0f86a
--- /dev/null
+++ b/audio/last.fm/files/pkg-deinstall.in
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/audio/last.fm/files/pkg-deinstall.in,v 1.1 2007-02-06 14:20:53 lofi Exp $
+#
+
+if [ "$2" != "POST-DEINSTALL" ]; then
+ exit 0
+fi
+
+lmozprefs=%%LOCALBASE%%/lib/linux-firefox/defaults/pref/firefox.js
+blmozprefs=%%LOCALBASE%%/lib/linux-firefox/defaults/pref/firefox.js.bak
+
+mozprefs=%%LOCALBASE%%/lib/firefox/defaults/pref/firefox.js
+bmozprefs=%%LOCALBASE%%/lib/firefox/defaults/pref/firefox.js.bak
+
+if [ -f $lmozprefs -a -f $blmozprefs ]; then
+ mv $blmozprefs $lmozprefs
+fi
+
+if [ -f $mozprefs -a -f $bmozprefs ]; then
+ mv $bmozprefs $mozprefs
+fi
+
+exit 0
diff --git a/audio/last.fm/files/pkg-install.in b/audio/last.fm/files/pkg-install.in
new file mode 100644
index 000000000000..325d272bd95e
--- /dev/null
+++ b/audio/last.fm/files/pkg-install.in
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/audio/last.fm/files/pkg-install.in,v 1.1 2007-02-06 14:20:53 lofi Exp $
+#
+
+if [ "$2" != "POST-INSTALL" ]; then
+ exit 0
+fi
+
+lmozprefs=%%LOCALBASE%%/lib/linux-firefox/defaults/pref/firefox.js
+blmozprefs=%%LOCALBASE%%/lib/linux-firefox/defaults/pref/firefox.js.bak
+
+mozprefs=%%LOCALBASE%%/lib/firefox/defaults/pref/firefox.js
+bmozprefs=%%LOCALBASE%%/lib/firefox/defaults/pref/firefox.js.bak
+
+if [ -f $lmozprefs ]; then
+ cp $lmozprefs $blmozprefs
+ echo 'pref("network.protocol-handler.app.lastfm", "/usr/local/bin/last.fm");' >> $lmozprefs
+fi
+
+if [ -f $mozprefs ]; then
+ cp $mozprefs $bmozprefs
+ echo 'pref("network.protocol-handler.app.lastfm", "/usr/local/bin/last.fm");' >> $mozprefs
+fi
+
+
+
+exit 0
diff --git a/audio/last.fm/pkg-descr b/audio/last.fm/pkg-descr
new file mode 100644
index 000000000000..5cf7ae7359e8
--- /dev/null
+++ b/audio/last.fm/pkg-descr
@@ -0,0 +1,4 @@
+The official last.fm radio player application. Integrates with Konqueror and
+(Linux-)Firefox.
+
+WWW: http://www.last.fm
diff --git a/audio/last.fm/pkg-message b/audio/last.fm/pkg-message
new file mode 100644
index 000000000000..8872cfa746e5
--- /dev/null
+++ b/audio/last.fm/pkg-message
@@ -0,0 +1,7 @@
+#################################################################
+
+The support for lastfm:// URIs in Konqueror and Firefox will only
+work in browser instances started after the installation of this
+package.
+
+#################################################################
diff --git a/audio/last.fm/pkg-plist b/audio/last.fm/pkg-plist
new file mode 100644
index 000000000000..d17e83247845
--- /dev/null
+++ b/audio/last.fm/pkg-plist
@@ -0,0 +1,120 @@
+bin/last.fm
+%%DATADIR%%/data/about.png
+%%DATADIR%%/data/about_generic.png
+%%DATADIR%%/data/about_mac.png
+%%DATADIR%%/data/app_55.png
+%%DATADIR%%/data/buttons/action_edit.png
+%%DATADIR%%/data/buttons/action_edit_down.png
+%%DATADIR%%/data/buttons/action_edit_hover.png
+%%DATADIR%%/data/buttons/action_tag.png
+%%DATADIR%%/data/buttons/action_tag_down.png
+%%DATADIR%%/data/buttons/action_tag_hover.png
+%%DATADIR%%/data/buttons/action_upload.png
+%%DATADIR%%/data/buttons/action_upload_down.png
+%%DATADIR%%/data/buttons/action_upload_hover.png
+%%DATADIR%%/data/buttons/ban.png
+%%DATADIR%%/data/buttons/closebutton.png
+%%DATADIR%%/data/buttons/love.png
+%%DATADIR%%/data/buttons/myprofile.png
+%%DATADIR%%/data/buttons/play.png
+%%DATADIR%%/data/buttons/recommend.png
+%%DATADIR%%/data/buttons/scrobble.png
+%%DATADIR%%/data/buttons/skip.png
+%%DATADIR%%/data/buttons/skip_active.png
+%%DATADIR%%/data/buttons/stop.png
+%%DATADIR%%/data/buttons/stop_active.png
+%%DATADIR%%/data/buttons/tag.png
+%%DATADIR%%/data/icons/as.ico
+%%DATADIR%%/data/icons/as.png
+%%DATADIR%%/data/icons/blackprofile24.png
+%%DATADIR%%/data/icons/blueprofile24.png
+%%DATADIR%%/data/icons/buy_album.png
+%%DATADIR%%/data/icons/buy_track.png
+%%DATADIR%%/data/icons/greenprofile24.png
+%%DATADIR%%/data/icons/history16.png
+%%DATADIR%%/data/icons/history32.png
+%%DATADIR%%/data/icons/icon_radio.png
+%%DATADIR%%/data/icons/icon_tag.png
+%%DATADIR%%/data/icons/icon_track.png
+%%DATADIR%%/data/icons/icon_user.png
+%%DATADIR%%/data/icons/lastfm.icns
+%%DATADIR%%/data/icons/loved_radio.png
+%%DATADIR%%/data/icons/my_bookmarks.png
+%%DATADIR%%/data/icons/my_friends.png
+%%DATADIR%%/data/icons/my_neighbours.png
+%%DATADIR%%/data/icons/my_tags.png
+%%DATADIR%%/data/icons/neighbour_radio.png
+%%DATADIR%%/data/icons/options_account.png
+%%DATADIR%%/data/icons/options_connection.png
+%%DATADIR%%/data/icons/options_radio.png
+%%DATADIR%%/data/icons/options_scrobbling.png
+%%DATADIR%%/data/icons/orangeprofile24.png
+%%DATADIR%%/data/icons/personal_radio.png
+%%DATADIR%%/data/icons/qt_cross.png
+%%DATADIR%%/data/icons/recent_tracks.png
+%%DATADIR%%/data/icons/recently_banned.png
+%%DATADIR%%/data/icons/recently_loved.png
+%%DATADIR%%/data/icons/recommended_radio.png
+%%DATADIR%%/data/icons/redprofile24.png
+%%DATADIR%%/data/icons/scrobble16.png
+%%DATADIR%%/data/icons/scrobbling_graphic.png
+%%DATADIR%%/data/icons/systray_mac.png
+%%DATADIR%%/data/icons/user_black.png
+%%DATADIR%%/data/icons/user_black32_collapse.png
+%%DATADIR%%/data/icons/user_black32_expand.png
+%%DATADIR%%/data/icons/user_blue.png
+%%DATADIR%%/data/icons/user_blue32_collapse.png
+%%DATADIR%%/data/icons/user_blue32_expand.png
+%%DATADIR%%/data/icons/user_disabled.png
+%%DATADIR%%/data/icons/user_green.png
+%%DATADIR%%/data/icons/user_green32_collapse.png
+%%DATADIR%%/data/icons/user_green32_expand.png
+%%DATADIR%%/data/icons/user_orange.png
+%%DATADIR%%/data/icons/user_orange32_collapse.png
+%%DATADIR%%/data/icons/user_orange32_expand.png
+%%DATADIR%%/data/icons/user_purple.png
+%%DATADIR%%/data/icons/user_red.png
+%%DATADIR%%/data/icons/user_red32_collapse.png
+%%DATADIR%%/data/icons/user_red32_expand.png
+%%DATADIR%%/data/install_mac.png
+%%DATADIR%%/data/logo.png
+%%DATADIR%%/data/no_artist.gif
+%%DATADIR%%/data/no_cover.gif
+%%DATADIR%%/data/progress.mng
+%%DATADIR%%/data/progress_active.mng
+%%DATADIR%%/data/slider_knob.png
+%%DATADIR%%/data/slider_left.png
+%%DATADIR%%/data/slider_middle.png
+%%DATADIR%%/data/slider_right.png
+%%DATADIR%%/data/speaker_high.png
+%%DATADIR%%/data/speaker_low.png
+%%DATADIR%%/data/watermark.png
+%%DATADIR%%/data/wizard.png
+%%DATADIR%%/data/wizard_generic.png
+%%DATADIR%%/data/wizard_mac.png
+%%DATADIR%%/extensions/libextension_metadata.so
+%%DATADIR%%/extensions/libextension_search.so
+%%DATADIR%%/extensions/libextension_sidebar.so
+%%DATADIR%%/extensions/libextension_userinfo.so
+%%DATADIR%%/last.fm
+%%DATADIR%%/last.fm.app
+%%DATADIR%%/last.fm.bak
+%%DATADIR%%/libLastFMTools.so
+%%DATADIR%%/libLastFMTools.so.1
+%%DATADIR%%/libLastFMTools.so.1.0
+%%DATADIR%%/libLastFMTools.so.1.0.0
+%%DATADIR%%/services/libinput_http.so
+%%DATADIR%%/services/libmediadevice_itunes.so
+%%DATADIR%%/services/libplayback_rtaudio.so
+%%DATADIR%%/services/libservice_settings.so
+%%DATADIR%%/services/libservice_web.so
+%%DATADIR%%/services/libtranscode_mp3.so
+share/services/lastfm.protocol
+@dirrmtry share/services
+@dirrm %%DATADIR%%/services
+@dirrm %%DATADIR%%/extensions
+@dirrm %%DATADIR%%/data/icons
+@dirrm %%DATADIR%%/data/i18n
+@dirrm %%DATADIR%%/data/buttons
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%