aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-12-27 19:05:30 +0800
committerbapt <bapt@FreeBSD.org>2013-12-27 19:05:30 +0800
commitd0ea75a9706ed29934ad1323bc74b25b11727a19 (patch)
treea7c254661dec1a5a1c71e7b6c7298740b6f71e3f /audio
parent7f2f0f0c7458e84299acd6a36e753b05e4fdd913 (diff)
downloadfreebsd-ports-gnome-d0ea75a9706ed29934ad1323bc74b25b11727a19.tar.gz
freebsd-ports-gnome-d0ea75a9706ed29934ad1323bc74b25b11727a19.tar.zst
freebsd-ports-gnome-d0ea75a9706ed29934ad1323bc74b25b11727a19.zip
Use CFLAGS_
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms-sapplug/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/audio/xmms-sapplug/Makefile b/audio/xmms-sapplug/Makefile
index 9b5fdd2be3ba..d877eecab1aa 100644
--- a/audio/xmms-sapplug/Makefile
+++ b/audio/xmms-sapplug/Makefile
@@ -27,6 +27,9 @@ PLIST_FILES= lib/xmms/Input/libsap.so
OPTIONS_DEFINE= OPTIMIZED_CFLAGS
+CFLAGS_amd64= -fpic -DPIC
+CFLAGS_ia64= -fpic -DPIC
+
.include <bsd.port.pre.mk>
# clang can build this without -fno-exceptions
@@ -34,10 +37,6 @@ OPTIONS_DEFINE= OPTIMIZED_CFLAGS
CXXFLAGS+= -fno-exceptions
.endif
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
-CFLAGS+= -fpic -DPIC
-.endif
-
.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CXXFLAGS+= -fPIC -fpic -funroll-all-loops -fno-strength-reduce \
-finline-functions -fomit-frame-pointer