aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2009-04-07 20:15:44 +0800
committerlwhsu <lwhsu@FreeBSD.org>2009-04-07 20:15:44 +0800
commitd50a0064e3dddf113776f9c67c9825c54158d7be (patch)
treeeaf76a244a34939d9cedb98c15f19f1910491cf5 /audio
parent61c3db15ce08f89043d0ec4943716c1ab48d0f90 (diff)
downloadfreebsd-ports-gnome-d50a0064e3dddf113776f9c67c9825c54158d7be.tar.gz
freebsd-ports-gnome-d50a0064e3dddf113776f9c67c9825c54158d7be.tar.zst
freebsd-ports-gnome-d50a0064e3dddf113776f9c67c9825c54158d7be.zip
Fix building with boost 1.37:
- Add -I${LOCALBASE}/include to CPPFLAGS, so boost headers can be found by waf - Remove single header test from wscript, as it won't succeed without linking to boost_filesystem library While here, minor fixes: - Install manpages relative to PREFIX, not LOCALBASE - Some whitespace/identation nits PR: ports/132891 Submitted by: amdmi3 Approved by: maintainer timeout
Diffstat (limited to 'audio')
-rw-r--r--audio/gx2osd/Makefile10
-rw-r--r--audio/gx2osd/files/patch-src-wscript12
2 files changed, 17 insertions, 5 deletions
diff --git a/audio/gx2osd/Makefile b/audio/gx2osd/Makefile
index c968f0833163..cb066b53b0cd 100644
--- a/audio/gx2osd/Makefile
+++ b/audio/gx2osd/Makefile
@@ -8,7 +8,7 @@ PORTNAME= gx2osd
PORTVERSION= 0.2
PORTREVISION= 2
CATEGORIES= audio
-MASTER_SITES= http://eclipser.no-ip.org/
+MASTER_SITES= http://eclipser.no-ip.org/
MAINTAINER= alexbl@FreeBSD.org
COMMENT= An OSD client for XMMS2
@@ -22,15 +22,15 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libxmmsclient++.so.3:${PORTSDIR}/audio/cpp-xmms2
USE_BZIP2= yes
USE_PYTHON_BUILD= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_ENV+= WAF_HOME=.
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" WAF_HOME=.
-MAN1= gx2osd.1
+MAN1= gx2osd.1
.include <bsd.port.pre.mk>
do-configure:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./waf --conf-prefix=${LOCALBASE} --with-mandir=${LOCALBASE}/man --prefix=${PREFIX} configure
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./waf --conf-prefix=${LOCALBASE} --with-mandir=${PREFIX}/man --prefix=${PREFIX} configure
do-build:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./waf build
diff --git a/audio/gx2osd/files/patch-src-wscript b/audio/gx2osd/files/patch-src-wscript
new file mode 100644
index 000000000000..d3099fd48923
--- /dev/null
+++ b/audio/gx2osd/files/patch-src-wscript
@@ -0,0 +1,12 @@
+--- src/wscript.orig 2007-05-27 19:44:02.000000000 +0400
++++ src/wscript 2009-03-21 04:05:07.000000000 +0300
+@@ -34,9 +34,6 @@
+ libconf.name = 'boost_program_options-st'
+ libconf.run()
+
+- e.name = 'boost/filesystem/path.hpp'
+- e.run()
+-
+ libconf.mandatory = 0
+ libconf.uselib = 'filesystem'
+ libconf.name = 'boost_filesystem'