aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-05-31 01:48:24 +0800
committermarino <marino@FreeBSD.org>2014-05-31 01:48:24 +0800
commitd6658da700c576e5747643785848bd3816c2f931 (patch)
treebc57b212b1cb15c0f9efbd3a2d527838f954a630 /audio
parent75e7873cad2761975fac4e166e6ef9c7bbb5f54d (diff)
downloadfreebsd-ports-gnome-d6658da700c576e5747643785848bd3816c2f931.tar.gz
freebsd-ports-gnome-d6658da700c576e5747643785848bd3816c2f931.tar.zst
freebsd-ports-gnome-d6658da700c576e5747643785848bd3816c2f931.zip
audio/streamripper: Simplify port, reset maintainer, pet portlint
This port was using an unecessary roll-your-own extraction to control where it was extracted. Just let the standard mechanisms extract the second tarball and move in the post-extract target. Also: * minor alignment * pet portlint * reset maintainer (MIA for 16 months)
Diffstat (limited to 'audio')
-rw-r--r--audio/streamripper/Makefile16
-rw-r--r--audio/streamripper/pkg-descr2
2 files changed, 8 insertions, 10 deletions
diff --git a/audio/streamripper/Makefile b/audio/streamripper/Makefile
index c784d5d4e433..51bbc5c047a7 100644
--- a/audio/streamripper/Makefile
+++ b/audio/streamripper/Makefile
@@ -9,18 +9,17 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20%28current%29/${PORTVERSION} \
http://gd.tuwien.ac.at/hci/cdk/:cdk
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:DEFAULT \
cdk-${CDK_VERSION}.tgz:cdk
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER= sylvio@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Splits SHOUTcast stream into tracks
+LICENSE= GPLv2
+
LIB_DEPENDS= libmad.so:${PORTSDIR}/audio/libmad \
libtre.so:${PORTSDIR}/textproc/libtre
OPTIONS_DEFINE= FAAD VORBIS
-OPTIONS_DEFAULT= FAAD VORBIS
-
-LICENSE= GPLv2
+OPTIONS_DEFAULT=FAAD VORBIS
USES= iconv pkgconfig
USE_GNOME= glib20
@@ -42,20 +41,19 @@ CDK_VERSION= 5.0-20060507
.include <bsd.port.options.mk>
.if ! ${PORT_OPTIONS:MFAAD}
-CONFIGURE_ARGS+= ac_cv_lib_faad_NeAACDecDecode2=no
+CONFIGURE_ARGS+=ac_cv_lib_faad_NeAACDecDecode2=no
.else
LIB_DEPENDS+= libfaad.so:${PORTSDIR}/audio/faad
.endif
.if ! ${PORT_OPTIONS:MVORBIS}
-CONFIGURE_ARGS+= --without-ogg
+CONFIGURE_ARGS+=--without-ogg
.else
LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
.endif
post-extract:
- @cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
- ${DISTDIR}/cdk-${CDK_VERSION}.tgz ${EXTRACT_AFTER_ARGS}
+ ${MV} ${WRKDIR}/cdk-${CDK_VERSION} ${WRKSRC}
post-patch:
@${REINPLACE_CMD} -e '/if test/s|==|=|g ; \
diff --git a/audio/streamripper/pkg-descr b/audio/streamripper/pkg-descr
index 53a3e01e857a..5b3c19909466 100644
--- a/audio/streamripper/pkg-descr
+++ b/audio/streamripper/pkg-descr
@@ -4,4 +4,4 @@ separate files as they arrive, and names the files by appending
".mp3" to the name of the track. The tracks can be listened to at
the user's leisure with an MPEG Layer 3 audio player.
-WWW: http://streamripper.sourceforge.net
+WWW: http://streamripper.sourceforge.net