aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2012-06-26 04:51:35 +0800
committerjkim <jkim@FreeBSD.org>2012-06-26 04:51:35 +0800
commitd9f0b8f09a3bbbf9c3b6c7e549410bdf3c65b2ce (patch)
treec3b146a03d0af5db1edd08ba25482c7832471640 /audio
parentb3d2645aa4c11a6c15d5ad7ba0097611daecaf09 (diff)
downloadfreebsd-ports-gnome-d9f0b8f09a3bbbf9c3b6c7e549410bdf3c65b2ce.tar.gz
freebsd-ports-gnome-d9f0b8f09a3bbbf9c3b6c7e549410bdf3c65b2ce.tar.zst
freebsd-ports-gnome-d9f0b8f09a3bbbf9c3b6c7e549410bdf3c65b2ce.zip
Include bsd.port.pre.mk before SRC_BASE is referenced.
PR: ports/169212
Diffstat (limited to 'audio')
-rw-r--r--audio/oss/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/audio/oss/Makefile b/audio/oss/Makefile
index 76a8b60bf148..f47e0e84ead4 100644
--- a/audio/oss/Makefile
+++ b/audio/oss/Makefile
@@ -55,10 +55,6 @@ PROTO_SBINDIR= ${PROTO_DIR}/usr/sbin
PROTO_MANDIR= ${PROTO_DIR}/usr/share/man
PROTO_OSSLIBDIR=${PROTO_DIR}${PREFIX}/lib/oss
-.if !exists(${SRC_BASE}/sys/Makefile)
-IGNORE= requires kernel source to be installed
-.endif
-
CONFIGURE_ENV= HOSTCC="${CC}"
OPTIONS_DEFINE= VORBIS
@@ -71,6 +67,12 @@ LIB_DEPENDS+= vorbisfile.6:${PORTSDIR}/audio/libvorbis
CONFIGURE_ENV+= OGG_SUPPORT=YES
.endif
+.include <bsd.port.pre.mk>
+
+.if !exists(${SRC_BASE}/sys/Makefile)
+IGNORE= requires kernel source to be installed
+.endif
+
pre-patch:
${FIND} ${PATCH_WRKSRC} -name '*.man' -or \
\( -name '*.[ch]' \! -name ossmkdep.c \) | \
@@ -125,4 +127,4 @@ do-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>