aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-11-11 05:51:07 +0800
committeryuri <yuri@FreeBSD.org>2017-11-11 05:51:07 +0800
commitdee051b16783282eb8d45f386a708db1d2be9c16 (patch)
treeb13c162f700c2ecb383d1341cc5e7690dc7be043 /audio
parentc73ad2b7c4cb475d00277e37e9825119fb2b0c46 (diff)
downloadfreebsd-ports-gnome-dee051b16783282eb8d45f386a708db1d2be9c16.tar.gz
freebsd-ports-gnome-dee051b16783282eb8d45f386a708db1d2be9c16.tar.zst
freebsd-ports-gnome-dee051b16783282eb8d45f386a708db1d2be9c16.zip
New port: audio/fomp-lv2: LV2 port of the MCP, VCO, FIL, and WAH plugins by Fons Adriaensen
PR: 221494 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D12992
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/fomp-lv2/Makefile22
-rw-r--r--audio/fomp-lv2/distinfo3
-rw-r--r--audio/fomp-lv2/pkg-descr20
-rw-r--r--audio/fomp-lv2/pkg-plist23
5 files changed, 69 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 0f552943f012..ed1ef5177ae7 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -178,6 +178,7 @@
SUBDIR += fluidsynth-dssi
SUBDIR += fmit
SUBDIR += foo-yc20
+ SUBDIR += fomp-lv2
SUBDIR += forked-daapd
SUBDIR += fpc-a52
SUBDIR += fpc-mad
diff --git a/audio/fomp-lv2/Makefile b/audio/fomp-lv2/Makefile
new file mode 100644
index 000000000000..2aa20f09199a
--- /dev/null
+++ b/audio/fomp-lv2/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= fomp
+DISTVERSION= 1.0.0
+CATEGORIES= audio
+MASTER_SITES= http://download.drobilla.net/
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= LV2 port of the MCP, VCO, FIL, and WAH plugins by Fons Adriaensen
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+
+USES= pkgconfig tar:bz2 waf
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/fomp.lv2/*.so
+
+.include <bsd.port.mk>
diff --git a/audio/fomp-lv2/distinfo b/audio/fomp-lv2/distinfo
new file mode 100644
index 000000000000..01ba362495a8
--- /dev/null
+++ b/audio/fomp-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502660242
+SHA256 (fomp-1.0.0.tar.bz2) = 65a22508ed910601eb9938e9ea73c7eb5ce496a1308a70791c165b6527ec02c2
+SIZE (fomp-1.0.0.tar.bz2) = 100399
diff --git a/audio/fomp-lv2/pkg-descr b/audio/fomp-lv2/pkg-descr
new file mode 100644
index 000000000000..a4406f6402da
--- /dev/null
+++ b/audio/fomp-lv2/pkg-descr
@@ -0,0 +1,20 @@
+Fomp is an LV2 port of the MCP, VCO, FIL, and WAH plugins by Fons Adriaensen.
+
+There are 13 plugins in total: 1 auto-wah, 1 EQ, 3 chorus, 5 filters, and
+3 oscillators.
+
+The plugin implementations are identical to their LADSPA forebears, except the
+primary frequency port of oscillators and filters has been converted to Hz to
+facilitate use in any host without assuming the hidden tuning frequency of
+AlsaModularSynth. All other frequency ports remain as they were, using octaves
+for faithful Moog-like modulation.
+
+Aside from that, the main benefit of these LV2 ports is improved metadata: CV
+ports are distinguishable from audio ports, controls have units where
+applicable, documentation is built-in for display in host UIs, and so on.
+
+The oscillators and filters are mainly useful in modular synthesizers, but since
+CV ports are distinct from audio ports, they should work fine in non-modular
+hosts as well.
+
+WWW: http://drobilla.net/software/fomp
diff --git a/audio/fomp-lv2/pkg-plist b/audio/fomp-lv2/pkg-plist
new file mode 100644
index 000000000000..d25fe24a01e5
--- /dev/null
+++ b/audio/fomp-lv2/pkg-plist
@@ -0,0 +1,23 @@
+lib/lv2/fomp.lv2/autowah.so
+lib/lv2/fomp.lv2/autowah.ttl
+lib/lv2/fomp.lv2/blvco.so
+lib/lv2/fomp.lv2/cs_chorus.so
+lib/lv2/fomp.lv2/cs_chorus1.ttl
+lib/lv2/fomp.lv2/cs_chorus2.ttl
+lib/lv2/fomp.lv2/cs_phaser.so
+lib/lv2/fomp.lv2/cs_phaser1.ttl
+lib/lv2/fomp.lv2/cs_phaser1_lfo.ttl
+lib/lv2/fomp.lv2/filters.so
+lib/lv2/fomp.lv2/manifest.ttl
+lib/lv2/fomp.lv2/mvchpf1.ttl
+lib/lv2/fomp.lv2/mvchpf24.so
+lib/lv2/fomp.lv2/mvclpf1.ttl
+lib/lv2/fomp.lv2/mvclpf2.ttl
+lib/lv2/fomp.lv2/mvclpf24.so
+lib/lv2/fomp.lv2/mvclpf3.ttl
+lib/lv2/fomp.lv2/mvclpf4.ttl
+lib/lv2/fomp.lv2/parametric1.ttl
+lib/lv2/fomp.lv2/pulse_vco.ttl
+lib/lv2/fomp.lv2/rec_vco.ttl
+lib/lv2/fomp.lv2/saw_vco.ttl
+lib/lv2/fomp.lv2/triple_chorus.ttl