aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-02-02 22:20:18 +0800
committernork <nork@FreeBSD.org>2003-02-02 22:20:18 +0800
commite17afca8fa4663ef21b661175a1cf6401afe9ef7 (patch)
tree95858c01a3cf8f863c1683c5a0abfd18d5919882 /audio
parentb1243b199588991cab76bcdf203002be8debf1b8 (diff)
downloadfreebsd-ports-gnome-e17afca8fa4663ef21b661175a1cf6401afe9ef7.tar.gz
freebsd-ports-gnome-e17afca8fa4663ef21b661175a1cf6401afe9ef7.tar.zst
freebsd-ports-gnome-e17afca8fa4663ef21b661175a1cf6401afe9ef7.zip
Conditionalize libgnugetopt dependencies.
PR: ports/47745 Submitted by: Ports Fury
Diffstat (limited to 'audio')
-rw-r--r--audio/speex-devel/Makefile14
-rw-r--r--audio/speex/Makefile14
2 files changed, 20 insertions, 8 deletions
diff --git a/audio/speex-devel/Makefile b/audio/speex-devel/Makefile
index c24e5db1a7a9..4c0dcd41ef3d 100644
--- a/audio/speex-devel/Makefile
+++ b/audio/speex-devel/Makefile
@@ -15,19 +15,25 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/beta/}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg
USE_REINPLACE= yes
USE_LIBTOOL= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
MAN1= speexdec.1 speexenc.1
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.if !exists(/usr/include/getopt.h)
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LDFLAGS+= -lgnugetopt
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|doc win32|win32|g ; \
diff --git a/audio/speex/Makefile b/audio/speex/Makefile
index c24e5db1a7a9..4c0dcd41ef3d 100644
--- a/audio/speex/Makefile
+++ b/audio/speex/Makefile
@@ -15,19 +15,25 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/beta/}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg
USE_REINPLACE= yes
USE_LIBTOOL= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
MAN1= speexdec.1 speexenc.1
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.if !exists(/usr/include/getopt.h)
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LDFLAGS+= -lgnugetopt
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|doc win32|win32|g ; \