aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-05-04 01:49:52 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-05-04 01:49:52 +0800
commite51592f3dae56aab19026db05bdc288242254bb0 (patch)
treec7dd8ebd5045cf9062fa64a0b055f2e971a57378 /audio
parent6bae6b1779ea92266b7261903bd539f5c52b7c33 (diff)
downloadfreebsd-ports-gnome-e51592f3dae56aab19026db05bdc288242254bb0.tar.gz
freebsd-ports-gnome-e51592f3dae56aab19026db05bdc288242254bb0.tar.zst
freebsd-ports-gnome-e51592f3dae56aab19026db05bdc288242254bb0.zip
OAML is a library the makes it easy to implement adaptive music in
games. Adaptive music, also known as interactive music or dynamic music, is music that reacts to what's happening on the video game. For example, if there is a battle going on, music will get more tense to stimulate the player's reaction to the battle. WWW: https://oamldev.github.io/
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile3
-rw-r--r--audio/oaml/Makefile36
-rw-r--r--audio/oaml/distinfo3
-rw-r--r--audio/oaml/files/patch-CMakeLists.txt11
-rw-r--r--audio/oaml/files/patch-cmake_modules_FindVorbisFile.cmake56
-rw-r--r--audio/oaml/pkg-descr9
-rw-r--r--audio/oaml/pkg-plist7
7 files changed, 124 insertions, 1 deletions
diff --git a/audio/Makefile b/audio/Makefile
index ffd0c7d64e44..7b96f2a60eba 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -515,8 +515,8 @@
SUBDIR += minitunes
SUBDIR += mixer.app
SUBDIR += mixmos
- SUBDIR += mixxx20
SUBDIR += mixxx
+ SUBDIR += mixxx20
SUBDIR += mma
SUBDIR += moc
SUBDIR += modplugplay
@@ -577,6 +577,7 @@
SUBDIR += nosefart
SUBDIR += nspmod
SUBDIR += nuvolaplayer
+ SUBDIR += oaml
SUBDIR += ocp
SUBDIR += ogg2mp3
SUBDIR += openal
diff --git a/audio/oaml/Makefile b/audio/oaml/Makefile
new file mode 100644
index 000000000000..85cac30e4f39
--- /dev/null
+++ b/audio/oaml/Makefile
@@ -0,0 +1,36 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= oaml
+PORTVERSION= 1.3.2
+DISTVERSIONPREFIX= v
+CATEGORIES= audio
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Open Adaptive Music Library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+LIB_DEPENDS= libogg.so:audio/libogg \
+ libvorbis.so:audio/libvorbis \
+ libvorbisfile.so:audio/libvorbis
+
+USE_GITHUB= yes
+GH_ACCOUNT= oamldev
+
+USES= cmake
+CMAKE_ARGS= -DENABLE_UNITYPLUGIN:BOOL=OFF
+
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS SOXR
+OPTIONS_DEFAULT= SOXR
+SOXR_LIB_DEPENDS= libsoxr.so:audio/libsoxr
+SOXR_CMAKE_BOOL= ENABLE_SOXR
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/audio/oaml/distinfo b/audio/oaml/distinfo
new file mode 100644
index 000000000000..422f5465ac5b
--- /dev/null
+++ b/audio/oaml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1524750684
+SHA256 (oamldev-oaml-v1.3.2_GH0.tar.gz) = 98713d442552c1ac7c9dfa7f5183302ec5967b0e8df6b791ce36f453bacea4ce
+SIZE (oamldev-oaml-v1.3.2_GH0.tar.gz) = 155490
diff --git a/audio/oaml/files/patch-CMakeLists.txt b/audio/oaml/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..d86cd9f0deb8
--- /dev/null
+++ b/audio/oaml/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2018-04-16 17:54:59 UTC
++++ CMakeLists.txt
+@@ -176,7 +176,7 @@ if (ENABLE_RTAUDIO)
+
+ # JACK supported on many Unices
+ if (UNIX)
+- find_library(JACK_LIB jack)
++ #find_library(JACK_LIB jack)
+ if (JACK_LIB)
+ list(APPEND OAML_LIBS ${JACK_LIB})
+ add_definitions(-D__UNIX_JACK__)
diff --git a/audio/oaml/files/patch-cmake_modules_FindVorbisFile.cmake b/audio/oaml/files/patch-cmake_modules_FindVorbisFile.cmake
new file mode 100644
index 000000000000..06830a5baae0
--- /dev/null
+++ b/audio/oaml/files/patch-cmake_modules_FindVorbisFile.cmake
@@ -0,0 +1,56 @@
+--- cmake/modules/FindVorbisFile.cmake.orig 2018-04-16 17:54:59 UTC
++++ cmake/modules/FindVorbisFile.cmake
+@@ -13,53 +13,14 @@
+
+ FIND_PATH(VORBISFILE_INCLUDE_DIRS
+ vorbis/vorbisfile.h
+- HINTS
+- $ENV{VORBISDIR}
+- $ENV{VORBIS_PATH}
+- PATH_SUFFIXES include
+- PATHS
+- ~/Library/Frameworks
+- /Library/Frameworks
+- /usr/local
+- /usr
+- /sw # Fink
+- /opt/local # DarwinPorts
+- /opt/csw # Blastwave
+- /opt
+ )
+
+ FIND_LIBRARY(VORBISFILE_LIBRARIES
+ NAMES vorbisfile
+- HINTS
+- $ENV{VORBISDIR}
+- $ENV{VORBIS_PATH}
+- PATH_SUFFIXES win32/VorbisFile_Dynamic_Release lib
+- PATHS
+- ~/Library/Frameworks
+- /Library/Frameworks
+- /usr/local
+- /usr
+- /sw
+- /opt/local
+- /opt/csw
+- /opt
+ )
+
+ FIND_LIBRARY(VORBISFILE_LIBRARIES_DEBUG
+ NAMES VorbisFile_d
+- HINTS
+- $ENV{VORBISDIR}
+- $ENV{VORBIS_PATH}
+- PATH_SUFFIXES win32/VorbisFile_Dynamic_Debug lib
+- PATHS
+- ~/Library/Frameworks
+- /Library/Frameworks
+- /usr/local
+- /usr
+- /sw
+- /opt/local
+- /opt/csw
+- /opt
+ )
+
+ SET(VORBISFILE_FOUND "NO")
diff --git a/audio/oaml/pkg-descr b/audio/oaml/pkg-descr
new file mode 100644
index 000000000000..16529abc4869
--- /dev/null
+++ b/audio/oaml/pkg-descr
@@ -0,0 +1,9 @@
+OAML is a library the makes it easy to implement adaptive music in
+games.
+
+Adaptive music, also known as interactive music or dynamic music,
+is music that reacts to what's happening on the video game. For
+example, if there is a battle going on, music will get more tense
+to stimulate the player's reaction to the battle.
+
+WWW: https://oamldev.github.io/
diff --git a/audio/oaml/pkg-plist b/audio/oaml/pkg-plist
new file mode 100644
index 000000000000..c51716d20588
--- /dev/null
+++ b/audio/oaml/pkg-plist
@@ -0,0 +1,7 @@
+include/oaml.h
+lib/cmake/oaml/oaml.cmake
+lib/liboaml.a
+lib/liboaml.so
+lib/liboaml.so.1
+lib/liboaml.so.1.3.2
+libdata/pkgconfig/oaml.pc