aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-10-21 22:54:12 +0800
committerwg <wg@FreeBSD.org>2013-10-21 22:54:12 +0800
commite98a0b1b20427498b6ada392c61f50d748b0a7ca (patch)
treed8cb81652914684ff7185d8630f9e4fd52442dec /audio
parent33d06f6eae7f02f75d228fd06b62561a69008ee1 (diff)
downloadfreebsd-ports-gnome-e98a0b1b20427498b6ada392c61f50d748b0a7ca.tar.gz
freebsd-ports-gnome-e98a0b1b20427498b6ada392c61f50d748b0a7ca.tar.zst
freebsd-ports-gnome-e98a0b1b20427498b6ada392c61f50d748b0a7ca.zip
audio/acoustid-fingerprinter: link against ffmpeg-2
- Link against ffmpeg-2 - Remove ffmpeg prefix patch Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'audio')
-rw-r--r--audio/acoustid-fingerprinter/Makefile10
-rw-r--r--audio/acoustid-fingerprinter/files/patch-cmake__modules__FindFFmpeg.cmake47
-rw-r--r--audio/acoustid-fingerprinter/files/patch-decoder.h13
3 files changed, 18 insertions, 52 deletions
diff --git a/audio/acoustid-fingerprinter/Makefile b/audio/acoustid-fingerprinter/Makefile
index 74487cf181e6..d880dcba646b 100644
--- a/audio/acoustid-fingerprinter/Makefile
+++ b/audio/acoustid-fingerprinter/Makefile
@@ -2,7 +2,7 @@
PORTNAME= acoustid-fingerprinter
PORTVERSION= 0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://bitbucket.org/acoustid/${PORTNAME}/downloads/ \
http://cloud.github.com/downloads/lalinsky/${PORTNAME}/
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libchromaprint.so:${PORTSDIR}/audio/chromaprint \
libtag.so:${PORTSDIR}/audio/taglib \
- libavcodec${FFMPEG_SUFFIX}.so:${PORTSDIR}/multimedia/ffmpeg${FFMPEG_SUFFIX}
+ libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
USES= cmake
USE_QT4= gui network \
@@ -22,12 +22,12 @@ USE_QT4= gui network \
INSTALLS_ICONS= yes
FETCH_ARGS= -Fpr
-CMAKE_ARGS= -DFFMPEG_SUFFIX:STRING=${FFMPEG_SUFFIX}
-FFMPEG_SUFFIX?= 1
post-patch:
- ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/cmake/modules/*.cmake
+ @${REINPLACE_CMD} -e 's,CodecID,AVCodecID,g' \
+ ${WRKSRC}/ffmpeg/audioconvert.h
post-install:
.for i in 16 24 32 48 128 256
diff --git a/audio/acoustid-fingerprinter/files/patch-cmake__modules__FindFFmpeg.cmake b/audio/acoustid-fingerprinter/files/patch-cmake__modules__FindFFmpeg.cmake
deleted file mode 100644
index abffc7cb9cf0..000000000000
--- a/audio/acoustid-fingerprinter/files/patch-cmake__modules__FindFFmpeg.cmake
+++ /dev/null
@@ -1,47 +0,0 @@
---- ./cmake/modules/FindFFmpeg.cmake.orig 2012-09-05 18:05:36.000000000 +0000
-+++ ./cmake/modules/FindFFmpeg.cmake 2013-03-24 22:35:28.751290553 +0000
-@@ -39,16 +39,16 @@
- /opt/include
- /usr/freeware/include
- NO_DEFAULT_PATH
-- PATH_SUFFIXES ffmpeg
-+ PATH_SUFFIXES ffmpeg${FFMPEG_SUFFIX}
- DOC "Location of FFMPEG Headers"
- )
- FIND_PATH(FFMPEG_${varname}_INCLUDE_DIRS lib${shortname}/${headername}
-- PATH_SUFFIXES ffmpeg
-+ PATH_SUFFIXES ffmpeg${FFMPEG_SUFFIX}
- DOC "Location of FFMPEG Headers"
- )
-
- FIND_LIBRARY(FFMPEG_${varname}_LIBRARIES
-- NAMES ${shortname}
-+ NAMES ${shortname}${FFMPEG_SUFFIX}
- PATHS
- ${FFMPEG_ROOT}/lib
- $ENV{FFMPEG_DIR}/lib
-@@ -63,11 +63,12 @@
- /opt/csw/lib
- /opt/lib
- /usr/freeware/lib64
-+ PATH_SUFFIXES ffmpeg${FFMPEG_SUFFIX}
- NO_DEFAULT_PATH
- DOC "Location of FFMPEG Libraries"
- )
- FIND_LIBRARY(FFMPEG_${varname}_LIBRARIES
-- NAMES ${shortname}
-+ NAMES ${shortname}${FFMPEG_SUFFIX}
- DOC "Location of FFMPEG Libraries"
- )
-
-@@ -77,6 +78,10 @@
-
- ENDMACRO(FFMPEG_FIND)
-
-+if (NOT DEFINED FFMPEG_SUFFIX)
-+ set(FFMPEG_SUFFIX 1)
-+endif ()
-+
- SET(FFMPEG_ROOT "$ENV{FFMPEG_DIR}" CACHE PATH "Location of FFMPEG")
-
- # find stdint.h
diff --git a/audio/acoustid-fingerprinter/files/patch-decoder.h b/audio/acoustid-fingerprinter/files/patch-decoder.h
new file mode 100644
index 000000000000..e1d52b050f75
--- /dev/null
+++ b/audio/acoustid-fingerprinter/files/patch-decoder.h
@@ -0,0 +1,13 @@
+--- decoder.h.orig 2013-10-21 12:47:16.077685162 -0200
++++ decoder.h 2013-10-21 12:47:47.588683149 -0200
+@@ -35,6 +35,10 @@
+ }
+ #include "fingerprintcalculator.h"
+
++#ifndef AVCODEC_MAX_AUDIO_FRAME_SIZE
++#define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000 // 1 second of 48khz 32bit audio
++#endif
++
+ #if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(52, 64, 0)
+ #define AV_SAMPLE_FMT_S16 SAMPLE_FMT_S16
+ #endif